Hello Guest it is October 18, 2019, 10:49:46 PM

Author Topic: Mach4 Printer Port Discussions  (Read 897550 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach4 Printer Port Discussions
« Reply #1040 on: June 18, 2016, 08:24:15 PM »
I think i can disable the charge pump and run with out it, but i know nothing will run with out a enable signal on pin 14 all drives are daisy chained internally in the board.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1041 on: June 19, 2016, 06:50:49 AM »
Funny, in those docs it tells you the 4th axis is available if the charge pump is turned off.. but doesnt tell you how to turn it off..

  Anyway, if your sure the charge pump isnt happening, then probably best to troubleshoot that.
In darwin, there is a reset on the ports page to put darwin out of any estop it may be in... us that first
so that darwin is not in ready state,m if it wont come out of Estop, then check the Estop input isnt inverted
or something, Reset should work and turn the system green to go.

   Next, check that charge pump, it should as you saw turn yellow if set to a frequency output, test it at 12.5Khz and also at 25Khz..
or a few others... some boards are very sensitive to frequency so maybe its pulsing too fast for it.. or too slow..

See if any of that gets the board to reset properly..

Art
 

Re: Mach4 Printer Port Discussions
« Reply #1042 on: June 19, 2016, 04:36:40 PM »
I have talked to several others , with this B/O board and they tell me mach 4 is not able to turn on the driver to the e stop relay built into the board and with out that signal nothing will work on the outputs.
  Sooo i think i am screwed at this point ,i will go back to mach 3 on my lathe .

  I abandoned Mach on the mill to another program with a either net board ,and all i had to do was import my mach xml and wang bang i was up and going ,i do not think that Mach 4 is going to work for me right now ,maybe in the future ,at this point i will ask for my money back and go somewhere else for my needs .

Until this system can be proven ,and gets much more easier to configure , because this thing is a night mare.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1043 on: June 19, 2016, 08:58:11 PM »
I would have thought the Estop relay was triggered by the ChargePump, Im not sure why it cant trigger it, should be just a matter of finding
the correct frequency for it.. If Mach3 can drive it, I suspect M4 can, but it may be hard tyo figure the exact settings to do so.
Sorry it was so difficult..

Art
 

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1044 on: June 20, 2016, 07:19:22 AM »
set the machine enable pin it's under outputs that one got me with the ESS with the bob I have connected to it, for the life of me I could not get it to work then as a stab in the dark I set the machine enable output as the enable (output 1) and bugger me it worked .

so try pin 14 on the machine enable, rember to set it in Darwin with a name you wont forget like machine enable, mine was output 1 what was pin 17 so I named it enable, then in M4 it just was tick (devices) for you Darwin, output name, what you called it in Darwin

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1045 on: June 20, 2016, 10:59:48 AM »
Yeah, that sounds better. If Mach3 can run a breakout baord, there really isnt any reason I can see why
Mach4 can't. Darwin will turn on any signal thats set. Charge pump is automatic if turned on, so an enable
really makes sense.
  As the Dude says.. thats the correct way to trip an enable signal..

Art

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1046 on: June 20, 2016, 05:10:10 PM »
it was a new thing they added Art around 2.294.
Re: Mach4 Printer Port Discussions
« Reply #1047 on: October 26, 2016, 11:51:07 PM »
Mach4 has given me this message:
Darwin license has failed with-11
I am trying to configure and get my momus machine working (which I did not build).
What I HAVE done is... receive the licence file from Artsoft.
Copy and paste into license folder.
Darwin shows in the plugin folder in Mach4 and I have configures it.
I have no action from the machine in jogging mode. I have not tried a file yet.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1048 on: October 27, 2016, 08:24:43 AM »
Hi:

   Put your license file on the desktop, and ask Mach4 to import the license. See if that helps. Im pretty sure the -11 is a license error..

Art
Re: Mach4 Printer Port Discussions
« Reply #1049 on: October 27, 2016, 02:50:57 PM »
Art
do you mean
mach4/config/plugins/add?