Hello Guest it is December 12, 2019, 10:53:20 AM

Author Topic: Mach4 Printer Port Discussions  (Read 917672 times)

0 Members and 1 Guest are viewing this topic.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #280 on: August 13, 2014, 11:01:06 AM »
By the way ...

 On this version I have confirmed by scope the PWM at 50hz from power 0 - 100% , the frequency outputs for spindleor general output as accruate to the
entered setting. Other then the oddity that you have to enter 1/2 base required into the pwm freq, all seems well.
  Ive been foole don the meory loss before , so please let me know if you lose your motors again, Ive run over 25 times with no loss so it looks
good.

Art

Offline Sage

*
  •  365 365
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #281 on: August 13, 2014, 02:40:20 PM »
Hi Art:

Should the new Darwin 12a show up as a different version in the water fall display page? (old one 1.09 1.08) ?

Sage

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #282 on: August 13, 2014, 02:50:07 PM »
Sage:

 You should see 1.1 and 1.08. The 1.1 comes from replacing the darwin.dll in the Mach4 folder, and the 1.08 is the driver itself..

Art

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #283 on: August 13, 2014, 02:54:16 PM »
Sage:

  I double checked to be sure, and the dll is out of date slightly. the only change is some text on the outputs tab to warn
a user to use 1/2f for PWM base setting. Other than that function should be the same. Ill post new one here but updating
probably isnt necessary till next time..

Art

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #284 on: August 13, 2014, 03:24:00 PM »
Tweaky:

  Slowly getting the laser built. :)

http://plus.google.com/u/0/+ArthurFenerty/posts/FhMxe9dgwMx?pid=6047131578158603650&oid=118339423221700707274

Dunno if that link works or not.. :)

Art

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #285 on: August 13, 2014, 03:35:04 PM »
link works,it looks very fast I will test new release of Darwin in a couple of hour's. I still have problem with macros I have to delete M3, M4, M5 before i can get the spindle to run from code or MDI.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #286 on: August 13, 2014, 03:44:52 PM »
Thats very strange. I dont have to delete anything, but I do need to set a S word.. Defaults to zero..

Your using PWM right?

Art
Re: Mach4 Printer Port Discussions
« Reply #287 on: August 13, 2014, 05:59:14 PM »
Hey Art any ideas why on the Darwin configuration I can't type the letter "B"?

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #288 on: August 13, 2014, 06:00:23 PM »
yes pwm if I type M3S5000 or what ever into mdi it does not work same goes for if its in a gcode no workey.
but button screen works.
I have removed macros i can use mdi and gcode to turn spindle on and screen button but no speed change its still just on or off.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #289 on: August 13, 2014, 06:14:15 PM »
Dan:

   Ahh, Ive been using the button. Ill check M3's and see why it wont work..

 -

Letter B wont type? --- Ill check it out..

Art