Hello Guest it is August 23, 2019, 03:25:40 AM

Author Topic: Mach4 Printer Port Discussions  (Read 889028 times)

0 Members and 1 Guest are viewing this topic.

Offline Sage

*
  •  365 365
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #870 on: October 26, 2015, 07:28:17 PM »
If you have pulses on pin2 (I assume you mean the parallel port) then that is already after Darwin so it must be working. Darwin is what it driving the Parallel port pins.
 So, likely your BOB is not passing the pulses along to the stepper driver. Have you configured a "direction pin" for the axis? Might also be a pulse polarity issue?
 Also does your BOB require an enable signal and/or charge pump.
A step by step description of what you HAVE done would be helpful for others to help you troubleshoot.
That's all I can think of off the top.

Sage
Re: Mach4 Printer Port Discussions
« Reply #871 on: October 26, 2015, 08:51:24 PM »
I'm running Mach4 on a laptop with Windows 7; I have purchased and installed the licenses for Mach4 and the Darwin Parallel Port Plugin.  I downloaded the latest plugin for Darwin, 2762, and ran the DarwinTest.exe and it Failed.  If you encountered this issue the only guidance under the installation instructions stated "If it fails to load you need to load the driver manually from this folder as in Mach3 with the old driver."  I never owned Mach3 so I downloaded the manual for it and the instructions to manually load the driver must be for XP or later because you cannot use these instructions for Windows 7.  Can someone please provide me the corrective action for this issue?  Also, I am not a real tech savvy guy so if you could break it down "Barney Style" for me I would greatly appreciate it.  Thanks in advance!!

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #872 on: October 26, 2015, 09:45:02 PM »
Monito:

   SO if you enter Darwins configuration and try to jog , can you make the DRO count? In Mach4 does the DRO count ?

Art

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #873 on: October 26, 2015, 09:49:24 PM »
Hi Ben:

  Is this a Win7, 32 bit or Win7 64 bit system? Darwin does not work on 64 bit systems. If you use the Win7 control panel you can get to the
Device manager, you want to check ( if this is a 32 bit system) is there an entry for Mach Pulseing engine showing a driver for Mach4 is
loaded?
   When you run the installer for Mach4, did you run it as admin? If not, Id try that first. It may be the installer needed higher
permissions to install the driver.

Art

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #874 on: October 27, 2015, 01:09:35 AM »
hi art its the openGl what is makeing M4 not run it`s just to old to update the graphics drivers.

DanL
Re: Mach4 Printer Port Discussions
« Reply #875 on: October 27, 2015, 08:20:19 AM »
Hello Art, thanks for such a quick response.  The Windows 7 I'm operating is 32 bit.  I checked the Device Manager and it does not have the entry for Mach Pulseing engine; I also checked under User Account and I am logged in as the administrator.  I went ahead and uninstalled and then reinstalled Mach4 and the option to install as admin was given.  So I'm assuming that it was installed as admin, but you know what they say about assumptions.  After re-installation with licenses loaded the results were the same; "Darwin Driver Installation Failed".  Thanks again for helping me troubleshoot.

Ben

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #876 on: October 27, 2015, 08:43:17 AM »
Ben:

   Yes, sounds like it doesnt want to install the driver. Heres a manual method, though not all systems will do it..

First, open the device manager.
Select the top of the tree and right click it, select "Add legacy hardware". hit "next"
Select "Install hardware I manually select.
Select Show All Device, click next
Select "Have disk"
Browse to C:\Mach4\Plugins\Darwin Driver
The file DarWin.inf should show up, select it..
Select OK and hold your breath.. if it works you should now be able to
run the DriverTest.exe and see the pulser work. If it doesnt work we
will all cease to exist in this dimension and no-one will ever know, though
nonsentient clones of ourselves will still be here to read your responce.

Art


Re: Mach4 Printer Port Discussions
« Reply #877 on: October 27, 2015, 08:42:59 PM »
Art:

You, Sir, are a genius; I got it installed and DarvinTest ran successfully.  Now I have a new challenge for you...  I continued with the instructions that came with Darwin2762;  copied and paste the drivers to the appropriate folders without Mach4 running, but once I run Mach4 they are not loading.  I doubled and tripled checked the folders and ran Mach4 again and they still do not load under Mach4/Config/Plugins.  Also, the only option I'm given for Select Motion Device is the Simulation Device.  Thanks again for your time.  I can't thank you enough for you help!!

Ben     

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #878 on: October 27, 2015, 09:01:36 PM »
try starting as admin that does help, if you are going to run Darwin remove the sim plugs you don't needed them

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #879 on: October 27, 2015, 09:13:42 PM »
Hi:

 Make sure mcDarwin.m4pw and mcDarwin.sig are in the c:\Mach4\Plugins folder..

Art