Hello Guest it is August 20, 2019, 01:01:37 PM

Author Topic: Mach4 Printer Port Discussions  (Read 886596 times)

0 Members and 1 Guest are viewing this topic.

Offline Sage

*
  •  365 365
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #630 on: November 19, 2014, 03:37:58 PM »
Since you apparently have that fancy interface board :-) maybe you have an LED or something on the PP signal (pin 17 I think). If not I can get the scope out open up my controller and have a look. In any case no rush. I'm not using it anyway.


>> Edit <<
On second thought I guess checking it on the PP cable would be useless. That's after Darwin. I guess it's up to you.
No rush.

Thanks

Sage
« Last Edit: November 19, 2014, 03:42:20 PM by Sage »

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #631 on: December 11, 2014, 12:22:48 PM »
Hi All:

  Here is a version of Darwin for the recenly released 2138 lversion of Mach. My appologies for the delay,
I wasnt aware of any issue in regards to running in 2138, but I hear someone is having a problem, so here is a
version for 2138, the official download will follow soon.

Art

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #632 on: December 11, 2014, 01:20:57 PM »
And here, just in case 2157 is delayed, is a copy in advance for version 2157 when released.

Art

Offline Tweakie.CNC

*
  • *
  •  7,884 7,884
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach4 Printer Port Discussions
« Reply #633 on: December 12, 2014, 01:46:00 AM »
Thanks Art for posting Darwin v.2157.

Mach4 v.2157 has now been posted on the web site.

( The site managed to keep in step for a while (Mach4 / Darwin versions) but that seems to have lapsed.  :(  )

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #634 on: December 12, 2014, 07:59:29 AM »
Hi Tweak:

 Apparently Brian was on the road and he makes the installs, so things got a touch out of sync. Often it doesnt matter, this time
it unfortunately did. :)

Art
Re: Mach4 Printer Port Discussions
« Reply #635 on: December 18, 2014, 08:17:44 PM »
Well, in the last 48 hours I have become pretty familiar with rereredoing things.  (BTW Art - Darwin installs files 1 directory too deep for Mach4 to find). 

I have a StarTech PCI add on parallel port in an old Compaq machine running Win XP SP3.  I can drill via Start/ Control panel/ System/ Hardware tab/ Device Mgr/ Ports/ PCI Parallel (LPT1)/ Propertys/ Resources to get my Hex address (AC00),...

then I can open Mach4/ Configure/ Plugins where I activate Darwin, then configure it (my pulse waterfall looks fine - even at the 75K limit). 

On port 1 I tell it the address (which it immediately revises to "0Xac00"), and I enable it. 

Then on the Motor Config tab I set the port/ pin data & enable the first three (Art - why does the motor selection come up highlighted, but it does not save feeble attempts to rename them?). 

Then on the Input Siganl tab, I change Signals 3,4 & 5 to Home X, Y & Z respectively.  Then I wander thru the other tabs looking for some rock I didn't reset.

Then it does not work.  Then I test it with a multimeter to prove it's still not working.  Then I reinstall the driver, take a nap, and start again. 

The one ray of sunshine is that when futzing with the port settings tab in the properties dialog, if I change the inerupt settings & save, the only motor I have set up (X) turns a few degrees.  Were it not for this, I would be a COMPLETE failure.

Is my error obvious?  Please & one thousand Thanks Yous.

OB

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #636 on: December 18, 2014, 08:56:15 PM »
Hi Bruce(other) :)

>>Well, in the last 48 hours I have become pretty familiar with rereredoing things.  (BTW Art - Darwin installs files 1 directory too deep for Mach4 to find).

  Thx, I will check that, Brian makes the installs so Ill ask him to redo it if it installs wrong on mine.

>>I have a StarTech PCI add on parallel port in an old Compaq machine running Win XP SP3.  I can drill via Start/ Control panel/ System/ Hardware tab/ Device Mgr/ Ports/ PCI Parallel (LPT1)/ Propertys/ Resources to get my Hex address (AC00),...

 Sounds right.

>>then I can open Mach4/ Configure/ Plugins where I activate Darwin, then configure it (my pulse waterfall looks fine - even at the 75K limit). 

 Sounds good as well.

>>On port 1 I tell it the address (which it immediately revises to "0Xac00"), and I enable it. 

 Good.

>>Then on the Motor Config tab I set the port/ pin data & enable the first three (Art - why does the motor selection come up highlighted, but it does not save feeble attempts to rename them?). 

  Are you running this config from inside Mach4? Darwins config will only be remembered if run from the Mach3 setup menu..
If Im undertsanding you, its because you cannot rename motors. They remain as motor0, 1 2 ..etc.. Otherwise confusion could get bad between m4 and darwin as m4 considers many things
in terms of motor number.

>>Then on the Input Siganl tab, I change Signals 3,4 & 5 to Home X, Y & Z respectively.  Then I wander thru the other tabs looking for some rock I didn't reset.
>>Then it does not work.  Then I test it with a multimeter to prove it's still not working.  Then I reinstall the driver, take a nap, and start again. 

   If you press on a home switch does it show up on the ports page as raw port data toggleing? If, for example the home X is on pin 10, does pin 10 toggle in the raw data wniow when you press
that switch? Best to make sure the port address is OK by checking a ouple of inputs. Check they toggle the LEDs when you press them on the ports page. Then, if that works the port is ok, so check the
state LED on the actual input pin setup, does that toggle? Let me know where the failure is at.

>>The one ray of sunshine is that when futzing with the port settings tab in the properties dialog, if I change the inerupt settings & save, the only motor I have set up (X) turns a few degrees.  Were it not for this, I would be a COMPLETE failure.

  I take it this is in some dialog for the printer port card? Darwin doesnt set interrupts so I imagein this is some setting of the card?

Let me know and we'll see how it reacts..
Art

 
Re: Mach4 Printer Port Discussions
« Reply #637 on: December 19, 2014, 12:52:39 AM »
Thanks for the reply Art!

>Are you running [Darwin] config from inside Mach4?... only be remembered if run from the Mach...
Yes, because when I did it in the install setup they didn't hold <g>

>>Then on the Input Signal tab...Then it does not work....
>If you press on a home switch
OK, your forcing my hand.... I thought I might come off as literate in that first message, but now I have to admit I don't know where there is a home switch.  Everything I am doing is in the jog tab.  I actually just looked for a home button & could not find one.  I am setting in the living room, with one motor hooked up to one power supply, one driver, and a BOB with only a 5 loose wire attached.  My goal is to make them dance one motor at a time.... so far they're all wall flowers.

>does it show up on the ports page as raw port data toggleing?
I can't find a home button & you think I can find this? <G>  Where is the ports page?

>If, for example the home X is on pin 10, does pin 10 toggle in the raw data window
You are light days ahead of me.  Where is a raw data window?

>>if I change the inerupt settings & save, the only motor I have set up (X) turns a few degrees.
> in some dialog for the printer port card?
In one of the tabs on the port properties dialog box.

>Let me know and we'll see how it reacts.
You are a good & generous god.  Thanks Art.
Re: Mach4 Printer Port Discussions
« Reply #638 on: December 19, 2014, 04:14:49 AM »
On another item: under the Input Signal tab, you stress the signals are NOT pin numbers, OK, but what are they?  There are 15 of them,... are they unique pulse signatures?

and another - "Negated" seems to have a new meaning in CNC parlance.... is it used to mean 'reversed?'

Sorry to be needing so much education.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #639 on: December 19, 2014, 05:20:32 AM »