Hello Guest it is December 12, 2019, 11:56:55 AM

Author Topic: Mach4 Printer Port Discussions  (Read 917698 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach4 Printer Port Discussions
« Reply #800 on: August 25, 2015, 06:55:35 PM »
Hello Art

     I've just updated to Mach4 version 2 and I seen you had  DarwinSetup-V2-2611 out so i uninstalled all of Mach4 and Darwin and after I installed Mach4 version 2 and made sure it was working with new licencing I installed  DarwinSetup-V2-2611 it ran the test like previous versions of Darwin but when i started up Mach4 I received  "Failed to load shared library 'mcDarwin.m4pw' (error 0: the operation completed successfully.)  So I reinstalled all of Mach4 and Darwin three times to the same results then I installed the older   Darwin 2178  and it worked! So I need some guidance on how to get  -V2-2611 to work, I'm running windows 7 I see in previous post there were two of the same problems and tried the (VCRedist.exe) but had no luck.   

Art, thanks for all your knowledge and hard work 

cnctom  

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #801 on: August 25, 2015, 09:10:59 PM »
Hi Tom:

  Its probably because I switched to Win7 and compile it now under VS2013. Down the VCRedistX86 for vs2013 from microsoft. Run that and I think
the problem will go away.

Thx
Art
Re: Mach4 Printer Port Discussions
« Reply #802 on: August 26, 2015, 08:37:24 PM »
Art it worked updating to VCRedistX86 and now it works thank you. I've got to figure out why it's not homing when I hit reference now it says its homing but no axes are moving bummer.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #803 on: August 26, 2015, 09:17:06 PM »
Tom:

 Glad to hear. Check your homing switches are not set to inverted in mach4. They must only be inverted in Darwin if needs be. Look to the error buffer
as Darwin in debug moe will send messages to show what steps its doing in homing.

Art
Re: Mach4 Printer Port Discussions
« Reply #804 on: August 31, 2015, 10:32:56 AM »
Hi Art
I tried everything I could think of everything works but homing, I can run a program move all around but when I hit ref all it says its homing but nothing moves I guess I'll reload the old version to verify all my settings again I checked for reverse home and its all as it should be.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #805 on: August 31, 2015, 11:33:30 AM »
Hi:

  It may be thinking its done. Before yu home, are the home leds on the diags page lit up? Do they light up when you press a home switch?

Art
Re: Mach4 Printer Port Discussions
« Reply #806 on: August 31, 2015, 01:19:53 PM »
Hi Art

They are not lit up, all are red. They don't light up went hitting home switch not even when i hit the micro switch manually when in homing cycle, But on the diagnostics page the x y z light's up when manually hitting the micro switch  but don't zero out the axis,  Also when testing my axis limits they light up in  the diagnostics page and stop movement as they should, so it's my thought that it mite be on the Mach4 side of thighs because Darwin is sending the single I guess to prove it out tonight I'll load the older Mach4 version 1 to see if it will work again.     





Re: Mach4 Printer Port Discussions
« Reply #807 on: August 31, 2015, 07:35:39 PM »
Art

Its official I reinstalled  Mach4Hobby Installer-2313 using the latest DarwinSetup-V2-2611 and Homing works! So now we are still at square one witch isn't working quit right Mach4Hobby Installer-4.2.0.2660 or DarwinSetup-V2-2611  ??? I would think it would be Mach4 2660 not telling Dawin to go home even though Mach4 is saying "HOMING"  but I could be wrong. All settings are the same I take photo's of each screen as to be sure each step is the same.

Thanks for your time


Tom

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #808 on: August 31, 2015, 09:11:34 PM »
Hi Tom:

  Interesting finding. I will try homing tomorrow in 2611 and see what mine does.. It sounds like somethign changed..

 ( hmm, did you check to see if your license works with the later version of Mach4? Does is show Darwin as licensed? If not, the homing wouldnt work,
and I did hear of some licenseing issues where you needed to get a new license on latest version..

Art

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #809 on: August 31, 2015, 09:54:12 PM »

cnctom bring up logging when you hit ref all home it shows what mach is doing it help`s to nail problems down just keep a copy of it so when you try upgrading again you can compare working with not working