Hello Guest it is December 13, 2019, 01:06:20 AM

Author Topic: Mach4 Printer Port Discussions  (Read 917752 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach4 Printer Port Discussions
« Reply #900 on: December 09, 2015, 01:40:04 PM »
Hi guys,

just tried setting the look ahead to 10 then 1.

also set the steps and velocity to 1.

still no luck, it toggles the enable then gets the motion error and unset sthe enable.

Up to now i have had no movement out of the motors , as i need the enable line set.

The probe and estop input are still working fine.

Have checked  all the setup screens , its not obvious whats wrong.

Art can you send us the settings, for a one motor setup that works for you , so we can check out the settings with our system and perhaps dpot the problem..

I need pin 14 as enable, 17 charge pump pin 2 motor dir, pin3 motor step, currently i am using motor 0 , pin 15 estop input

Kind Regards

Mark

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #901 on: December 09, 2015, 02:03:24 PM »
try running M4 as admin if that dont help do a reinstall and run as admin, some people run into problems and reinstalling as admin fixes it. other than that have you just brought up darwin and see if you can jog from inside darwin.

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #902 on: December 09, 2015, 02:56:05 PM »
Settings would be meaningless Mark, but I agree with the previous suggestion, lets do this one step at a time..

Can you jog in Darwins config masks..?

Art
Re: Mach4 Printer Port Discussions
« Reply #903 on: December 10, 2015, 09:54:46 PM »
I still get "Darwin Buffer Error - Motion out of bounds" with the "Test" plugin:
- Tried enabling only 1 motor,
- Tried lowering motor speed to just 10 steps/sec
- Tried multiple Pulse Count settings.
Jogging does not work in the Darwin config for any case.
I'm using a slower machine, but my "Time in Interrupt" is still only 8-9us
-Bill
DSTechLabs.com

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #904 on: December 11, 2015, 07:56:16 AM »
Hi guys:

 I did some experimental tracing and found the buffer error CAN get mixed with a signal set in the config to any signal
which can be told to trip an Estop. If one of your inputs is set to EstopOnActive.. you could get the buffer error instead of a
simple Estop..

  Id be interested in hat this new version does for you. You need only install the .m4pw and the .sig file to test. If you find
you no longer get buffer errors, but cannot get out of Estop.. Turn off input signals in Darwins config till you no longer get Estop..

Art
Re: Mach4 Printer Port Discussions
« Reply #905 on: December 11, 2015, 01:40:08 PM »
Hi Art,

Probably me being a bit thick.

which folder do the two files need to be moved to?
 i have put them in the  c\mach4hobby\plugins\DarwinDriver folder

however theses two files did not exist in this folder.

Is this correct or is there some other location off the windows program files path?

p.s Checked , I had been running with administrator privileges.

Kind Regards

Mark

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #906 on: December 11, 2015, 02:52:17 PM »
The two files should already exist in Mach4\Plugins , replace those two , the .sig and the .m4pw

Art
Re: Mach4 Printer Port Discussions
« Reply #907 on: December 12, 2015, 11:51:25 AM »
Hi Art,got this patched.

Signal 1 emergency was causing the problem. Have turned this off in mach4 setup to, and now it seems to be ok.

The x dro can be jogged now , but still no motor output.
looking on the m4 diagnostics screen , I see the x motor light on , but no other , so i suspect we dont have any outputs working through darwin.

The probe input is still working ok.

If you like I can hook a scope onto the parrell port to check for any output.

I presume the charge pump output , should light one of the leds in the mach4 diagnostic pannel.

Kind Regards

Mark
Re: Mach4 Printer Port Discussions
« Reply #908 on: December 12, 2015, 12:09:21 PM »
Hi Art -
Thanks for looking into the "Darwin Buffer Error".
The error still occurs with the new plugin, however, a signal tripping the E-Stop definitely has something to do with it.
Playing with Darwin Emergency enable on/off, Darwin E-Stop Tri on/off and Mach4 config setting on/off DOES effect the outcome.

But configs are getting a bit much for the end user ... having now duplicate settings for Darwin and Mach4 Configs.
- What config settings are the "master settings", Darwin or Mach4?
- Which settings take precedence?
- Do they negate each other? (Darwin has a signal enabled high and Mach4 has the same signal enabled low)???
- If the Emergency Signal is enabled, shouldn't it ALWAYS trip an E-Stop (the [EStop Tri] checkbox should be checked and grayed out)?
« Last Edit: December 12, 2015, 12:18:35 PM by DSTechLabs »
-Bill
DSTechLabs.com

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #909 on: December 12, 2015, 03:07:30 PM »
All signals in Mach4 , like switches and inputs should be left Active HI. , do not set any active low. If a signal is active low, then invert it
in Darwin. Darwin sends a signal "Active", and that signal is true if the config in Darwin says it is, low or high, so Darwins setting takes
precedence over Mach4. Darwin wasn't designed for Mach4, which is why two configs exist, also when it was attached many of m4's
calls did not exist, so its using signals as it see's them.

  Set all M4 signals to Active High, then tell Darwin if high or low is "Active"..


   If the DRO's are counting, then Darwin "thinks" its sending out, so your almost there, ensure the port number is
correct, if it is, you should have step pulses, otherwise the DRO's would not count.  If one find you cannot enable  
Mach4, turn off all inputs, in Darwin and in Mach4. When your jogging Ok, then turn on one signal at a time,
first in darwin, and see if all is OK, then turn that signal on in Mach4, and see if its OK.  This will lead you
to the trouble. If a signal in Darwin is set to activate Estop it will do so without M4's help, so you should probably
make sure no signal is set to EStop on active inside Darwin except perhaps ESTOP..  Sounds like
if you follow this process, youll be OK at this point..

Art