Hello Guest it is August 20, 2019, 01:08:25 PM

Author Topic: Mach4 Printer Port Discussions  (Read 886605 times)

0 Members and 1 Guest are viewing this topic.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1010 on: May 03, 2016, 10:28:26 PM »
Kvoms profile will help Art it will show all the M4 pin states

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1011 on: May 04, 2016, 07:16:57 AM »
True, probably best just to post the profile ....

Thx Dude,
Art

Offline kvom

*
  •  37 37
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1012 on: May 04, 2016, 11:44:42 AM »
Attached are the M4 .ini. file (added txt)  and the working M3 profile.

The BOB is a C11G from CNC4PC.com.  The current model is newer but apparently is just a repacking, with the electronics being the same.  The web page for the card is http://cnc4pc.com/c11gs-multifunction-cnc-board.html

One "clue" I found is that the card has an EN External Enable pin that if not enabled with +5V causes all the outputs to go to ground.  Apparently the charge pump could be coupled to this, and if so it's being done by M3 and possibly not by M4.  I'll inquire with my machine vendor how that's configured and post up the response.

Offline kvom

*
  •  37 37
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1013 on: May 04, 2016, 12:06:34 PM »
I have jogging

Very mysterious but today I started up M4 and the Darwin configurator and noticed that the charge pump indicators were green.  Then I was able to jog all three axes in the proper directions.   ;D

However, now when I exit the Darwin configurator and click the M4 Enable button, all my BOB pin leds go off, and no keyboard jogging.

Seems like a milestone nevertheless.  Maybe the .ini file will show something I've missed in the M4 config.

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1014 on: May 04, 2016, 12:25:30 PM »
Sounds like its going into Estop in Darwin, liek the polarity is off.. In Mach4, make sure all Darwin signals in and out  are set to ActiveHi..

 If thats a problem swap them in Darwin, not in Mach4.

Art

Offline kvom

*
  •  37 37
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1015 on: May 04, 2016, 12:34:20 PM »
More progress.  Seems exiting the Darwin Configuration leaves the BOB in a stopped state, with its leds out.  However, pressing enable-disable-enable turns them on again.

I also found that I can jog in M4 with the jog window buttons, so now my next problem is why the keyboard keys don't work.

Offline kvom

*
  •  37 37
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1016 on: May 04, 2016, 01:25:45 PM »
Now I found the Keyboard Enable button on the Jog tab, and I can jog with the keyboard!

If I can get the spindle configured next I may be good to go.  In the meantime I've copied the motor tuning params from M3 and will use a DTI to see if the axis movements are still accurate.

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1017 on: May 04, 2016, 01:50:20 PM »
I think your on your way..

  Read the spindle posts on the previous posts on this thread.. they explain how a spindle connects

Art

Offline kvom

*
  •  37 37
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1018 on: May 04, 2016, 03:40:16 PM »
The axis travels seem to match commands, so it is on to the spindle.  After searching this thread and looking at the M3 spindle config, I tried the following.

Set output signals 5-7 as spindle freg, spindle fwd, spindle rev, pins 14, 2, 4 respectively.  Set frequency to 1800 on pin 14.  FWIW, it seems that output signals 1-4 have charge pump locked as their name, and any names specified for others are not saved to the profile until M4 is stopped and restarted.

Set the input signals for Spindle On, Spindle Fwd, and Spindle Rev to device Darwin and the respective signals.

However spindle does not turn on.   History states that Signal 5 turns ion and off.

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #1019 on: May 04, 2016, 03:47:16 PM »
and you mapped signal 6 to Spindle on in mach4?

(Look in the debug hsitory at turn on, darwin reports all it does when an M3 comes in. Alos, in config/Darwin, you must select frequency spindle and set the min and max frequency..

Art


Art