Hello Guest it is December 13, 2019, 08:47:06 PM

Author Topic: Mach4 Printer Port Discussions  (Read 917797 times)

0 Members and 2 Guests are viewing this topic.

Re: Mach4 Printer Port Discussions
« Reply #470 on: August 23, 2014, 05:47:41 PM »
Art,

I think that was it.... when I set the debounce for the limit switch it had no affect, but when I set it to 100 for the e-stop and referanced it maybe 20 times and it worked right every time with the limit enabled. gonna have to go through my wiring. Thanks for all your help!

Dave

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #471 on: August 23, 2014, 05:51:32 PM »
Dave:

   I think for now Id kill the X++ switch and set the home switch to Etrip. Tht way it will act as a safety unless your homing..

Im not sure why the X++ would do that as yet... but then your one of a few that home in a positive direction..Ill give it thought.

Art


Re: Mach4 Printer Port Discussions
« Reply #472 on: August 23, 2014, 06:41:30 PM »
Art,

My mistake... when I went to uncheck the debounce for the limit switch I unchecked the e-stop trip and then when I was testing it it would home everytime. I tried the debounce in both the e-stop and the limit set at 200 and it had no effect. I will do like you said. the reason I'm homing in a positive direction is because it's a Lathe with the tool post in front. I figured I made it work with Mach3 so I can make it work with this. Maybe I can't... I'm probably the only one trying to put it on a lathe right now. Thanks again for your help!

Dave

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #473 on: August 23, 2014, 08:19:31 PM »
Dave:

  As far as I know, you can turn on that x++ switch, but not set it to Estop. It will then stop motion, but position is remembered.
SO just stop the Estop portion of the limit and I think it will be fine..
Art

Offline Sage

*
  •  365 365
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #474 on: August 24, 2014, 07:00:17 PM »
I purchased the Mach4 pre-buy a week ago and got my license no problem.
I just now purchased the parallel port driver and went through almost the same process but the website automatically added Mach4 to the cart when I selected only the PP item so I removed it from the cart.
The system asked for the Machine ID again which I entered.  ???
The purchase went through for just the PP driver ($20) but I was sen another license file.
What's up with that and what do I do with it. I already have one.

Now what  :-\

Sage

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Mach4 Printer Port Discussions
« Reply #475 on: August 24, 2014, 07:02:01 PM »
Send an email to license@machsupport.com and explain the situation.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Sage

*
  •  365 365
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #476 on: August 24, 2014, 08:00:10 PM »
Will do

Thanks

Sage

Offline Racer

*
  •  16 16
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #477 on: August 25, 2014, 09:50:32 AM »
Ahh, pin 8..

 Ill run a check just to be absolutley sure ..

Art


Art:

More testing on the Y axes not working.

In Darwin Control all 4 axes setup and working (x,y,z,a)
X out to Mach 4 set everything up in Motors and Maping, did not enable.
Went back to Darwin control, all still working.
Back to Mach 4 and hit enable all work execpt Y axes on pins 8 step and 3 direction.
Go back to Darwin controal and Y not working.
The only way to get y working in Darwin Controal is Create new profile and start over.


Again Mach 3 works good on same config, same computer.
Might be a Mack 4 problem.

Thanks
Jerry

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #478 on: August 25, 2014, 10:03:34 AM »
Jerry:

  Post your machine.ini when its not working but should be. Might be some setting that Darwin is screwing up on when saving..
( Or it might be Mach4 is limited to 3 axis.. I havent used 4 yet..)


Art

Offline Racer

*
  •  16 16
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #479 on: August 25, 2014, 10:42:44 AM »
Jerry:

  Post your machine.ini when its not working but should be. Might be some setting that Darwin is screwing up on when saving..
( Or it might be Mach4 is limited to 3 axis.. I havent used 4 yet..)


Art

Had to rename the file.