Hello Guest it is August 22, 2019, 11:13:09 PM

Author Topic: Mach4 Printer Port Discussions  (Read 889004 times)

0 Members and 2 Guests are viewing this topic.

Re: Mach4 Printer Port Discussions
« Reply #520 on: October 04, 2014, 11:30:42 AM »
Art,
 Thanks for the info. I changed some hardware but didn't get my license changed yet for the new pc id I have now. so I'll get that straightened out first.

Dave
Re: Mach4 Printer Port Discussions
« Reply #521 on: October 04, 2014, 03:23:18 PM »
I can't get M4 V2030 to show as licensed.  I put the license files in the license folder and started M4.  When I load the Mach4 license file that gets generated, I get a message indicating success but also get an error message that copying the file failed but the operation was a success.  Opening the dat file shows the M4 license file was incorporated.

If I go ahead and install Darwin V2030, it seems to install okay but when I check the licensing status, the program crashes, an unhandled exception.

I've tried using the original license files I received as txt file, changed them to dat files, and made new dat files with just the license data but no change in trying to license M4.

I have not changed my system since getting my original licenses.

Anyone else having these types of problems?

Peter

Offline Tweakie.CNC

*
  • *
  •  7,885 7,885
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach4 Printer Port Discussions
« Reply #522 on: October 05, 2014, 02:16:59 AM »
Hi Peter,

As mentioned by Dave, the way in which our PC ID is calculated has now been changed so you need to contact license support for the new licenses (Mach4 & Darwin)  license@machsupport.com

Please bear in mind that the '1 axis limit' issue has yet to be resolved so we will all have wait for the next Mach4 / Darwin release to be posted.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #523 on: October 05, 2014, 07:21:41 AM »
Hi Guys:

  As Tweaky says the process has changed so the ID's may have changed, the problem with Darwins license may also necessitate
them changing yet again while the guys get the code right for this section. Id be patient and ignore the update to 2030 until this issue is resolved,
probably early this week..

Thx
Art
Re: Mach4 Printer Port Discussions
« Reply #524 on: October 05, 2014, 11:51:02 AM »
Thank you gentlemen.  I'll wait for the next release then request new licenses.

Looking forward to working with M4!

Pete

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #525 on: October 07, 2014, 06:59:45 AM »
Hi Guys

  As you get your systems running can you report here on success or failure. The license issue has been addressed and so
if you have your darwin license you should be able to run. The behavior of a nonlicensed system has been changed so that all axis
work fine, but no IO occurs. Id like to monitor how this all works though so please post both success as well as failure so I have a benchmark.

Thx
Art

PS( Here is a copy of the plugin just in case it takes Brian a while to release an update..)

Offline Tweakie.CNC

*
  • *
  •  7,885 7,885
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach4 Printer Port Discussions
« Reply #526 on: October 07, 2014, 08:41:07 AM »
Hi Art,

The new plugin appears to work just fine.
I have only tried jogging so far but will try running some Gcode later on today.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #527 on: October 07, 2014, 06:11:55 PM »
Hi art just played with M4 its all good. its a lot better than it was a couple of changes ago smother, faster and less of a drag on my computer.
Re: Mach4 Printer Port Discussions
« Reply #528 on: October 07, 2014, 08:08:04 PM »
I installed M2030 and D2035, got new licenses for both and put them in the license folder.
Darwin configured okay and I could jog all three axes and see the limit, home, probe, index, and estop inputs toggle.  However, when I tried to jog in M4, no motion.  Tripping the estop had no effect.  It seems there is no communication between M4 and Darwin.  I double checked the licenses and confirmed they are where they should be.  All three axes are set up in M4 as far as motor configuration goes and enablement.  When I try jogging in M4, the M4 DROs change as expected, but there is no motor movement.

Could this be a problem with the Darwin license?

BTW, if I try to check the motion controller selection in M4 (after having previously set it to parallel port), M4 locks up.  This is similar to what used to happen in previous versions.  I end up stopping M4 and restarting my system.

Also, M4 takes about 60 seconds to start up.  This is longer than it used to be by far.  Again, a license issue?

Thanks

Peter

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Mach4 Printer Port Discussions
« Reply #529 on: October 07, 2014, 09:11:47 PM »
Hi All:

 Heres a new version of Darwin that respects old CPU id's. Im told this is necessary for a week or so till the license generator is
updated..

  Now..as to errors. If the DRO's move, motion should occur. DRO's update only due to Darwin counting steps going out.
The license behaviour has been changed so Darwin halts motion after about 30 minutes if not licensed. Ive ask the guys
to add to m4 a license status list as I know its important to see if one is correct or not..

I still get errors in Mach4GUI in config.. but not in wxMach.. Still trying to find that ..

Art