Hello Guest it is November 12, 2019, 11:12:34 PM

Author Topic: Mach 4 Bug Reports  (Read 364392 times)

0 Members and 1 Guest are viewing this topic.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach 4 Bug Reports
« Reply #400 on: July 11, 2015, 06:12:59 PM »
 very true ger, I reproduced it hitting stop shifts the Zero over it did not happen with feed hold
« Last Edit: July 11, 2015, 06:19:15 PM by daniellyall »

Offline Pedio

*
  •  200 200
    • View Profile
Re: Mach 4 Bug Reports
« Reply #401 on: July 23, 2015, 02:03:01 PM »
Not sure if this has been reported but occasionally the display showing the tool paths that have been run by the machine does not line up with the toolpaths on the display.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Mach 4 Bug Reports
« Reply #402 on: July 24, 2015, 07:03:12 PM »
The Mach4 screen editor is crashing on an hourly basis. You never KNOW what sets it off. A lot of times it is WHEN you go to SAVE that it crashes. AND that is a real treat to endure. When it crashes it locks Windows HARD requiring you to power it down then restart.

NOT good, (;-) TP

Re: Mach 4 Bug Reports
« Reply #403 on: July 24, 2015, 07:17:01 PM »
Build 2568 introduced a bug in the core that causes random crashes.

Build 2580 has just been posted and is supposed to include a fix.

http://www.pmdx.com/Downloads_Mach4/Mach4_Hobby_Releases/
Steve Stallings
www.PMDX.com
For PMDX product support, please use PMDX forum or direct email for quickest response. We do not use this forum as our primary product support site.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Mach 4 Bug Reports
« Reply #404 on: July 27, 2015, 12:20:52 AM »
Version updates, EVERYTIME I do a version update Mach4 DUMPS OUT all my setup info . I have to start over from scratch EVERY time.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach 4 Bug Reports
« Reply #405 on: July 27, 2015, 12:33:31 AM »
yer that`s a pain fix it please

Offline smurph

*
  • *
  •  1,143 1,143
  • "That there... that's an RV."
    • View Profile
Re: Mach 4 Bug Reports
« Reply #406 on: July 27, 2015, 01:37:43 AM »
Make a copy of the Mach4Mill profile and use it instead.  That way, your settings do not get overwritten.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Mach 4 Bug Reports
« Reply #407 on: July 27, 2015, 01:28:09 PM »
V2508 seems to have helped the Random crashing. BUT it introduced another bug in the SetVN  . The SetVN is reporting an error in the G code using #vars  EVEN though it was never called to define any named Vars UNLESS there is one hiding somewhere ??  We will get a View table to be able to SEE all the Named Variables that are created/associated. This example would be a good reason to have one.


Thanks, (;-) TP

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Mach 4 Bug Reports
« Reply #408 on: July 27, 2015, 02:07:16 PM »
Another glitch in the new function that reports the tool change status to the Mach4 status line. It is NOT reporting the status of the tools correctly ALSO the wording NEXT TOOL is wrong ,  that implies that it would be the NEXT TOOL in the Gcode file. The word that is correct would be Selected Tool.

Also the message itself should be standardized as to content   Selected Tool = 1   not == . And yes I know where that comes from.

NOW IT WOULD be nice to be able to see the next tool call in the gcode stack to be called (;-)  I can do it in Mach3.

(;-) TP

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Mach 4 Bug Reports
« Reply #409 on: July 27, 2015, 02:54:59 PM »
V2580  after a random period of time the toolpath stops responding to panning. All screen views are effected.  To make it work again I have to ether reload the screenset(stock) or load another screenset and it starts workiing again. THEN it works until it stops again.

It still has NOT crashed since I loaded V2580 (;-) Even in the screen editor it has not crashed out.

(;-) TP
« Last Edit: July 27, 2015, 02:56:56 PM by BR549 »