Hello Guest it is October 14, 2019, 02:25:15 AM

Author Topic: Mach 4 Bug Reports  (Read 359483 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach 4 Bug Reports
« Reply #40 on: May 06, 2014, 01:55:04 PM »
Zorder 0 is the lowest level.  Anything with a higher Z level will be on top of the lower levels.  For example, if you have a bitmap that you wish to place a LED over, the bitmap should be Zorder 0 and the LED should be Zorder 1.

I hope that clears it up because I, like Jeff, keep getting it confused.  But I tend to be a bit lisdexic sometimes...  :)

Steve

EXCELLENT . Thanks,
Russ

How abot the following ?
M4-1754 
File Ops. buttons are "hot" while G-code file is running. Should they be disabled and maybe warn "Stop file before ......" like Mach3  ?
And,
Go to Zero sends all axis' except Z. Is there a Safe Z setting ?

Russ


Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Mach 4 Bug Reports
« Reply #41 on: May 06, 2014, 02:06:17 PM »
If you have an offset in place for the A axis, G81 does have an issue.

The line should wrap in the G code window.  Does it not?  It does on mine but maybe there is something different about your machine.  So check it out and let me know.

Steve

HIYA Steve NO offsets in A here that I can find.

(;-) TP

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
Re: Mach 4 Bug Reports
« Reply #42 on: May 06, 2014, 02:10:59 PM »
M4-1754  
File Ops. buttons are "hot" while G-code file is running. Should they be disabled and maybe warn "Stop file before ......" like Mach3  ?
And,
Go to Zero sends all axis' except Z. Is there a Safe Z setting ?

Russ


This is all done in the screen set.  Obviously, the existing screen set has not covered every angle.  And that screen set might not be the "stock" screen either.  We were thinking of having a contest or something for the development of the stock screen set.  The one you are using basically is a clone of the static wxMach.exe GUI interface.  And it has a back story associated with it.  It came from my efforts to produce a G code interpreter front end for the Galil motion controllers over 10 years ago.  Before I even knew of Mach!  It is pretty functional, but it is not frill free at the moment.

Feel free to do up your own screen sets.  I know that is not a simple matter at the moment without documentation.  But that will get there.  As soon as we get out of this stage, I think it will be full on doc time!

I may add a property to all of the controls like "Valid States" where all one needs to do is select the machine states in which the control will be enabled.  But right now, you can handle this type of thing in the PLC script.

Steve

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
Re: Mach 4 Bug Reports
« Reply #43 on: May 06, 2014, 02:13:06 PM »

HIYA Steve NO offsets in A here that I can find.

(;-) TP

There has to be.  Do a G53 G00 A0 in MDI and then zero your A axis.  Then try it.  Works for me. 

Steve
Re: Mach 4 Bug Reports
« Reply #44 on: May 06, 2014, 02:24:36 PM »
M4-1754  
File Ops. buttons are "hot" while G-code file is running. Should they be disabled and maybe warn "Stop file before ......" like Mach3  ?
And,
Go to Zero sends all axis' except Z. Is there a Safe Z setting ?

This is all done in the screen set.  Obviously, the existing screen set has not covered every angle.  And that screen set might not be the "stock" screen either.  We were thinking of having a contest or something for the development of the stock screen set.  The one you are using basically is a clone of the static wxMach.exe GUI interface.  And it has a back story associated with it.  It came from my efforts to produce a G code interpreter front end for the Galil motion controllers over 10 years ago.  Before I even knew of Mach!  It is pretty functional, but it is not frill free at the moment.

Feel free to do up your own screen sets.  I know that is not a simple matter at the moment without documentation.  But that will get there.  As soon as we get out of this stage, I think it will be full on doc time!

I may add a property to all of the controls like "Valid States" where all one needs to do is select the machine states in which the control will be enabled.  But right now, you can handle this type of thing in the PLC script.

Steve

That's all good to know Steve, thanks. I didn't realize it wasn't "The Real thing".  :)
Course I tried to fix it in the screen editor first, but couldn't figure it out.
I'll try not to clutter your inbox with piddly screen issues .... for now , it'll all come together eventually.  :)

Russ :)

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Mach 4 Bug Reports
« Reply #45 on: May 06, 2014, 02:40:42 PM »
HIYA Steve , SO there IS and obvious bug in the G81 call.

Thanks (;-0 TP

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
Re: Mach 4 Bug Reports
« Reply #46 on: May 06, 2014, 03:23:13 PM »
Yes that is what it is.  G81 is not working right.  We added code in so as to be able to drill on a rotation and it doesn't work in all cases.  If there is no A offset, then all is fine.  Otherwise, A will creep A by the offset amount every cycle.  We will have that fixed in the next update.

Steve

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Mach 4 Bug Reports
« Reply #47 on: May 06, 2014, 05:02:02 PM »
Steve THANK YOU  for fixing the axis DROs entry function. It works well now.

(;-) TP

Offline Calum

*
  •  40 40
    • View Profile
Re: Mach 4 Bug Reports
« Reply #48 on: May 06, 2014, 06:00:37 PM »
In build 1754 feed rate now metric, great, but the units for Soft Max and Min on the Homing/SoftLimits tab of Configuration seem to be in inches when machine is set to metric!

The Show Tool Path Limits is still not persistent.

Calum
Re: Mach 4 Bug Reports
« Reply #49 on: May 06, 2014, 06:50:26 PM »

Go to Zero sends all axis' except Z. 

Russ


This is all done in the screen set.  
Steve

Well, I think I found it. (Steve, you're such an instigator  ;D )
 After looking through and trying to make sense of what looks like one of the Dead Sea Scrolls under the the Operator/Lua script, I'd guess there would need to be a Z0 in there as well.  ::)
Can't edit there though, and don't see how to add it.
Is it protected ?
Or ? ? ?.
Thanks,
Russ
 :)