Hello Guest it is October 14, 2019, 10:02:02 PM

Author Topic: Mach 4 Bug Reports  (Read 359507 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach 4 Bug Reports
« Reply #300 on: February 12, 2015, 02:45:06 PM »
daniellyal,

It's not a motion problem, it's an error in the displayed value of the acceleration expressed in G units.  When you enter a value for acceleration on the motor tuning page, the box to the right of that should display the acceleration in units of G.  If you enter 300 units/s/s and you are working in metric units (mm), the displayed value should be 300/9800=.0306.  Nothing to do with pulses, steps per unit, maximum velocity, just a translation from units/s/s to G.

In M3, you can enter either G units or units/s/s but, obviously not both as they are not independent values.

G values are nice in that they give one a quick feel for the forces acting on the table and any vices, work, jigs mounted on it.  An actual acceleration of .77 would require very high forces be applied by the motors.

Peter

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach 4 Bug Reports
« Reply #301 on: February 12, 2015, 04:08:21 PM »
how did you get the value of 9800

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Mach 4 Bug Reports
« Reply #302 on: February 12, 2015, 04:18:08 PM »
Gravity.
9.8m/s
1G
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach 4 Bug Reports
« Reply #303 on: February 12, 2015, 04:34:38 PM »
thanks I will have another look
Re: Mach 4 Bug Reports
« Reply #304 on: February 13, 2015, 01:39:43 AM »
daniellyal,

It's not a motion problem, it's an error in the displayed value of the acceleration expressed in G units.  When you enter a value for acceleration on the motor tuning page, the box to the right of that should display the acceleration in units of G.  If you enter 300 units/s/s and you are working in metric units (mm), the displayed value should be 300/9800=.0306.  Nothing to do with pulses, steps per unit, maximum velocity, just a translation from units/s/s to G.

In M3, you can enter either G units or units/s/s but, obviously not both as they are not independent values.

G values are nice in that they give one a quick feel for the forces acting on the table and any vices, work, jigs mounted on it.  An actual acceleration of .77 would require very high forces be applied by the motors.

Peter

Confirmed. Broken in (at least) the most recent version.

With an acceleration of 4000 mm/s the G force should be (4000 mm/s² / 1000) / (9.81 m / s²) = ~ 0,40 G.
It displays ~ 10 G.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach 4 Bug Reports
« Reply #305 on: February 13, 2015, 01:51:24 AM »
looks like the math is a bit out

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Mach 4 Bug Reports
« Reply #306 on: February 28, 2015, 02:46:39 PM »
Does Mach4 NOT show the original toolpath along with the COMPED toolpath when using tool comp code? 

(;-) TP
Re: Mach 4 Bug Reports
« Reply #307 on: March 02, 2015, 05:35:45 PM »
Open Mach 4.
Open diagnoses tab: Z Limit Switch is active (but it shouldn't be). Unable to jog Z axis. Pressing limit switch does nothing.
Open Config/Mach. Go to Inputs tab, Press OK.
Z Limit Switch goes inactive (as it should be). Able to jog Z axis. Pressing limit switch now works as expected.

on the Inputs screen, Motor 2-- and Motor 2++ are set to "Mapping enabled, SmartBobUSB, Pin 13, Active Low ticked"
Other limit switches are fine. They are Active Low unticked.

It does this every time I restart MACH4.

Running on Windows 7 Professional, 64 bit.
Re: Mach 4 Bug Reports
« Reply #308 on: March 04, 2015, 09:32:21 AM »
Hi Neil,

There is an issue between our plug-in and the Mach4 core displaying the correct current values of the input signals on startup, though I haven't seen a case where togging the switch hasn't fixed that.  Something seems fishy since only your Z limit switch input refuses to toggle (and only until to enter and exit the config screen).

Since this involves the PMDX SmartBOB plug-in and/or device, please re-post this on our support forums so we can help figure out what is going on.  If this does turn out to be a Mach4 issue we can report that back here.  Please go to:

http://www.pmdx.com/PMDX-Forums

Some of the information we will need:

- Mach4 build number
- PMDX plug-in version
- PMDX SmartBOB firmware version

All of these are available from our plug-in configuration dialog.  Go to the Mach4 "Configure" menu, then select "plugins...", then click on the "Configure" button on the line for the PMDX-SmartBOB-USB plug-in.

Bob
PMDX
Re: Mach 4 Bug Reports
« Reply #309 on: March 04, 2015, 04:31:54 PM »
Hi Bob,

Actually, I'm going to ignore it. I decided to rewire my Z limit switch to Active High ( as it's safer ) only to find the switch was a bit dodgy.
I've replaced the switch and wired it Active High and now all is good.