Hello Guest it is October 15, 2019, 03:39:42 PM

Author Topic: Mach 4 Bug Reports  (Read 359943 times)

0 Members and 1 Guest are viewing this topic.

Re: Screen /screen Editor problem
« Reply #150 on: June 04, 2014, 07:01:44 PM »
Might try pages and use the BMP as the default page and then the other dro's and files on separate pages then try the Zorder.

Offline Bodini

*
  •  216 216
    • View Profile
Error on startup build 1817
« Reply #151 on: June 04, 2014, 07:45:08 PM »
Just installed 1817, uninstalled 17XX first (even deleted the folder that the uninstall did not delete).

I am getting an error on start up: "File 'C:\[OEM PATH HERE]\macros\mcLua.mcc' couldn't be removed (error 0: the operation completed successfully.)"

I dont see mcLua.mcc in the macros folder. Sounds like thats what the error is about.  Known problem or did I do something? ???

addendum:  now i am getting this error too if i edit a script and then run it in the editor.  the editor crashes too.

addendum 2: now i see that it gets this error if i do not save the script before i run it in the editor.
« Last Edit: June 04, 2014, 07:48:25 PM by Bodini »

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Mach 4 Bug Reports
« Reply #152 on: June 04, 2014, 07:55:54 PM »
OH I fought with that one last night for about about 2 hours. It will ERROR everytime you push a button or try to do a function.

EVEN if you put THAT file back where it says it should be you will STILL get that error.

(;-) TP

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
Re: Mach 4 Bug Reports
« Reply #153 on: June 04, 2014, 07:57:37 PM »
1817 used LUA 5.2  So we shipped it without the *.mcc files to ensure that they get rebuilt.  Once you press Start Cycle, they will build and the mcLua.mcc will be created.

The mcc files are not compat between LUA 5.1 and 5.2.  So if you have any scripts that you wrote, delete all of the mcc files and let them rebuild.

Steve

Offline Bodini

*
  •  216 216
    • View Profile
Re: Mach 4 Bug Reports
« Reply #154 on: June 04, 2014, 08:25:12 PM »
 Once you press Start Cycle, they will build and the mcLua.mcc will be created.

Hi Steve,

I dunno... mcLua.mcc is not being created here.  Start Mach4, load roadrunner, press cycle start, let it run, stop it...  Still no mcLua.mcc in C:\Mach4Hobby\Profiles\Mach4Mill\Macros folder.  Close Mach, restart it... the error persists.

-Nick

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
Re: Mach 4 Bug Reports
« Reply #155 on: June 04, 2014, 08:32:37 PM »
It is because some mcc file is still in there somewhere when it tried to roll all of them up into the one big mcLua.mcc file.  Incompatible mcc files prevent this from happening. 

The rule of thumb is if there is no mcLua.mcc file, then there is an error in at least one script or the mcc files are incompatible.  Those are the only two instances we have found that prevent the mcLua.mcc file from being built.   

Be sure that if your scripts reference any scripts external to the profile (like in Mach4/Modules dir), that those scripts also have their mcc files deleted.  You may have to compile external scripts in the mcLuaEditor as the auto compile will not work for scrips outside of the macros dir.

Steve

Offline BR549

*
  •  6,902 6,902
    • View Profile
Loading SUBS or G65 macro
« Reply #156 on: June 04, 2014, 10:11:01 PM »
OK I found the problem in the M98 calls it seems Mach4 Fails on the starting of 2nd nest of the Sub. It does NOT even start the 2nd level.

It SHOULD be able to do 4 levels of sub nesting. Most modern controller do MUCH more levels of nesting.

(;-) TP
« Last Edit: June 04, 2014, 10:13:10 PM by BR549 »

Offline BR549

*
  •  6,902 6,902
    • View Profile
Serious problem with G65 #vars
« Reply #157 on: June 05, 2014, 12:01:53 AM »
When you call G65 for a MACRO you are allowed to set #vars through Letter calls   A-Z  == #1-#26.  During the G65 call is the ONLY time you should be able to make the Letter calls update #vars.

In Mach4 ANYTIME you use a Gcode word X Y Z A B C U V W G F H M N Q P R S L etc ,  you are updating the #1-#26 VARS. This SERIOUSLY messes up the parametric Gcode in the G65 macro.

(;-) TP

Offline Bodini

*
  •  216 216
    • View Profile
Re: Mach 4 Bug Reports
« Reply #158 on: June 05, 2014, 12:03:29 AM »
It is because some mcc file is still in there somewhere when it tried to roll all of them up into the one big mcLua.mcc file.  Incompatible mcc files prevent this from happening. 

The rule of thumb is if there is no mcLua.mcc file, then there is an error in at least one script or the mcc files are incompatible.  Those are the only two instances we have found that prevent the mcLua.mcc file from being built.   

Be sure that if your scripts reference any scripts external to the profile (like in Mach4/Modules dir), that those scripts also have their mcc files deleted.  You may have to compile external scripts in the mcLuaEditor as the auto compile will not work for scrips outside of the macros dir.

Steve

Hi Steve,

Reading what you wrote there and kind of understanding some of it I did exactly this and nothing more...

Uninstalled Mach4 1817, deleted folder.
Reinstalled M4 1817.
Started M4. No error.  looked in the macros folder and I see m3, m6 and m6end: mcs and mcc files.
Loaded arctest and ran it.
Closed gcode. Closed M4.
Reopen M4.  The error shows on load up.
Close M4.
Delete the m3, m6, m6end mcc files.
Open M4.  M3,m6, m6end mcc files are created.  mclua.mcc is created.  This error comes up: 
23:55:25: Failed to open 'C:\Mach4Hobby\Profiles\Mach4Mill\Macros\m3.mcc' for reading (error 0: the operation completed successfully.)
23:55:25: Failed to retrieve file times for 'C:\Mach4Hobby\Profiles\Mach4Mill\Macros\m3.mcc' (error 0: the operation completed successfully.)
Ok that error box.  Then this error comes up:
23:55:25: Failed to open 'C:\Mach4Hobby\Profiles\Mach4Mill\Macros\m6.mcc' for reading (error 2: the system cannot find the file specified.)
23:55:25: Failed to retrieve file times for 'C:\Mach4Hobby\Profiles\Mach4Mill\Macros\m6.mcc' (error 2: the system cannot find the file specified.)
23:55:25: Failed to open 'C:\Mach4Hobby\Profiles\Mach4Mill\Macros\m6end.mcc' for reading (error 2: the system cannot find the file specified.)
23:55:25: Failed to retrieve file times for 'C:\Mach4Hobby\Profiles\Mach4Mill\Macros\m6end.mcc' (error 2: the system cannot find the file specified.)
23:55:25: File 'C:\Mach4Hobby\Profiles\Mach4Mill\Macros\mcLua.mcc' couldn't be removed (error 2: the system cannot find the file specified.)
Close M4.
Reopen M4.  No errors.

I'd bet none of that is a surprise to you but it sure is a lot of hoops to jump through for your average user. ;-)

-Nick

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Mach 4 Bug Reports
« Reply #159 on: June 05, 2014, 12:28:25 AM »
THIS is about the 3rd time today I got this error. HOW should I respond ???

(;-) TP