Hello Guest it is July 06, 2020, 06:15:53 AM

Author Topic: Mach3 2010 Screenset - Now available  (Read 427932 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach3 2010 Screenset - Now available
« Reply #70 on: June 12, 2012, 02:45:15 PM »
i Gerry
here's the xml and a file i have been cutting
thanks
john

Offline ger21

*
  • *
  •  6,281 6,281
    • View Profile
    • The CNC Woodworker
Re: Mach3 2010 Screenset - Now available
« Reply #71 on: June 12, 2012, 06:01:34 PM »
You don't have Mach3 configured to turn on your spindle. You need to setup an output pin, and assign that pin to M3, on the spindle tab of the ports and pins page.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach3 2010 Screenset - Now available
« Reply #72 on: June 13, 2012, 05:12:23 AM »
Hi Gerry

Sorted thanks machine now sorted after a year of alterations just got a 4th axis to do now.

John

Offline abhi

*
  •  24 24
    • View Profile
Re: Mach3 2010 Screenset - Now available
« Reply #73 on: July 09, 2012, 09:55:47 AM »
Hi,

okay ive been using the 2010 screen set under mach 3.042.040. After it completes an M06 and goes back to the last position before the M06 call then does the M03, mach doesn't always pause for the spindle spin up and instead executes the next move (usually a G0) and very soon after stalls my x and often my Y motors. Anyone else run into this? also looking at the code the execution line looks something like this.

N300 G00 X233.05 Y130. S2000 M03

The error does not happen every time which has made it hard to trouble shoot. I've been through checking the motors, made some inertial dampers, set the max speed to something reasonable 3000mm per sec (around 118ips) and accel at 150 (0.01g).

Any help would be geat

Offline ger21

*
  • *
  •  6,281 6,281
    • View Profile
    • The CNC Woodworker
Re: Mach3 2010 Screenset - Now available
« Reply #74 on: July 09, 2012, 11:38:00 AM »
You should probably have that as 2 separate lines:

N300 S2000 M3
N301 G00 X233.05 Y130

Also, do you have a spin up delay set in ports and pins > Spindle Tab?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline abhi

*
  •  24 24
    • View Profile
Re: Mach3 2010 Screenset - Now available
« Reply #75 on: July 09, 2012, 12:05:20 PM »
thanks for the quick reply :)
i posted this also in general, hood said the same thing. Oh and yes i have a delay for the spin up.

ill have to hand edit untill i sort the post out.

thanks again
ab.
Re: Mach3 2010 Screenset - Now available
« Reply #76 on: July 15, 2012, 08:54:52 AM »
Hi, I've having some problem using this screenset along with Mach3 R3.043.062. Sometimes during toolchanges my steppers stall out entirely. This never happens during normal rapids, just rapids caused by 2010 screenset. The problem goes away if I turn of toolpath display or unload my g-code file. Is there any workaround for this? My computer (XP 2500+, 1gb ram) should be sufficient to drive this config?

I'm using Gecko G540 as stepper driver, if that has something to do with it.
Other than the problem above I'm much pleased with the looks and feel of this screenset.

Thanks
Petter

Offline ger21

*
  • *
  •  6,281 6,281
    • View Profile
    • The CNC Woodworker
Re: Mach3 2010 Screenset - Now available
« Reply #77 on: July 15, 2012, 08:57:20 AM »
I was typing this in response to the post you made in the other thread, but I'll place it here instead. I think your issue may be due to #1?

Quote
I'm experiencing the exact same problem that you are describing. Stalling motors during move commands from 2010 screenset.

I've had 4 users come to me with this issue. It's probably one of two things.

1) If you have a dual core processor, go into the bios and disable either C1E or EIST.
this fixed the issue for 3 people.

2) the 4th user was using an old PC that just wasn't capable of displaying the larger toolpath. Open the task manager and check the CPU usage with g-code loaded. Then turn the toolpath on and off with the toolbar button. The user that had the problem was seeing 90%CPU usage without the machine even running, but only 3% with the toolpath turned off.
If this is the issue you're having, the machine should run smoothly with the toolpath turned off. But you really need a better PC.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Mach3 2010 Screenset - Now available
« Reply #78 on: July 17, 2012, 09:59:46 AM »
Do you need to see both the commanded speed and actual? I modified a screen for someone to do that. Send me an email explaining what you want and I'll se what I can do.

I'd like to have both visible but not necessarily at the same time (to keep from taking up too much desktop space)
For those that have spindle speed feedback set up, I think having the ability to simply toggle between the two would be nice. (small radio button above the DRO).

Offline ger21

*
  • *
  •  6,281 6,281
    • View Profile
    • The CNC Woodworker
Re: Mach3 2010 Screenset - Now available
« Reply #79 on: July 17, 2012, 11:39:11 AM »
Quote
For those that have spindle speed feedback set up, I think having the ability to simply toggle between the two would be nice. (small radio button above the DRO).

Sorry, but it's not possible to do that.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html