Hello Guest it is November 19, 2019, 01:16:14 PM

Author Topic: Galil controller compatability (what works with the plugin)  (Read 167658 times)

0 Members and 1 Guest are viewing this topic.

Offline smurph

*
  • *
  •  1,149 1,149
  • "That there... that's an RV."
    • View Profile
Re: Galil controller compatability (what works with the plugin)
« Reply #140 on: September 30, 2014, 12:42:40 PM »
DMC-8240 is not a controller that I recognize.  I would not use anything ISA, period.  10 years ago, I would have said different.  But now, it is a waste of money.  You can buy a new DMC-41x3 cheaper than you can put a modern processor in a ISA motherboard (they still make them but they are expensive!!!) to put together a system that is still ultimately based on a bus controller.

We are moving away from Linear mode in the plugin and toward Contour mode.  The only bus based controller that supports contour mode is the DMC-18x6 (PCI).  For Mach 4, we go back to using the Galil drivers and they do not support ISA at all.  So there is no future for ISA controllers.

Steve
Re: Galil controller compatability (what works with the plugin)
« Reply #141 on: October 01, 2014, 08:52:11 AM »
Steve
Thanks a bunch for explanations.
I aware  of your intentions going away from Smart term drivers Its just bits and bobs been lying around I would like to utilise in simple applications for cheep clients :-)

Offline bubba

*
  •  80 80
    • View Profile
Re: Galil controller compatability (what works with the plugin)
« Reply #142 on: November 18, 2014, 01:05:47 AM »
Hi Steve,

Are the 18x3 PCI cards working with the plugin for Mach4?

Thanks,
Joe

Offline smurph

*
  • *
  •  1,149 1,149
  • "That there... that's an RV."
    • View Profile
Re: Galil controller compatability (what works with the plugin)
« Reply #143 on: November 18, 2014, 01:11:37 PM »
I don't know what 18x3 is.  18x0 is Optima, 18x6 is Accelera, and 18x2 is Econo.  Of all, only the 18x6 supports contour mode, so that will be the favored card.  If Galil's drivers will support the card, then it MAY work.  I don't have any bus based cards anymore and I really can't test any of them. 

Steve

Offline bubba

*
  •  80 80
    • View Profile
Re: Galil controller compatability (what works with the plugin)
« Reply #144 on: November 18, 2014, 02:51:29 PM »
Which drivers do you want installed Galil tool,smarter etc?
Has any one done a step by step instructions.
Example load Galil software,communicate with card, then install mach4 etc

Thanks for your response,
Joe

Offline smurph

*
  • *
  •  1,149 1,149
  • "That there... that's an RV."
    • View Profile
Re: Galil controller compatability (what works with the plugin)
« Reply #145 on: November 18, 2014, 04:35:37 PM »
I cannot write instructions for setting up bused based cards for which I don't have.  :(

The Galil plugin for Mach4 uses the Galil Tools/Galil Suites API library called LibGalil.  It will work with the driver provided by Tools or Suites.  But not Smart Term.  Smart Term is dead and will only work on Windows XP.

If you are shooting for Mach4, then:

1. Don't use Windows XP.
2. Don't use bus based cards. 

Currently, we are supporting XP for Mach 4.  But for how long?  The safe bet is not long at all.  And bus based cards...  I don't have any of them.  I can't test them and I won't be able to support them.  IF it works, then great.  If not, then I will be of no help.  :(

The Ethernet Galils do not require ANY drivers and thus do not require any special setup other than setting up the IP address.  You can load Galil Tool/Suites and immediately communicate with them with no driver install and reboot.  This is the future.  There is no going back to the bus based controllers for Galil.  They have not nor do I believe they will ever produce a PCIe controller.

So that is the writing on the wall, unfortunately. 

The Galils differ greatly on how the data record is obtained.  The Ethernet controllers can "stream" a data record to the PC and this is what we have chosen to use in programming the Mach4/Galil plugin.  The PCI cards have to be polled.  And since I don't have a PCI card, I cannot test this polling of the data record.  So there is absolutely no guarantee that your PCI card will ever work with the Mach4/Galil plugin.  So please don't invest a ton of time and money into the setup you have for Mach 4.  It should work fine for Mach 3 though.

Steve

Offline bubba

*
  •  80 80
    • View Profile
Re: Galil controller compatability (what works with the plugin)
« Reply #146 on: November 18, 2014, 07:03:46 PM »
Thanks

Offline bubba

*
  •  80 80
    • View Profile
Re: Galil controller compatability (what works with the plugin)
« Reply #147 on: November 22, 2014, 11:01:08 PM »
Hi Steve,

Will this be ok with Mach4

Galil DMC-2142, ICM-20105, DB-28040-5

Excuse if this a stupid question, but is there a working Galil plugin for Mach4?
I have been looking for it but I must be overlooking it because I have not found it.

Thanks,
Joe

Offline smurph

*
  • *
  •  1,149 1,149
  • "That there... that's an RV."
    • View Profile
Re: Galil controller compatability (what works with the plugin)
« Reply #148 on: November 23, 2014, 04:46:54 PM »
DMC-2142 is an Econo controller with the old style 100 pin connectors on it.  Are you sure it is a 2142?  Or is it a 2143?  Both can only use Linear mode motion control.   The newer controllers use Contour mode.  Strictly speaking, the 21x2/3 controllers will work.  But they are getting long in the tooth.  And the Mach 4 plugin has not been tested with them as yet.

There is a working Galil plugin for Mach 4 for Ethernet controllers only at this point.  It is not ready for prime time yet and has really only been tested on the newer controllers.  Thus it has not been released.  And I'm not sure when it will be released at this point as we are concentrating on Mach 4 primarily at this time.  Right now, Mach Motion, Kenny Crouch and myself are the only ones that have machines running Mach 4 with Galil.  And we are using 4000 series controllers. 

We will be building a machine at the shop with a 21x3 controller in the coming months, so that should shore up the support for the older Ethernet controllers.  But that is not high priority at this time.  :(

Also, the Galil plugin will be a supported plugin for Mach 4.  And that means it will most likely be licensed much like Darwin is.  The price of Mach 4 alone is not going to cover the cost of the Galil plugin development and maintenance. 

Steve
Re: Galil controller compatability (what works with the plugin)
« Reply #149 on: February 23, 2015, 05:40:44 PM »
Hi steve.
What is the status on Mach 4 galil etc?
Another one of my big Biesse original controls has just done the splits!
I just got a new 2280 (same as I used in the first one)
I just read that your only going to support the accelera series?
All my machines are on the older 2100,2200 or 2183 galils.
Have you got a price yet for the m4 galil plugin? Happy to pay for it
Or am I best to stick with m3?
I have purchased m4 but haven't licences it to a PC yet awaiting a supported plugin
if its not broken yet, fit more gadgets!