Hello Guest it is October 23, 2019, 10:51:23 PM

Author Topic: Galil controller compatability (what works with the plugin)  (Read 166530 times)

0 Members and 1 Guest are viewing this topic.

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
Re: Galil controller compatability (what works with the plugin)
« Reply #20 on: February 02, 2011, 11:08:55 PM »
That error means that the plugin could not find some support DLL.  The plugin is linked against these Windows system DLLs.  These should all reside in the System32 directory. 

dmc32.dll (SmartTerm)
dmcser32.dll (SmartTerm)
VERSION.dll
KERNEL32.dll
USER32.dll
GDI32.dll
comdlg32.dll
ADVAPI32.dll
COMCTL32.dll
SHLWAPI.dll
ole32.dll
OLEAUT32.dll

Sometimes a bare bones Windows install does not provide all of these DLLs.

Steve
Re: Galil controller compatability (what works with the plugin)
« Reply #21 on: February 03, 2011, 05:43:32 AM »
i believe you need a licenced mach 3 to use the galil plugin. smurph???

go for it, its a superb program with galil
my machine running on mach / galil can be seen here
http://www.youtube.com/user/automateanything?feature=mhum#p/a/u/0/dWp__rJURpU
if its not broken yet, fit more gadgets!
Re: Galil controller compatability (what works with the plugin)
« Reply #22 on: February 03, 2011, 11:21:49 AM »

dmc32.dll (SmartTerm)
dmcser32.dll (SmartTerm)
VERSION.dll
KERNEL32.dll
USER32.dll
GDI32.dll
comdlg32.dll
ADVAPI32.dll
COMCTL32.dll
SHLWAPI.dll
ole32.dll
OLEAUT32.dll


Thanks for the responses!! I checked the .DLL's and they are all in the sys32 folder.


Here are some SS of the error.



and



Do I need Mach3 to be licensed? If so I will get the license, but I was hoping I could test this before I purchased it.

Thanks!!

Aero
Re: Galil controller compatability (what works with the plugin)
« Reply #23 on: February 03, 2011, 11:51:59 AM »
I just talked with a tech from Galil, and he confirmed that I have the card registered correctly in Windows. I can use GalilTools to make moves and turn outputs on and off. Is there a certain .NET I need installed on the computer? I have .NET 3.5 SP1 on the box right now. I think I will update it to .NET 4 and see what happens.

Thanks again,

Aero
Re: Galil controller compatability (what works with the plugin)
« Reply #24 on: February 03, 2011, 01:54:09 PM »
Not sure if it matters, but I have a DB-28040-5V daughter card installed on the DMC-2162.

Thanks,
Aero
Re: Galil controller compatability (what works with the plugin)
« Reply #25 on: February 03, 2011, 01:56:42 PM »
the daughter board wont make any difference.
 i have 2 machines running with 2153 and daughter board
if its not broken yet, fit more gadgets!
Re: Galil controller compatability (what works with the plugin)
« Reply #26 on: February 03, 2011, 02:11:49 PM »
Maybe there is something wrong with the plug in. I tried it on two different computers, XP 2k.

I didn't think the daughter card would make a difference, but thanks for letting me know.... one more thing to cross off the list.

Does it matter about the versions of the plug in and the mach3? All I did was download the latest Mach3 and grabbed the plug in from the plug in section. Since I tried it on two different computers I'm thinking maybe they upgraded Mach3 and the plug in might not be working with it... just a thought.

Thanks,

Aero
Re: Galil controller compatability (what works with the plugin)
« Reply #27 on: February 03, 2011, 02:44:34 PM »
i think mine is using .040 which could be downloaded from the archive. here
ftp://machsupport.com/Mach/

if you pm me your email address il send you the plugin im using
if its not broken yet, fit more gadgets!
Re: Galil controller compatability (what works with the plugin)
« Reply #28 on: February 03, 2011, 02:50:40 PM »
i presume you have the controller set ethernet? smarterm on pc

i know there is an issue with drivers on pci cards if you have galil tools drivers on the same pc.
 recommended only smarterm drivers which mach uses to talk to the galil
if its not broken yet, fit more gadgets!
Re: Galil controller compatability (what works with the plugin)
« Reply #29 on: February 03, 2011, 03:01:00 PM »
Sent... and thanks for the help :)