Hello Guest it is September 19, 2019, 05:15:12 AM

Author Topic: Problems threading on the lathe  (Read 330164 times)

0 Members and 1 Guest are viewing this topic.

Offline RICH

*
  • *
  •  7,361 7,361
    • View Profile
Re: Problems threading on the lathe
« Reply #150 on: March 17, 2009, 09:39:56 PM »
Ok ART,
Give me about 20 minutes or so and will let you know.
RICH

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Problems threading on the lathe
« Reply #151 on: March 17, 2009, 09:42:39 PM »
Rich:

Is this the repeating code your using?

G01 Z-0.1                                   Z IN POSITION WAITING FOR INDEX TO START THREAD
G32 X0.999 Z-0.0997 F0.076923   INDEX / Z ACCEL TO THREAD START POINT
G32 X0.999 Z1 F0.076923            THE THREADING CUT
G01 X1.1 Z1 F0.076923               RETRACT OUT OF THREAD
G00 X1.1 Z-0.1                            RETURN TO THE X OFFSET & Z START
G00 X1                                       X MOVE TO STOCK DIAMETER

if so, can you change the first move to a g0 from a g32. So it reads..

G01 Z-0.1                                   Z IN POSITION WAITING FOR INDEX TO START THREAD
G00 X0.999 Z-0.0997                  INDEX / Z ACCEL TO THREAD START POINT
G32 X0.999 Z1 F0.076923            THE THREADING CUT
G01 X1.1 Z1 F0.076923               RETRACT OUT OF THREAD
G00 X1.1 Z-0.1                            RETURN TO THE X OFFSET & Z START
G00 X1                                       X MOVE TO STOCK DIAMETER

  Does it still do it? Im thinking the first G32 is being ignored, ( and it shouldnt be necessary anyway.. )

Art

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Problems threading on the lathe
« Reply #152 on: March 17, 2009, 09:51:28 PM »
Hi Guys:

  OK, I think we're narrowing way in..

You can keep the original code as youve been doing, try this exe for me..

Thx
Art

Offline RICH

*
  • *
  •  7,361 7,361
    • View Profile
Re: Problems threading on the lathe
« Reply #153 on: March 17, 2009, 10:08:10 PM »
ART,
It's not the double line of the gcode. I generated a different Gcode with just a single line of g32
coding. Same problem.
I will change it.

Just a quick question, is the *********x17-2 file strictly for use with a PP? ( the other one would not work with
the SS). That other one would also generate an error if you tried to use the gcode posted in my reply #117?.

RICH

Offline RICH

*
  • *
  •  7,361 7,361
    • View Profile
Re: Problems threading on the lathe
« Reply #154 on: March 17, 2009, 10:23:36 PM »
Answered my owne questiion in the last post #153.
Here is the code i am using for testing with *********xx17-2 mach file.
First line of g32 code changed to a G00.

Looks promising, but let me fool around some.
RICH

Offline RICH

*
  • *
  •  7,361 7,361
    • View Profile
Re: Problems threading on the lathe
« Reply #155 on: March 17, 2009, 11:12:11 PM »
Art,
With the changed code and the 17-2 version I CAN NOT get the XZ move to occur.
The threading cycle will stop at around 75% turndown ( 100 down to 25 or 30  rpm to trip it).
I could "very rapidly" stop the spindle ie; 100 rpm down to 0 only for less than a 1/2 sec or less
and the thread cycle would continue on.

I tried to spike the index pulse by varying the rpm numerous times during the threading and stiill the threadiing continued.

The displayed rpm is off in the readout and also in the turn diagnostics by about 5 rpm ( 95-96 vers 100 actual).

------------------------------------------------------

Now i need to replace the first line G00 back to G32 and see what happens.

------------------------------------------------------

One thing i did notice is that if you vary the speed it may keep that speed for a few thread passes.
As compared to a 5 months ago, the Z dosen't seem to be as reponsive to a slow down or speed up
of the spindle.  But lets not dwell on that for now.

Think your on the right track!
I'll fool with it more tomorrow as it's getting a little late.
Will stiick arorund for about 20 minutes of so.
RICH


  

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Problems threading on the lathe
« Reply #156 on: March 18, 2009, 08:32:07 AM »
Rich:

 Sounds good ..  Can you see if the original code and the 17-2 works good too?

 The RPM being off is due to other changes in this exe, you can ignore those for now,
the fixed version from Brian wont have that strangness..

Thx
Art

Offline RICH

*
  • *
  •  7,361 7,361
    • View Profile
Re: Problems threading on the lathe
« Reply #157 on: March 18, 2009, 12:05:35 PM »
Will do later today and post what i find.
RICH

Offline RICH

*
  • *
  •  7,361 7,361
    • View Profile
Re: Problems threading on the lathe
« Reply #158 on: March 18, 2009, 10:41:13 PM »
Art,
The original threading code and the 17-2 version work fine.
Tried it out on two different lathes and three different PC's and coudn't get
the XZ moves to happen.

That extra line of G32 code is not skipped. It happens very fast and in a short distance.

For those following this thread, let me remark that the spindle slowdown can cause
the threading cycle to stop. The trigger point which causes the stop will vary depending on the pc,
but it is not no 10%.

Art,
Can you let us know when an update may get posted. Also will the update impact the SmoothStepper?

RICH

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: Problems threading on the lathe
« Reply #159 on: March 18, 2009, 11:10:04 PM »
Hi Guys:

  Thx for the confirmation, Brians code is fixed, update wont be long. PP and SS should both be fine as this fix affects both.

You all did real well here, and I bow to your effort. It was a very bad one to find and your descriptions really led me to the well,
I still needed to be forced to drink, but at least I was at the well.

Id like to hear of any threads you get after the fix and their quality. I have more to fix in threading and any assistance helps.

Thx
Art