Hello Guest it is October 18, 2019, 08:18:46 PM

Author Topic: A new Huanyang VFD plugin  (Read 147362 times)

0 Members and 1 Guest are viewing this topic.

Re: A new Huanyang VFD plugin
« Reply #80 on: May 22, 2013, 01:49:17 PM »
Ive been using the plugin for a bit now and its working pretty well. I think I have my noise issues fixed.

One issue i'm running into is an occasional e-stop. Im on the newest version. Mach3 reports it as "e-stop button pressed". Ive been watching my rpm DRO and it appears that once in awhile it will drop rpm's for a quick second. The motor runs properly, but the DRO itself will drop out every now and then. I think what is happening with the e-stop is that the plugin thinks that the RPM is dropping and reports an e-stop. Is there any way for you to lengthen the period of rpm dropping before reporting an e-stop. Or even, can you provide a switch to remove that feature all together? Im assuming its there so that your program will stop running if you happen to lose connection to the motor for whatever reason, but id rather it wasn't there at all - or atleast make it take a few seconds of rpm dropping before it reports the e-stop.

Online Chaoticone

*
  • *
  •  5,607 5,607
  • Precision Chaos
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #81 on: May 22, 2013, 02:37:27 PM »
TropicalGuru, have you set up your spindle pulley?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: A new Huanyang VFD plugin
« Reply #82 on: May 22, 2013, 03:16:48 PM »
Hi all,

It's been a while since my last visit..

@TropicalGuru
I think there is the pwm checkbox checked in your configuration.. ensure it is unchecked and let me know the results.


@MikeMaat
The fact that the spindle slow down without order is considered as faulty. But you're idea is good, i will add a come configuration possibility  to this feature:
-1 : The deature is disabled (no E-stop will be triggered)
 0 :  (default value) the E-stop is thrown asap a faulty speed is detected
 n : The E-Stop will be thrown after n seconds.

Do you think it will be a good answer to your problem?

If yes, will try to do it this week-end





Re: A new Huanyang VFD plugin
« Reply #83 on: May 22, 2013, 03:28:57 PM »
The spindle itself doesn't actually slow down, the dro just flashes a lower rpm for a split second. I think if you made it check for an incorrect speed for 2 seconds before throwing the code it would work fine, and would keep your user interface for the plugin clean without the extra settings.
Re: A new Huanyang VFD plugin
« Reply #84 on: May 22, 2013, 03:32:19 PM »
Also, I don't know if its possible, but maybe display an error dialog box with the reason for e-stopping when your plugin sends an e-stop. Would help with diagnosing why e-stops are happening (noise vs. an actual issue)
Re: A new Huanyang VFD plugin
« Reply #85 on: May 22, 2013, 09:30:45 PM »
Chaoticone,

Think so, see the attached PulleySetup pic.

royaumedeole,

Unchecked the PWM checkbox (SpindleSetup), but no change, still throwing "PWM Buped to minimum setting" (SpndleStatus). I've attached the motor outputs screen as well; not sure if the motor output for spindle needs to be enabled?

Thanks very much for the quick responses, last hurdle to be cleared before I can start cutting.
Re: A new Huanyang VFD plugin
« Reply #86 on: June 06, 2013, 05:34:42 PM »
@royaumedeole Did you get a chance to try to program this?
Re: A new Huanyang VFD plugin
« Reply #87 on: June 20, 2013, 12:07:22 PM »
Hi,
I keep getting the "Driver Watchdog Triggered" showing up in the status bar, from the MDI sometimes the spindle will run for a few minutes and other times not at all, I then have to restart Mach3 but its still the same issue all over again.

as suggested by cjmerlin #78... "When realising that his plugin would not work for my setup I then used this new plugin but didn't realise that I needed to have the ‘Disable Spindle Relays’ checkbox, checked".

Having first used the Matty Zee plugin I was hopeful that this was the problem but there no change either ticked or unticked.

any thoughts

Breastfed
Re: A new Huanyang VFD plugin
« Reply #88 on: July 02, 2013, 12:22:16 PM »
Well, I attributed my issues to noise and i bought an opto-isolated adapter. Unfortunately, it doesnt have "ADDC" meaning it doesn't take care of RTS (message direction) like my other adapter does, so it doesnt work.

Is there any way for you to program the plugin to always be in "receive mode" (RTS always off) unless the plugin is sending a message, in which case it would briefly be turned on? I think that would solve the issue that alot of people were having in Matty Zee's thread with some adapters not working.

Reference:
http://www.moxa.com/resource_file/857220091121341.pdf
Re: A new Huanyang VFD plugin
« Reply #89 on: July 03, 2013, 10:55:50 AM »
Forget my last post. After months of trying different things I finally seem to have it working flawlessly.

For anyone reading through all these posts, The problems I encountered were:

1) Couldn't communicate with the VFD.

The solution to this was making sure I bought a USB - RS485 converter that: Was based on the FTDI chip, and had "ADDC" or "Automatic Handshake Mode". This basically means the adapter takes care of whether it is sending or receiving data automatically - you dont have to tell it to, since neither of these plugins takes care of that.

2) Noise issues that would cause Mach to either E-Stop or Freeze.

This was the big one that I battled with for months. Basically, I could start the spindle no problem and it wouldnt run for an indeterminate amount of time, but would randomly crash during a job. Watching the reported RPM DRO, the rpms would fluctuate up and down and sometimes even report completely strange numbers like "675834". The e-stops would happen because when the reported RPM dropped down near zero for an amount of time, the plugin is programmed to e-stop (which is normal, and meant to protect against a stall). However, since I was having noise, my "reported" rpm would sometimes go down near zero, even though it truly wasnt changing in reality, and thus the plugin would e-stop.

The solution to this one will be different for everyone. My VFD is in my control cabinet so my noise issues will probably be among the worst, but i was stubborn to keep everything in one box and not change it. I first started by using a firewire cable as my communication line between the usb-rs485 converter and the VFD. Firewire cables are great because they have TONS of shielding in them. I also made sure to ground one end of the inner shielding to my RS485 adapter. Only ground one end - this will make a "Farraday Cage" and help to block out EMI. This helped, but it really seemed like the noise was coming THROUGH the cable (The VFD worked absolutely fine in manual mode and the computer experienced no noise).

Finally, after months of trying things, I started tracing grounds. Im a big grounding cynic as I have rarely found huge differences from different grounding procedures. I grounded the things I should have, but Ive always been quite cynical while doing it. Well..... My VFD (and im sure yours as well) has two places on it with grounding symbols. One on the terminal blocks by the 220 input terminals, and one in the lower left of the VFD. I had the ground from my power supply going to the grounding screw on the bottom left. I had the ground from the motor cable (which was also attached to the motor's ground and the motor's housing) going to the terminal block ground. I made the assumption, for months, that both the grounds would be connected in some fashion, I was wrong. I took a multimeter and checked for continuity between the two ground posts - nothing. So I temporarily jumped the two with a strand of wire and my noise issues basically disappeared.



So, in summary, dont be stubborn like me. Make sure everything is grounded properly. Trace all your grounds with a multimeter to make sure they are all connected. The following grounds should exist:

(Power source implies your 220 breaker panel or similiar within your control panel)

- Spindle motor wiring should have a ground attached to the motor housing
- Spindle motor feed wiring from the VFD should be attached to the motor's ground wire (and thus the motor housing)
- VFD should have a ground coming to it from the power source.
- Spindle motor feed wiring should be grounded on the VFD side to both the VFD and the power source. It may not be best practice, but you can share the same ground terminal
- PC should have its power supply ground attached to the power source ground.
- Motor drive power supply should have its ground attached to the power source ground
- USB-RS485 communication cable should have ONE end of its shield attached to the power source ground (the computer's ground located within the RS485 adapter's breakout terminals)

Also, its a great idea to throw snap on ferrite cores on all your power source and communication cables (limits, usb, etc.) See here for details on ferrite cores (http://en.wikipedia.org/wiki/Ferrite_core). They can be bought in bulk on ebay for very very cheap.
« Last Edit: July 03, 2013, 10:58:27 AM by mikemaat »