Author Topic: A new Huanyang VFD plugin  (Read 136836 times)

0 Members and 1 Guest are viewing this topic.

Offline mikemaat

  • Active Member
  • Posts: 54
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #120 on: October 27, 2013, 04:48:48 AM »
Here is some more info..

I think the main problem, is that when the plugin sees a change in RPM (set by the S1000 command or whatever) it throws an e-stop because you have it programmed to monitor if the rpm drops below what it was set at (Im assuming for safety reasons). I dont think the answer is just to remove that monitoring, as it can be a good thing like when you try to start the spindle, if it doesn't end up starting you get an e-stop rather than just having the program continue.

So basically, the plugin needs to realize that the gcode has changed the RPM and not trigger an e-stop. Now this only happens when spinning DOWN to a lower speed. There is no issues when you are increasing the speed (say S1000 to S3000).

Ive attached some videos to illustrate the problem. Also, the tests were done on the older plugin. I noticed the new version disables the e-stop monitoring all together. For those of us that have our noise issues sorted out, you may want to have the ability to enable or disable the e-stop monitoring within the plugin. Probably enable it by default. Lastly, do you have Skype? It'd make working through these bugs alot easier and quicker.

So here is spinning up from 1000 to 3000. Works perfect..
http://www.youtube.com/watch?v=8Zt6bW547uw

And here is spinning down from 3000 to 1000. You will see the e-stop occur. Disregard the "M3" in the second spindle speed line. I have tried it with and without the M3, same results.
http://www.youtube.com/watch?v=h8Gr_EvBp5g
« Last Edit: October 27, 2013, 04:50:28 AM by mikemaat »

Offline NosmoKing

  • Active Member
  • Posts: 238
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #121 on: November 09, 2013, 03:28:56 PM »
I notice that you in the program you do not have M5 or M30 etc.
In the first video what stopped the spindle and program?
N.

Offline mikemaat

  • Active Member
  • Posts: 54
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #122 on: November 09, 2013, 03:33:24 PM »
Settings in Mach stop it, it's not an issue. I'm in talks with the plugin creator right now and I think he's got most of the issues figured out. Stay tuned for a response from him at some point

Offline royaumedeole

  • Active Member
  • Posts: 36
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #123 on: November 09, 2013, 04:13:30 PM »
@Nosmoking,

do not worry, I'm working on problems. Once the new plugin debugged( thanks to MikeMaat), we will tackle your problem.
But i must admit that at the time, i do not have any kind of idea why M03,M04,M05 commands do not work on your side....In Config>Ports and pins>spindle setup, "Use spindle relays" checkbox and "Use spindle Motor output" must be unchecked...that's just a point to check...


@Mikemaat
I'm working on the frequency issue which is the one explaining others..
Will contact you before the end of this long week-end (remembrance day)

seb

Offline gene8522

  • Active Member
  • Posts: 117
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #124 on: November 09, 2013, 05:18:36 PM »
I do not have a problem with  M03,M04,M05 commands but "S" will not change the DRO & RPM of the spindle.

Offline NosmoKing

  • Active Member
  • Posts: 238
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #125 on: November 10, 2013, 12:22:56 AM »
Settings in Mach stop it, it's not an issue. I'm in talks with the plugin creator right now and I think he's got most of the issues figured out. Stay tuned for a response from him at some point
What setting in mach?, and does M5 work for you?
N.

Offline mikemaat

  • Active Member
  • Posts: 54
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #126 on: November 10, 2013, 12:45:55 AM »
In General Config under "Pgm End or M30 or Rewind" check off "Turn off spindle" or "E-stop the system"

For those with M3,M4,M5 issues, make sure you check your macros in the macros folder and make sure that they contain the right code (download a demo of the latest mach version to compare to).

Offline tgdavies

  • Active Member
  • Posts: 21
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #127 on: November 10, 2013, 05:31:27 AM »
It turns out that my problem was that I hadn't cleared the "Disable Spindle Relays" checkbox -- clearing that made M5 work and reversed the direction of the spindle, so everything is working for me now.

Offline NosmoKing

  • Active Member
  • Posts: 238
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #128 on: November 10, 2013, 12:21:15 PM »
It turns out that my problem was that I hadn't cleared the "Disable Spindle Relays" checkbox -- clearing that made M5 work and reversed the direction of the spindle, so everything is working for me now.



It also turned out to be my problem also, I was sure I had the disable spindle cleared, but now the M3, M4, M5 and also MDI works, sorry for the misleading info.
Nosmo.

Offline vre

  • Active Member
  • Posts: 20
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #129 on: December 18, 2013, 08:03:29 PM »
Iam planing to buy a Huanyang VFD 4kw of 5.5kw which models work with this plugin ?