Author Topic: A new Huanyang VFD plugin  (Read 137202 times)

0 Members and 1 Guest are viewing this topic.

Offline royaumedeole

  • Active Member
  • Posts: 36
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #70 on: March 21, 2013, 02:56:55 PM »
Hello guys!

@rexdc
if you're using the 1.5 version, you may be facing some random EStop.
on my side, the release version is 1.5.1, which is te only one available on my web site.
If once shiellded, you still have problems, do not hesitate to contact me..it may be a bug (i'm not perferct!)




@MikeMaat
happy to see that noise was the problem ;-)


Offline rexdc

  • Active Member
  • Posts: 17
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #71 on: March 21, 2013, 03:03:05 PM »
yep you are right, my cable is not sheilded, but will be by this evening.  Also going to re-route the cable and short to get it away from other (RS-485) cables and the computer.

Offline rexdc

  • Active Member
  • Posts: 17
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #72 on: March 22, 2013, 11:56:46 PM »
Gentlemen, after changing and shortening the motor cable and doing some re-routing it, it appears that the E-stop problems have ceased.  However, I have now another problem,  it seems that if the motor is running and and the RS-485 connected the Z-axis will randomly freeze for a few steps. It won't freeze if the motor is not running and the rs-485 pluged in by removing M03 from the G-code, or if RS-485 cable is unplug and the motor running manually.  Incidentally, I don't know if this is a bug or not but if the VFDplugin.dll is loaded in Mach3 and the RS-485 cable is unplugged the program will E-stop if it encounters an M03 cammand in the G-code, even if you have the plugin disabled.  I had to delete the VFDplugin.dll before it would run code with M03 enbedded.  I checked the motor cable for noise with a scope, it seemed to be pretty quiet, however that was a lot of noise on, most of it looked like common mode noise, the worst kind to get rid of.  Being some more test tomorrow to attack the noise on the RS-485.  Just wondering, has anyone used a opto-issolated RS-485 interface, if so did it help?
« Last Edit: March 23, 2013, 01:10:55 AM by Overloaded »

Offline royaumedeole

  • Active Member
  • Posts: 36
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #73 on: March 24, 2013, 04:53:19 AM »
Hello rexdc,

I think there is a bug in the plugin if disabled. I'm going to check this.

Morevover, there is a 'simple' way to check if noise is problem:  Unplug the spindle from the VFD. Noise is generated by the Spindle.
On this way, you can check if everything is working .

If not, this is a bug and i'll fix it.

Offline rexdc

  • Active Member
  • Posts: 17
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #74 on: March 24, 2013, 09:06:51 PM »
Hi Royaumedeole

It seems that I don't proof read very well.  In my last post I was thinking faster than I type!  I believe that I was trying to say that if the VFDplugin.dll was loaded mach 3 would E-stop when encountering M03 in th G-code if it wasn't able to communicate with the VFD, even when the VFDplugin.dll was disabled. I had to completely remove the VFDplugin.dll before mach 3 would execute the G-code with M03 embedded when the VFD was disconnected.  In reference to the cables,  the way I wrote the post would lead one to believe that the common-mode noise was on the motor cable,  actually the motor cable is fairlly quiet.  In the middle of the sentence my thought had changed to the control (RS-485) cable, that was where I was finding the common-mode noise.  I have since done more checks, and believe that the Z-axis problem may be do to noise generated by the VFD somehow getting into the computer running Mach 3  because it also will lock up the keyboard.  I have some thoughts on how that is happening, but haven't had the time to pursue.  Hope to get at it tomorrow.  By the way I want to thank you for your effort in all the work you have done, I really like how this plugin works,  incidentally it is now displaying AMPS in my DRO, haven't got the speed to display yet, but again this may be on me.  Mikemaat, if you are reading this, thanks for your help also.  Lastly, has anyone used a opto-issolated RS-485 interface,  did it help.  I have one ordered so we will soon know.

Offline rexdc

  • Active Member
  • Posts: 17
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #75 on: March 25, 2013, 06:02:25 PM »
Gentleman

An update on the tests I ran today.  I am convinced the problem lays in the fact that my computer doesn't like to run the VFD through a USB to RS-485 converter.  I tried all four baud rates and different carrier frequencies in the VFD.  I use a least 3 different cables for the communications.  Anytime I was controlling the VFD form the Mach 3 program the Z-axis would freeze for a few steps at random, not good!  I have setup a kind of work around that seems to work, not what I want but for now it will have to do.  The work around basically is using the VFD in a semi-manual oreration.  There is a output from the Gecko Drive that provides AC for running a vacuum system and follows the M03  commands from the G-gode.  I connected a relay to that output that closes a set of contacts on M03 comand.  The set of contacts are connected to the VFD at For. (D1) and DCM.  I programmed PD001 for external control and PD044 to 01 (for RUN function) and PD002 to 0.  This allows the computer to start and stop the spindle and setting the speed manually.  When I get the opto-issolated interface for the serial port on the computer I will update it's function.  I'm hoping that by completely issolating the commuications line from the computer and using a real serial port will get me where I would like to be.

Offline NosmoKing

  • Active Member
  • Posts: 238
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #76 on: April 10, 2013, 02:08:25 PM »
Lack of proper grounding can cause many spurious problems such as you see, did you also confirm the spindle ground pin is actually grounded internally?
There have been some who have discovered that when the spindle was dismantled, the ground pin was  not actually in contact with  case ground.
Nosmo. 

Offline cjmerlin

  • Active Member
  • Posts: 194
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #77 on: April 12, 2013, 02:14:08 PM »
Hi Royaumedeole, I have just fitted a newly purchase Huanyang vfd with a new spindle motor and a big thank you for making the Mach3 plugin to control these vfd's.

I have the vfd communicating with Mach3, If I command an M03 the motor starts spinning and requesting various S words changes the speed of the motor of which is displayed in the speed DRO.

However there is no response to an M05 commmand, I have to click the e-stop to stop the motor. If I command an M03 or M04 the spindle of the motor only runs clockwise.

Is there a setting I have missed somewhere?

Plugin was downloaded today and is ver 1.5.1
« Last Edit: April 12, 2013, 02:15:57 PM by cjmerlin »

Offline cjmerlin

  • Active Member
  • Posts: 194
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #78 on: April 13, 2013, 12:28:20 PM »
Hi Everyone, I have found the solution to my problem and so post it here just in case someone else has similar.

When I first got interested in a plugin for the Huanyang vfd I first downloaded the other plugin written by Matty Zee. His plugin manual instructs to "Firstly, open Mach3 ‘Ports & Pins’ config dialog. On the ‘Spindle Setup’ ensure the ‘Disable Spindle Relays’ checkbox is unchecked. This is required to enable the plugin to control the spindle."

When realising that his plugin would not work for my setup I then used this new plugin but didn't realise that I needed to have the ‘Disable Spindle Relays’ checkbox, checked.

Once I had checked the box the spindle motor now works as expected with m03 and m04 doing the foward and reverse and m05 stopping the motor.

Hope this helps.

Offline TropicalGuru

  • Active Member
  • Posts: 4
    • View Profile
Re: A new Huanyang VFD plugin
« Reply #79 on: May 22, 2013, 08:52:36 AM »
Hi all,

Apologies in advance if this is an easy fix, but I'm having issues getting the plugin configured. Running Mach 3, Gecko G540 driver board, Huanyang 1.5kw water cooled spindle and VFD. Loaded the plugin no problem, and the driver Seb linked to on his site for the RS-485 USB adapter. COnfigured the plugin as per the instructions, and finally getting the "Configuration OK; SPindle speed 3000RPM at 50hz" message. All the parameters set in the VFD as per Sebs instructions. (The spindle ran fine when in manual mode and not connected to Mach 3).

What I'm getting when I try and run the spindle from the Mach 3 interface is the stats message "PWM bumped to minimum setting".

Pretty sure it's a configuration issue, anyone got any ideas?

Thanks in advance