Hello Guest it is October 16, 2019, 06:48:41 PM

Author Topic: GSim Mach4 Material Removal Simulator  (Read 36826 times)

0 Members and 1 Guest are viewing this topic.

Re: GSim Mach4 Material Removal Simulator
« Reply #40 on: January 31, 2015, 11:05:09 AM »
One option that would be nice is to add a "stock" size option.  Attached is a picture of how I did it that you are welcome to copy any/all of it if you are so inclined.

Karl
 

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #41 on: January 31, 2015, 11:19:37 AM »
Latest version, Gearotic motion runs OK, I have rerun the distrrabutables file. Loading the RR.

STILL NOJOY a blank screen. The tool Crib works fine but still no toolpathing.  I even tried rrerunning the GSIM while the GSim was loaded.  Got a LOT of info in teh History file about extents but no toolpathing.

(;-) TP

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #42 on: January 31, 2015, 11:35:14 AM »
OK a Question about viewing this in gearotic. I select a pulley and apply and it shows the rendering on screen. I then go to the WORKBENCH and I get a blank table. I did select the pulley from the project list.   AM I doing something wrong there as well ?

(;-) TP

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #43 on: January 31, 2015, 11:51:12 AM »
Another clue ? When you load teh Gsim and have teh blank page if you mouse over the screen the toolpathing widow flickers from color to black back to color at the speed ot which you are moving the mouse. It never did that before.

(;-) TP

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #44 on: January 31, 2015, 12:53:02 PM »
Terry:

  In Gearotic, you have to select the gear or pulley, then press the "Send to WorkBench" button, OR right click in the tree and
select "Send to workbench". Otherwise your just going to a empty workbench.

 For GSim, for some reason your the only one who whenm loading a file gets no entities actually loaded. The blank screen is normal
when you have no file loaded. I know you do have one loaded, but I still cant figure why the job doesnt load for you... Tiem will tell I guess.. :)

Art

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #45 on: January 31, 2015, 01:39:23 PM »
Karl:

 Excellent file for displaying what GSim can do.. Thanks for that.

(Next version shoudl be more accurate, Im working on some small issues. :)

Thx
Art

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #46 on: January 31, 2015, 02:04:42 PM »
OK Gearotic works fine. Lets make sure I copied the Gsim files over correctly.

Unzip the file and then Copy ALL teh Files including teh Folder into the PLUGINS folder.

Was I suppose to setup a SUB folder (Gsim)in the Plugins directory or just dump the files/folder into the PLUGINS folder(which does NOT sound right as it makes a jumbled mess) ??

(;-) TP

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #47 on: January 31, 2015, 02:24:38 PM »
Could it be a problem with DARWIN not being licensed ???

(;-) TP

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #48 on: January 31, 2015, 02:29:05 PM »
Terry:

  You unzip the folder.. and put the files and the included subfolder into the plugins folder. So Plugins gets the gsim.m4pw and gsim.sig, as well as glew32.dll and glut32.dll, also it gets the folder GSimSupport which has a couple files in it.. 

thx
Art

Offline ART

*
  • *
  •  1,698 1,698
  • Tough as soggy paper.
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #49 on: January 31, 2015, 02:30:26 PM »
Hi All:

 A new version, all black screens should now be gone, there is a reload button on screen, and more error messages in m4's history buffer.
This should fix more errors many may have had..

Thx
Art