Author Topic: GSim Mach4 Material Removal Simulator  (Read 35375 times)

0 Members and 1 Guest are viewing this topic.

Offline dude1

  • Active Member
  • Posts: 1,253
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #140 on: February 13, 2015, 10:51:36 PM »
you would have to what for art to answer that one

Offline ART

  • Administrator
  • *
  • Posts: 1,691
  • Tough as soggy paper.
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #141 on: February 13, 2015, 11:18:17 PM »
Karl:

  Try it in wxMach and see if the history button shows a list of debug messages from Gsim.. can you list them ?

Art

Offline nc_Karl

  • Active Member
  • Posts: 50
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #142 on: February 13, 2015, 11:21:29 PM »
what is wxmach

Offline nc_Karl

  • Active Member
  • Posts: 50
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #143 on: February 13, 2015, 11:22:47 PM »
My laptop that runs GSim is openGl ver 2.1

Offline ART

  • Administrator
  • *
  • Posts: 1,691
  • Tough as soggy paper.
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #144 on: February 13, 2015, 11:22:51 PM »
Karl:

 Sorry, missed many of those. I think you need OpenGL 1.5 or better for VBO objects, but that depends on type of card. It
may be a driver upgrade woudl help, that a pretty low GL version.. That error I think is coming from the driver, not from GSim,
I have no error with that text in it..

Art

Offline ART

  • Administrator
  • *
  • Posts: 1,691
  • Tough as soggy paper.
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #145 on: February 13, 2015, 11:23:37 PM »
wxmach4.exe is the non-gui version of mach4.. but that isnt it. Im pretty sure its your opengl version..

Art

Offline dude1

  • Active Member
  • Posts: 1,253
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #146 on: February 13, 2015, 11:23:50 PM »
its in M4 file on C drive bottom of the list

Offline nc_Karl

  • Active Member
  • Posts: 50
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #147 on: February 13, 2015, 11:40:54 PM »
It appears to crash at the exact same point with no ability to read anything except the frozen history window "GSim contex: X:11024 Y:845"

Karl

Offline nc_Karl

  • Active Member
  • Posts: 50
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #148 on: February 14, 2015, 12:08:01 AM »
The tablet that runs GSim is openGL ver 4.0 with 178 extensions.  Until I can update the video card in the new machine, we'll have to put this discussion on hold.  And I'm off to watch grown men play with antique tractors in Florida for a week.  So I'll check back then.

Thanks again Daniel and Art

Karl

Offline nc_Karl

  • Active Member
  • Posts: 50
    • View Profile
Re: GSim Mach4 Material Removal Simulator
« Reply #149 on: February 14, 2015, 12:58:38 PM »
Art

   You, once again have hit the nail on the head!!  I couldn't go to Florida without knowing if a newer OpenGL solved the problem.  So this morning I got up early and drove an hour to to a computer store and picked up a new video card with OpenGL4.4.  Not only do I get no more error messages, it fires right up and WOW does it fly!  It is now running faster in the GSim than I could cut it.  You put my laptop next to the new box and it is unbelievable

One more time Art, Thanks

Karl

Ps thanks to Daniel for your help in this matter also.