Author Topic: Newbie to cnc building in need of some help please  (Read 617 times)

0 Members and 1 Guest are viewing this topic.

Offline scooternauman

  • Active Member
  • Posts: 35
    • View Profile
Re: Newbie to cnc building in need of some help please
« Reply #60 on: January 20, 2019, 02:05:28 PM »
same thing happens with p2 to ground and p4 to ground so it would appear the controllers are fine?

Offline TPS

  • Active Member
  • Posts: 1,122
    • View Profile
Re: Newbie to cnc building in need of some help please
« Reply #61 on: January 20, 2019, 02:10:02 PM »
same thing happens with p2 to ground and p4 to ground so it would appear the controllers are fine?

yes that means all Motor Controllers are working.

i would now Z axis P6/P7 as shown in my Video

step- and dir- to GND
step+ to P6
dir+ to P7

that is one of the last ideas now

don't Forget to Setup p6/p7 in Port's&pin's

anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline scooternauman

  • Active Member
  • Posts: 35
    • View Profile
Re: Newbie to cnc building in need of some help please
« Reply #62 on: January 20, 2019, 02:39:51 PM »
I'm not sure about the ground idea.
this is how I am wired and it matches the schematic you linked earlier
x axis=
PUL+ to  5 volt power supply
PUL-  to  P2
DIR+ to  5 volt power supply
DIR-  to  P3
ENABLE to 5 volt power supply

Y axis=
PUL+ to  5 volt power supply
PUL-  to  P4
DIR+ to  5 volt power supply
DIR-  to  P5
ENABLE to 5 volt power supply

Z axis=
PUL+ to  5 volt power supply
PUL-  to  P6
DIR+ to  5 volt power supply
DIR-  to  P7
ENABLE to 5 volt power supply


Offline TPS

  • Active Member
  • Posts: 1,122
    • View Profile
Re: Newbie to cnc building in need of some help please
« Reply #63 on: January 20, 2019, 03:46:54 PM »
i mean how it was shown in the two Videos

PUL+ to  P2
PUL-  to  GND
DIR+ to  P3
DIR-  to  GND
ENABLE to 5 volt power supply

and so on

i am out for today, it is getting late here.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline scooternauman

  • Active Member
  • Posts: 35
    • View Profile
Re: Newbie to cnc building in need of some help please
« Reply #64 on: January 20, 2019, 04:27:04 PM »
Hey thanks again for all your help. Progress was made. Have a great evening.
 I just tried wiring with a common ground as shown in the videos.
Still no movement from motors.
TTYL

Offline TPS

  • Active Member
  • Posts: 1,122
    • View Profile
Re: Newbie to cnc building in need of some help please
« Reply #65 on: January 21, 2019, 02:44:01 AM »
somethings amiss here.
p2 on the breakout board is a steady 1.58 volts in both directions.
p4 is at 1.54 in both dir
so it seems there might be an issue with p2 and p4?

here you can a test of the 25pol cable to make sure that P2 and P4 are connected here.

and for additional testing i think a oszlisocope is needed to check P2,P4 and P6 that there
a pulse stream is created.

anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline scooternauman

  • Active Member
  • Posts: 35
    • View Profile
Re: Newbie to cnc building in need of some help please
« Reply #66 on: January 21, 2019, 04:57:48 AM »
So I wanted to rerun the testing of the pins on the drive side before work this morning. It appears I had something wrong the first time.
All pins 2-9 are acting as they should. 5.12 volts in the "on" dir. and 1.1 volts in the "off" dir.
I tested all pins twice.
Once with the drives disconnected.
Once with the drives connected.
Same results both times.
Off to work I go.
TTYL