Hello Guest it is April 12, 2021, 07:16:27 PM

Author Topic: Mach3 mit USB-Steuerungplatine Probleme  (Read 2917 times)

0 Members and 1 Guest are viewing this topic.

Offline TPS

*
  •  2,102 2,102
    • View Profile
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #30 on: August 30, 2020, 04:10:53 AM »
So, jetzt habe ich mir die Beschreibung noch mal angeschaut.

Die Ausgänge sind minus schaltend, soll heissen ein angeschlossenes Relaise muß für die 24V Versorgungsspannung ausgelegt sein, und nicht für 5V. An dem A1(+) Eingang des Relaise liegen
dann immer 24V an, und der A2(-) EIngang des Relaise wird geschaltet.

Zur Ansteuerung der Ausgänge.
Sagen wir mal Output3 ist die Kühlung,
dann in Config -> Ports&Pins -> Output Signals den Output3 enabeln Port auf 3 und Pin auf 3 stellen.
nun noch in  Config -> Ports&Pins -> Spindle Setup sicherstellen, das Disable Flood/Mistrelaise nicht ausgewählt ist, und bei Flood M8 Output eine 3 steht.

Nun solltest Du schon mal auf der Diagnostic Seite den output3 rot blinken sehen, wenn Du im oberen linken
Teil den Flood toggle Button drückst, dann wäre das schon mal geprüft.

Gruß Tom
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline TPS

*
  •  2,102 2,102
    • View Profile
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #31 on: August 30, 2020, 04:17:10 AM »
Noch ein Ergänzung. Wenn Du nichts an dem Ausgang angeklemmt hast wirst Du da keinen Signalwechsel
messen können, da ich auf den Bildern keinen Pull Up Widerstand erkennen kann. Die Spule des Relaise wirkt
dann erst als Pull Up. Ohne Relaise müsstest Du einen 10k Widerstand zwischen Ausgang und 24V+ hängen,
um was messen zu können.

Gruß Tom
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline TPS

*
  •  2,102 2,102
    • View Profile
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #32 on: August 30, 2020, 04:23:16 AM »
Dieser Teil des Anschlussplans zeigt, das das Relaise an +24V hängt.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #33 on: September 02, 2020, 02:19:31 AM »
Hallo TPS
Das Relais ist nicht an 24V angeschlossen, sondern am 5V Ausgang der Platine. Wenn ich in Diagnostic den Button für Ausgang 3 oder 4 betätige leuchtet auch die Kontrolle (nicht blinkend). Eine Frage dazu. Ist die Kontrolleuchte nur da um kenntlich zu machen, dass der Ausgang funktioniert oder müsste auch die Wasserpumpe anlaufen, wenn ich den Output Button betätige?

Offline TPS

*
  •  2,102 2,102
    • View Profile
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #34 on: September 02, 2020, 02:48:21 AM »
Hallo,
bei allen Beschreibungen zu der Karte, die gefunden habe hängen die Relaise an der Versorgungsspannung 12/24V.

Die Outputs Anzeige im Diagostic Screen sagt nur aus, das Mach3 den Ausgang geschaltet hat, ob das an der
USB Platine ankommt ist eine andere Frage.

Schaue Dir das mit dem Verdrahtungsplan der Platine noch mal an, die Ausgänge funktionieren nur, wenn die
externe 12/24V Versorgung angeschlossen ist, und das Relaise an dieser hängt.

Wie ich bereits geschrieben habe die eine Seite des Relaise an + der Versorungsspannung, und die andere am Ausgang. Siehe mein Bild aus  Reply #33 .
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline TPS

*
  •  2,102 2,102
    • View Profile
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #35 on: September 02, 2020, 07:08:04 AM »
Hier habe ich noch was gefunden:

https://www.youtube.com/watch?v=Qi4M3DAtTXg

zeigt auch klar, das das Relaise mit 24V betrieben wird.

anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline TPS

*
  •  2,102 2,102
    • View Profile
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #36 on: September 16, 2020, 03:49:41 PM »
irgendwelche Neuigkeiten?
some new informations?
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #37 on: September 30, 2020, 11:14:25 AM »
Hallo Tom
Ich habe mir ein 24V Relais beschaft und diese wie vorgesehen angeschlossen. Wenn ich in Diagnose den Schalter für die Kühlung betätige leuchtet auch die Diode. Ich habe am Relais die Wapu angeschlossen und in Manual den Befehl M07 eingegeben. Leider ohne Erfolg, das Relais schaltet nicht.
Kannst du mir sagen wie die Input für die Homeswitsches geschalten sind? An der Klemme Input 3 liegt im Normalfall 24V an, also werden diese dann gegen DCM geschaltet? Im Schaltplan sind die Schalter paralell geschaltet, sodass ein Schaltvorgang ausgelöst wird wenn einer der Schalter schließt. Das würde bedeuten dass keine Kabelbruchsicherung vorhanden ist. Im Umkehrfall müssten ja die Sensoren in Reihe geschaltet werden. Kann das in Mach3 eingestellt werden dass die Input im Ruhezustand geschlossen sind und erst beim öffnen den Schaltvorgang erzeugen? In Mach3 habe ich IN3 den Port 3 sowie PIN 3 zugewiesen und auf aktiv eingestellt. Ich habe einen Sensoren NPN Nc angeschlossen, da reagiert überhaupt nichts (auch nicht die Dioden am Sensor). Dann habe ich es mit PNP NO versucht. Da wird vom Sensor auch bei Annäherung an Metall ein Schaltvorgang ausgeführt, aber der Verfahrvorgang wird auch nicht angehalten. Hier liegen im Ruhefall an der Klemme IN3  etwa 14V an und wenn der Sensor schaltet geht dies auf 24V hoch.
Ich habe beide Sensoren jeweils braun auf 24V, blau auf DCM und schwarz auf IN3 geklemmt. Was habe ich falsch gemacht, oder wo ist mein Denkfehler? Wenn schon die Spindelansteuerung und die Relaisfunktion nicht funktioniert sollten zumindest die Rev-schalter funktionieren um mit den Softlimits die Maschine abzusichern.
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #38 on: October 01, 2020, 04:47:50 AM »
Hallo Tom
Ich habe nach einigen Versuchen den Anschluss der Ref-Schalter erreicht. Ich habe die Sensoren NPN NC genommen. In Mach 3 habe ich die Home Schalter auf Enable, Aktiv und aut. Ref gestellt. Die Sensoren habe ich mit 24V auf die braunen Kabel versorgt. Die DCM und die Leitungen für IN3 habe ich in Reihe geschalten. Damit funktioniert die Referenzfahrt und die Kabelbruchsicherung ist auch vorhanden.
Ich danke für Deine Hilfe
Gruß Dieter

Offline TPS

*
  •  2,102 2,102
    • View Profile
Re: Mach3 mit USB-Steuerungplatine Probleme
« Reply #39 on: October 01, 2020, 04:53:03 AM »
Hallo Dieter,
jetzt noch mal zu dem Relaise.

Als erstes must Du in Config -> Ports&Pins -> Outputs die
Daten für die Ausgänge eintragen

Output1 Port 3 Pin 1
Output2 Port 3 Pin 2
Output2 Port 3 Pin 3
Output2 Port 3 Pin 4

dann unter Config -> General Config -> Spindle Setup
bei Flood Control in der Zeile Mist M7 den Ausgang (1-4) eintragen, an dem das Relaise hängt.
Dann sollte das klappen.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.