Hello Guest it is October 19, 2021, 07:53:57 PM

Author Topic: Mach3 + Galil  (Read 119217 times)

0 Members and 1 Guest are viewing this topic.

Galil mpg configuration
« Reply #130 on: May 09, 2010, 10:03:39 AM »
I need help I have a Galil 4080 with an additional encoder wired to aux channel b/y second axis and can not get
any response from Mach3 . I see it in the diagnostics panel as a functioning encoder. I enable MPG mode but nothing.
The axis is functional in the continuous mode . IE keyboard but I don't know if I should be configuring it in
Galil as a E/slave gearing or I just missed something in Mach3 setup with he Galil plug in setup. again HELP please
Re: Mach3 + Galil
« Reply #131 on: May 09, 2010, 10:38:59 AM »

I have a motion control card MPU 11 from Ajax out puting +- 10V
I can get a copley servo amp for example, and drive a AC servo motor or DC servo motor.
Just want to understand what the +- 10V drives in terms of servo amp output.

jim

I set my drives up in the Torque mode as suggested by Galil etc, in this mode the drive is known as a Transconductance amplifier, simply put, the current out is directly proportional to the analogue voltage input.
Nosmo.
Re: Mach3 + Galil
« Reply #132 on: May 26, 2010, 05:44:53 AM »
can anyone help with this?
i have to set lots of i/o
using setuserled(1000,1) etc switches on  output 1, setuserled (1000,0) turns it off (i started my user leds at 1000 for outputs)
i have this working fine on the bench
using vb script to make an mcode is it possible to use one mcode followed by the output number (eg m100-1015 ) to switch output 15 on
or M101-1015 to switch that output off.
m100-1020 m101-1020 etc top switch output 20
wanted to see if this was possible rather than writing 2 seperate mcodes for each output
if anyone has ideas on this could they share please.
im using a galil 2280 with galil 1964 opto output breakout plus 2 off icm 1900 for everything else
any better ideas? how are other people doing this sort of thing?
if its not broken yet, fit more gadgets!
Re: Mach3 + Galil
« Reply #133 on: May 26, 2010, 04:05:41 PM »
also having trouble getting a delay between outputs
tried g4 p5 etc but it seems to skip it in a running code (but seems to work if you step through the script)
someone please help im pulling my hair out and i dont have much left!
if its not broken yet, fit more gadgets!
Re: Mach3 + Galil
« Reply #134 on: May 26, 2010, 04:13:28 PM »
here is a trial sample program im running

aaa=1
While aaa<33
Setuserled(1000+aaa,0)
code "g53 x0"
code"g4 p0.5"
code"g53 x0.5"
code"g4 p0.5"
aaa=aaa+1
Wend

aaa=32
While aaa>0
Setuserled(1000+aaa,1)
code "g53 y0"
code"g4 p0.5"
code"g53 y0.5"
code"g4 p0.5"
aaa=aaa-1
Wend
End

can anyone see whats wrong with it?
i need to write a tool change routine but need the outputs switched on in sequence with moves etc so i cant have all outputs coming on or off like this.
if i put end in the gap in the middle of program it just switches outputs once :'(
if its not broken yet, fit more gadgets!
Re: Mach3 + Galil
« Reply #135 on: May 27, 2010, 02:04:06 AM »
Battwell,

  I am a complete novice, so take this with a grain so salt.  I am very much just starting to learn macro editing in mach.

I think your moves run into eachother.  Without a While IsMoving/Wend after each move, it immediately feeds that data into Mach.  A few milliseconds after you initially told mach "G53 X0", you told it to dwell for 0.5 seconds.  Without the While Ismoving/Wend, these two commands pretty much happen simultaneously, that is, the 0.5 second clock started at the same time as the initial "G53 X0" command. 

I realize you would break syntax if you tried to put the While IsMoving/Wend command within your current conditional loop (after each motion, to inhibit any commands until complete).  Perhaps you could, instead of the { Code "G4 P0.5"} command, try a {Sleep 500} command. Of course, you would want to add the required motion time to that number.

I would love to hear the correct answer, so I will be watching this thread.

Cheers!

Rob
Re: Mach3 + Galil
« Reply #136 on: May 27, 2010, 05:13:16 AM »
im going to give it another try today. now ive read the programming guide!
never done vb before
attatched the very useful guide!
if its not broken yet, fit more gadgets!
Re: Mach3 + Galil outputs
« Reply #137 on: May 27, 2010, 06:55:33 AM »
ok. this worked right.
aaa=1
While aaa<33
Setuserled(1000+aaa,0)
sleep(500)
code "g53 x0"
While ismoving()
Wend
code"g53 x0.5"
While ismoving()
Wend
aaa=aaa+1
Wend
While aaa>0
Setuserled(1000+aaa,1)
sleep(1000)
aaa=aaa-1
Wend
End

switches off outputs and sequences with moves in x, properly timed
then switches inputs back on in reverse order timed at 1 second intervals
thank god for written idiot guides!

one thing i noticed. couldnt stop the program when it was running? is there something to write into code so space bar or escape gets you out of vb loop?
if its not broken yet, fit more gadgets!
Re: Mach3 + Galil
« Reply #138 on: June 01, 2010, 09:30:33 PM »
Hello, I am a newbie in this forum and I am looking for help with running a mill on mach software. this machine has a Galil DMC 1030 card.
Re: Mach3 + Galil
« Reply #139 on: June 01, 2010, 11:31:17 PM »
I think you are out of luck, the legacy DMC-1000 ISA series is not supported by Mach.
I have about half a dozen of these cards.
Pity, because they are CNC capable.
Interface can be written using the VB files available from Galil.
Nosmo.