Hello Guest it is October 03, 2023, 10:56:38 PM

Author Topic: Mach3 + Galil  (Read 129010 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach3 + Galil
« Reply #30 on: January 24, 2007, 02:51:41 PM »
Hi Drew,

It's my understanding that Barry's plugin works with the 1800's (PCI) and that Art is busy with the 2100's (Ethernet) I don't think anyone is busy with a USB version.

Re: Mach3 + Galil
« Reply #31 on: January 24, 2007, 03:14:54 PM »
Hi there, I think greg is right, 21xx 22xx...(ethernet), pci ones work with mach3 20xx etc do not....

thanks for the turret control info....I am getting closer to trying that, the plugin is not quite there for the I/O but sounds like a pretty simply macro will work . the Galil that I have (2130) has 8 normal uncomitted ins and outs +64 extra I/O that can be ins or outs...so no worries about not enough....

right now I am using 12 outputs

vfd fwd
vfd rev
clutch high
clutch low
vertical slide
collet open
collet closed
parts catcher
turret index
turret stop

inputs are as follows: 8
turret encoder (4)
turret down
spindle lock
main pressure
collet closed (pressure)

any pushbuttons  and indicators I may want on the control.....

as I understand it my third axis will control the 0-10v that my vfd needs for speed control...I also have mounted a encoder on the spindle
that Brian says should be able to work with mach3 for threading....good luck, Roo
« Last Edit: January 24, 2007, 03:20:03 PM by roodesign »

Offline drew

  •  79 79
    • View Profile
Re: Mach3 + Galil
« Reply #32 on: January 25, 2007, 11:53:16 AM »
Don't forget your vertical slide down LS (input).
Plus with all that IO you can check you vfd for up to speed and falt/error.
I also use a spindle enable ssr(monintary on by macro) to a mechanial relay that self latches this pulls in the motor starter that you don't need with a VFD. E-Stop releases the self latching relay and the motor starter so the spindle won't turn till the ssr resets the self latching relay.
If I had something important to say it would be here.

Offline drew

  •  79 79
    • View Profile
Re: Mach3 + Galil
« Reply #33 on: January 25, 2007, 11:58:54 AM »
How big of a job would it be to recode a enet plugin to use usb? I would think that once you got the communication setup that most of the other code for axis and IO would be the same as I'm almost positive the enet and usb use the same command set. But I know ZERO about mach3 plugin's. Although I'm sure timming will play a role here too.
If I had something important to say it would be here.
Re: Mach3 + Galil
« Reply #34 on: January 25, 2007, 02:06:43 PM »
If there dll will hookup and find a usb version it should work... But I have no idea if it will or not so please don't buy one to test!
Fixing problems one post at a time ;)

Re: Mach3 + Galil
« Reply #35 on: March 03, 2007, 03:44:11 PM »

I just bought and installed Mach3 along with the Galil plugin.  Mach3 is ver R2.0.050 and the Galil plugin is ver .1a.  This is in a Dell P4 1GHz with 1G ram.  The Galil hardware is a DMC-1840 (PCI bus 4 axis) driving AMC analog (+/- 10V command) servo amps.

I had two Galil registry entries originally, and Art told me the Galil plugin would use only the first entry.  I deleted the unnecessary entry (for other TCP/IP remote I/O hardware), and that got the driver to load and motors moving.

I can now get the motors to run using Mach3, but the position displays in Mach3 show no motion.  If I change the display to "distance to go", they do show motion.  There is always a message "status 21 begin not valid while running" displayed either for MDI moves or when running a program.  Also, feed override has no effect.  Programmed feedrate does seem to work.

I have config'd the Galil plugin options for motor type as servo.  I have no clue what the other settings do.

I have no idea how to set ports & pins for use with the Galil plugin, or any other necessary I/O settings necessary to work with the Galil board.  None of the guesses I have tried have any effect on the problem.  Is there any documentation available to show any of the settings for use with the Galil plugin?  I am familiar with the Galil DMC-*********X programming language, and the card works perfectly with Galil's Smarterm program.

What am I missing here?

I'm really anxious to get this system working.  I have already spent many, many hours trying to figure out the correct settings without much luck. 

Thanks in advance for any clues you can share...

Re: Mach3 + Galil
« Reply #36 on: March 03, 2007, 04:14:21 PM »
Hi Lowrange, I thought I would chime in a little....
I can't help you with the axis issues...I have my settings as follows....

motor tuning window....

steps per...whatever your encoders are....my case 50,000 per inch...
I have about 70 max ipm and acell at about 35

plugin config....I did not check use other than actual feedback for display...
I did check use programmed feedrate....

the two other commands which are dmc commands, I believe,   are about decelaration..I have mine set at 1.3, and 75,000...

ports and pins:

galil outputs are port 1 pins 1-8 and inputs are port1 pins 1-8 (I have the extended I/o on my controller and have not been able to get those to work yet...note that as of yet things like the spindle setup under ports and pins will only let you use the first 6 inputs....I made buttons in mach for the outputs that are above 6, in my case spindle fwd and reverse...all of the limits, and inputs and outputs work...that being said, my galil is a 2130 ethernet not pci,

hope some of this info helps....I could not get an accuracy issue figured out till I played with the decell settings in the plugin config...also, if I change the plugin settings sometimes, the galil gets messed up and wont move..I go to smartterm and reset the controller....(not master reset!) that cures that...let me know if I can help any...

Roo Trimble, Roodesign :)
Re: Mach3 + Galil
« Reply #37 on: March 03, 2007, 04:33:25 PM »
Thanks Roo,

I'll give these clues a try.  What is your address setting for port 1?  I have tried changing mine to the base address of my Galil card, but it seems to have no effect...


Re: Mach3 + Galil
« Reply #38 on: March 04, 2007, 07:21:49 PM »
Hi there, not at the machine at present, but I think that Brian said that you ignore all that stuff about ports when using a galil...at least for the ethernet one....I am guessing pci too...I do not have any of that stuff checked, or the p-port driver loaded...hope that helps...Roo
Re: Mach3 + Galil
« Reply #39 on: March 04, 2007, 08:05:18 PM »
Thanks again for your help Roo.

Setting the Galil plugin config move settings "Vetor Time Const" to 1.3 and "VectorDeceleration" to 75000 did help with the motor response.  The motor would overshoot badly with these at the defaults, and jogging had severe overshoot (3-4 seconds extra) if the jog buttons were held for more than about .5 second.  I found that a setting for "VectorDeceleration" of 250000 actually seems to work the best.

These changes did make me notice another problem - the setting for "VectorDeceleration" will not stay set.  It reverts to a setting of "1" every time I exit Mach3 and then reopen Mach3.  The "Vetor Time Const" setting does stay as I set it, but not "VectorDeceleration".

This has no effect on any of the issues I mentioned before - primarily no display of motion in position displays in Mach3.

All my original problems remain.

I still need help...

Thank you,