Hello Guest it is September 15, 2019, 02:52:35 PM

Author Topic: New PlugIn just about done..  (Read 144006 times)

0 Members and 1 Guest are viewing this topic.

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: New PlugIn just about done..
« Reply #90 on: July 26, 2009, 09:37:18 PM »
if you look at the "Drop down" list, you will see that the drop down puts it in numerical order, and the 800 series are in the middle, that will shift all your other OEM button choices by 6 down.

How about the Reverse Jog axis buttons, the thought here is that when you tick the reverse (for some axis), that if it was going ++ with that push, it will now go --

scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/
Re: New PlugIn just about done..
« Reply #91 on: July 27, 2009, 12:46:18 AM »
if you look at the "Drop down" list, you will see that the drop down puts it in numerical order, and the 800 series are in the middle, that will shift all your other OEM button choices by 6 down.

How about the Reverse Jog axis buttons, the thought here is that when you tick the reverse (for some axis), that if it was going ++ with that push, it will now go --

scott

Scott,

I'll give reverse axis a try in the AM.

Regards,
Ray L.
Regards,
Ray L.

Offline lemo

*
  •  139 139
    • View Profile
Re: New PlugIn just about done..
« Reply #92 on: July 27, 2009, 02:48:40 PM »
Just saw this.... YOU DA MAN!!! YEAHHH!!! I'll test it right away! Very nice of you to run it through the compiler. I looked at EBay and there is only some joker selling an old license  for $700... pfffffff
Lemo
Cut five times and still to short...

Offline budman68

*
  • *
  •  2,360 2,360
    • View Profile
Re: New PlugIn just about done..
« Reply #93 on: July 27, 2009, 03:01:16 PM »
Scott, I truly appreciate your effort and tested this out a bit. None of the reverse jogs are working for me nor is assigning the macros. Now let's wait until the others try theirs out as I could possibly be doing something out of order or something.

I installed the plug-in and the configure screen comes up just fine but when pushing a button for a specific macro, Mach 3 screen says that it's been executed but nothing happens.

Thanks again, Scott, it's probably just me.......... :D
Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)

Offline budman68

*
  • *
  •  2,360 2,360
    • View Profile
Re: New PlugIn just about done..
« Reply #94 on: July 27, 2009, 04:46:33 PM »
So I went back out to the shop and tried reinstalling the old plug-in and then copied my old shuttle dll file over the one in the plug-ins folder and now I can't even save either of the 2 macros that were originally available.

So I'm thinking the issue is me and my shuttle config is now borked as well. I hate these macros as I just don't mess with them enough. I'm going to try to delete the plugins and start from scratch again.

Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: New PlugIn just about done..
« Reply #95 on: July 27, 2009, 09:58:43 PM »
OK,

    Here is Version 2 of the Shuttle pro upgrade attempt.......  as stated above, there was some jog code that I didnt get into, cause I was unsure what it went to
(since I dont have a shuttle pro to test with).  At any rate, I put in some individual axis direction reversal code (if you choose it), in that jog code as well. I think the others that I did where for the 810 and 811 "button Choices" only.  (not the wheels).

so here is the plugin, please test and let me know.......  If this one fails, I will just post up the Source (my modified source that is), and someone else who actually HAS a shuttle Pro can see where I am goofing up and debug it.

scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: New PlugIn just about done..
« Reply #96 on: July 28, 2009, 08:18:02 AM »
I see some downloads.....  so is the Reverse axis jogging options working now??  I had one guy tell me the Macros are working...

Feed back would be MUCH appreciated!!!

scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/

Offline GaryB

*
  •  108 108
    • View Profile
Re: New PlugIn just about done..
« Reply #97 on: July 28, 2009, 08:42:00 AM »
Thanks for the shuttle upgrade Scott.
downloaded & am still testing, macros are working well as with most other commands. Still to run through a lot yet.

The old bug that popped up a year or so ago is still there. That is if you select the large black buttons left and right of the wheel and program to "Rapid ++" and "Rapid --" they intimately act as a toggle button. If you move the Rapids to the silver buttons below the wheel they work fine. Any chance you can locate that one while your in there adjusting things?

thanks G.
« Last Edit: July 28, 2009, 09:25:55 AM by GaryB »
Beckwith Decor Products
ArtCam Trainer
Onsrud & Custom CNC tooling Distributor

Wichita/Derby Kansas
http://www.beckwithdecor.com
Re: New PlugIn just about done..
« Reply #98 on: July 28, 2009, 09:04:51 AM »
Scott

   I am in the process of building my machine now so I have been testing the plugin with MACH not being connected to a machine. That said everything I have tried has worked 100%. Reversing the axis worked fine and the macros I added worked well also.

   I would like to thank you for taking the time to make this upgrade to the shuttle pro. For my application the two macro that the old plugin allowed was not enough. So I was looking into other pendants.  Now this will allow me to set up my pendant as I wanted.

Great job !!!!

Thanks
Sam

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: New PlugIn just about done..
« Reply #99 on: July 28, 2009, 10:15:09 AM »
Gary:

    I looked at the 810, 811 again, and really dont see any reason for that bug, they are just standard jog commands, dont see any toggle code in them.

Sam:

  Thanks.

Scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/