Hello Guest it is September 17, 2019, 09:13:26 AM

Author Topic: New PlugIn just about done..  (Read 144025 times)

0 Members and 1 Guest are viewing this topic.

Offline budman68

*
  • *
  •  2,360 2,360
    • View Profile
Re: New PlugIn just about done..
« Reply #120 on: August 06, 2009, 05:09:11 AM »
Wow, now that's weird, wonder what's causing that, as it happens on all 3 axis.

Dave

Dave,

You just seem to be jinxed.  It works fine for me, at all jog rates.

Regards,
Ray L.


Well Ray, I found out this morning that I'm not jinxed  ;)

http://www.machsupport.com/forum/index.php/topic,12163.new.html#new

Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)

Offline Greolt

*
  •  956 956
    • View Profile
Re: New PlugIn just about done..
« Reply #121 on: August 06, 2009, 05:22:23 AM »

Normal mode working perfectly / Without the reverse function checked:

1) .34  2) .64  3) 1.61  4) 3.23  5) 8.06  6)16.09  7) 32.17


Now this is how it is WITH the reverse function enabled:

 1) .34  2) 0    3) 1.61  4)0       5) 8.06   6)0        7) 32.17

Notice how I get 0 IPMs for the 2, 4, and 6 increments?

Hey this is exactly what is happening for me too.  When an axis is not reversed (normal) it works as it always did.

But when an axis is reversed then it is just as Dave is seeing.

Greg

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: New PlugIn just about done..
« Reply #122 on: August 07, 2009, 05:51:48 PM »
The New, (new), ShuttlePro plugin is up in the Finished downloads section under that post.

I removed the "Reversable Axis" stuff, it appears that I was unable to fix it.......

BUT, the new one still has 10 macros, and NO reversabel axis.

scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/

Offline budman68

*
  • *
  •  2,360 2,360
    • View Profile
Re: New PlugIn just about done..
« Reply #123 on: August 07, 2009, 06:43:34 PM »
Thanks, Scott  8)

Just a thought, maybe you'd want to make both of the plug-in versions available since, for some reason, reverse works correctly for some of these?

Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: New PlugIn just about done..
« Reply #124 on: August 14, 2009, 09:11:25 AM »
Dave,

     I understand, but you have run into the problem that always bother me, you CAN'T get feedback for the most part on this site. I have asked for feedback for this or that, and only 1 or 2 people reply.  I guess no news, is good news.........  For instance, I had asked users of Mach MAD to email me or post how they like using it, what they are using it for etc........  I think I had ONE reply...  It is furstrating in a way. Myself and others here, release stuff (often for free), to help out the community at large, but you cannot tell if they like the stuff, or what. You see the downloads but dont see any comments....... 

(Unless there is a problem......... I guess.........)

scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/
Re: New PlugIn just about done..
« Reply #125 on: September 09, 2009, 12:44:32 AM »
Just got the Shuttle Pro and hooked it up to mach3 with surprisingly little problems. In fact I would say zero problems. I just installed the plugin and connected the shuttle pro and every button worked!

One thing though. The outside round wheel is great but the jog rates it chooses are not. If I rotate it all the way to one direction, I jog at full speed, but the increments it chooses between zero and full speed are not great. Is there a way to change how the jog speed increments that are assigned to the outside wheel? Also, this leads me to my next question. The outside jog wheel is discrete in the jog speeds that it allows. I think i counted about 5-6 speeds that are increasingly quick as you rotate the wheel all the way to one direction. Is there any way to make this continuous such that instead of there being only 5-6 speeds, the speed of the jog would be a continuous function of the wheel position?

and not to sound like i'm complaining, I really appreciate that someone spent so much time writing up this plugin. It works great!

thanks,

- Will

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: New PlugIn just about done..
« Reply #126 on: November 24, 2009, 09:17:45 AM »
To all who worked on this feature, THANKS! It works great, it was easy to set up for a complete novice (though with all the late nights reading here and on the other forums when will I be an apprentice?). It sure is nice to stand right at the machine move the tool to touch the part, zero out, start running a file or even to just machine manually with incremental precision. BTW can I turn in my "Total time spent logged in" to some university and get a degree? Seems more effective here than in a classroom and I get to test yalls answers immediately. Thanks
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: New PlugIn just about done..
« Reply #127 on: November 26, 2009, 12:21:19 PM »
Just a side note,  I sent the version of this shuttle pro (source with the macros and (the axis reversal stuff)), to Brian, and he is going to UPGRADE it to the Version 4, Plugin format (and send it back to me so I can see all the new changes), but it appears that the Shuttle Pro will carry forward with the Macro additions etc. to the new Mach as well......

scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/

Offline RICH

*
  • *
  •  7,358 7,358
    • View Profile
Re: New PlugIn just about done..
« Reply #128 on: November 26, 2009, 09:32:56 PM »
scott,
"It is furstrating in a way. Myself and others here, release stuff (often for free), to help out the community at large, but you cannot tell if they like the stuff, or what. You see the downloads but dont see any comments....... "

I would not let it bother you and also know where your coming from. Just continue doing what you enjoy doing since you have posted a lot of things that are being used and enjoyed by many. That said,
 I surely appreciate the amount of time you have spent on some of the plugs ins.
RICH
Re: New PlugIn just about done..
« Reply #129 on: January 04, 2010, 04:25:45 AM »
poppabear, Greolt, budman68.... thankyou so much for providing this mod. 
It was very quick and easy to setup and I am simply chuffed with having such a pendant supported.  Very appreciated ;-)

Thoughts for future changes... Instead of Zero All, I'd prefer Zero X/Y as one button.  Not a big one, I'II just get into the habit of tool zero after setting X/Y

I would prefer to have it default at startup as incremental step, rather than assign a button to the "Cont/Inc Center Mode" function.  It might be worth adding a comment to the setup guide for others who might get confused at first.  As well as mentioning to set the jog step to what they want and also to set slow jog to 100% to make best use of the outer wheel.

I would really like to have override inc/dec on spindle RPM.  I like having the ability to adjust both feedrate and spindle RPM to get a good chip load, and that is best done while the chips are hitting the googles, pendant in hand :)
I'II have to look into assigning a macro for the job.

Once again, thankyou all.... thumbs up!