Hello Guest it is October 19, 2019, 01:49:42 AM

Author Topic: OEM codes for buttons, DRO's and LED's  (Read 152717 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
OEM codes for buttons, DRO's and LED's
« on: April 27, 2008, 04:07:52 AM »
The xls contains a list of OEM codes for buttons, LEDs and DRO's. If any more are known that are not in the list please let me know and I will alter and re attach it for all to use.
Hood


Another version of the list can be found in this post. Read the post the newer list is in for more info.

http://www.machsupport.com/forum/index.php/topic,6657.msg90480.html#msg90480

Edit: Added link
Brett
« Last Edit: January 14, 2010, 05:49:59 AM by Chaoticone »
Re: OEM codes for buttons, DRO's and LED's
« Reply #1 on: April 30, 2008, 11:40:36 PM »
Hey Hood!

Thanks for posting that! Good Stuff!

I have an embarassingly lame question...  Is there an OEM code for 'Fast' Jog.  I'm not even really sure if I am using the correct terminology.  It's when you hold down the Shift button and jog your machine.  Or maybe there is an OEM code for the shift button?

I hope I am making myself clear- if not let me know and I'll try and think of a better way to say this.

Thanks,
Sid

Offline Chaoticone

*
  • *
  •  5,607 5,607
  • Precision Chaos
    • View Profile
Re: OEM codes for buttons, DRO's and LED's
« Reply #2 on: May 01, 2008, 05:34:20 AM »
I think toggle override of rapid feeds 287 may be what your looking for. 

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: OEM codes for buttons, DRO's and LED's
« Reply #3 on: May 01, 2008, 02:38:55 PM »
Thanks Brett!  I tried it but it's not quite what I needed.  I wanted to be able to toggle between slow jog and rapid jog using the shuttle but, No worries- I've got PLENTY of time!  ;)

Regards,
Sid

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: OEM codes for buttons, DRO's and LED's
« Reply #4 on: May 01, 2008, 07:03:23 PM »
The list has been updated with more stuff that Chip pointed out was on the wiki.

Hood

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: OEM codes for buttons, DRO's and LED's
« Reply #5 on: May 01, 2008, 07:05:30 PM »
Sid
 sorry dont know :( if its not in the list then you may have to resort to making a VB button to change the feedrate DRO, not great at VB but it should be possible.
Hood
Re: No Z Axis forward in Turn3
« Reply #6 on: May 15, 2008, 09:28:36 AM »
Hi ;)
 
    Just a quick question about Z Axis motor in Mach3Turn3. I have been using Mach3Mill on my router for a couple years and I just decided to mount a couple stepper motors and connect it up to my Taig lathe. Everything went ok except I don't get any response from the up arrow which should move my work platform towards the head stock. It works if I give it a "G00 Z-.5" under program control but now I seem to have lost the jog in that direction. I think the setup is ok, seems to work fine during tuning. What am I forgetting? Input pins and key codes look ok.
 
   
    Thanks
 
Barry
Re: OEM codes for buttons, DRO's and LED's
« Reply #7 on: May 15, 2008, 09:33:20 AM »
I don't use a lathe but, I thought that the Keyboard shortcut for Z axis was the Page Up/Page Down keys.  Arrow Keys only work in the Motor Tuning config.  Maybe it's different for Lathe though???

HTH,
Sid

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: OEM codes for buttons, DRO's and LED's
« Reply #8 on: May 15, 2008, 09:55:18 AM »
In Turn I think the left and right arrow may be default for the Z, thats what I use. If its not default then its easy enough to set up, just go to Config menu then down to Hotkeys, in there presse on the Z++ and a box will pop up asking you to select a key, press the right arrow and it will be set, do the same for the Z--.
 The X Axis on my lathe is the up and down arrows, again whether this is default I am not sure but easy to set up as detailed above for the Z.
Hood
Re: Responce to Sid
« Reply #9 on: May 15, 2008, 01:31:06 PM »
Hi Sid
 Thanks for the Reply. When I am using my CNC Router the page up and down controls the Z Axis but when I loaded the turn3 Lathe Mach3 program the default was set to Axis X (Tool Platform) and Axis Z for (back and forth towards the head stock). It surprised me too when I first saw it but when you think about on a Mill or Router the depth cut is the Z Axis the surface is just round here. I did see a options to select different Axis but it kind of made sense so I am working on it from there. It acts like it see the limit switch when using the up arrow but that's working ok. I did change the control for the Z Axis keys to the up and down arrow keys just to keep it visually correct. Maybe I'll try switching them back to the page keys to see if it is different. I know when I reverse the signal the problem reverses and like I said it works in the tune mode ok but then again the up and down arrow jog what Axis you have selected at the time. Thanks for taking the time out to reply. It works under program control just not the jog.... strange.
 
I'll Post something when I figure it out if I live that long.

Thanks again