Hello Guest it is November 12, 2019, 06:14:26 PM

Author Topic: XBOX 360 plugin thumbsticks not working  (Read 2741 times)

0 Members and 1 Guest are viewing this topic.

XBOX 360 plugin thumbsticks not working
« on: June 10, 2016, 03:43:29 PM »

i have tried just about anything by now (have directX installed, inserted the ID codes), but still fail to get the thumbsticks to work. i am on XP, mach3 v D1.90.065 (came preinstalled on the machine), would really hate to upgrade mach since that could void warranty.

the buttons work fine and do what they were programmed to in the plugin, but whenever i hit the sticks, mach3 flashes a "unknown word where unary operation could be" error in the status line.

one strange thing though - when i set up the vendorID/productID to 45E/719 (as shown in device manager details), after restarting mach the productID always gets changed to 2A1...

any help would be appreciated, would really like to liberate myself from the keyboard.

SOLVED: XBOX 360 plugin thumbsticks not working
« Reply #1 on: June 16, 2016, 02:39:40 AM »
in case anyone is stuck with the same issue:

the solution (after buying a new controller to no avail and trying all sorts of settings) was to upgrade mach3 - from v1.90********* that came with the machine to the latest 3.x.

speaking of which, artsoft does advise against upgrading if everything is working fine for a reason - i lost signal to a slave motor and ended up skewing the gantry. fingers crossed that was the only crucial setting that did not get imported by copying the original manufacturer settings after the upgrade.