Hello Guest it is April 09, 2020, 07:01:49 AM

Author Topic: not getting any spindle read out from photo interrupter  (Read 32 times)

0 Members and 1 Guest are viewing this topic.

not getting any spindle read out from photo interrupter
« on: March 26, 2020, 07:56:17 PM »
I am running the current version of Mach3 on XP 32 bit and ,using a photo interrupter on single slotted disc pick up,
I cannot see any movement on the spindle DRO.  What am I doing wrong.
Ps. The electronics have been checked to the end of the parallel port extension lead and all appear to be OK. 

Offline Graham Waterworth

*
  • *
  •  1,988 1,988
  • Yorkshire Dales, England
    • View Profile
Re: not getting any spindle read out from photo interrupter
« Reply #1 on: March 26, 2020, 08:18:51 PM »
You need to have the input port and pins set for index and then set the index de-bounce to 0 or 1 in the general config screen.

Can you see the index LED flash in the diagnostics screen if you turn the spindle by hand?

« Last Edit: March 26, 2020, 08:20:50 PM by Graham Waterworth »
Without engineers the world stops
Re: not getting any spindle read out from photo interrupter
« Reply #2 on: March 26, 2020, 09:08:40 PM »
Thanks for the rapid reply. No I don't see the LED flash when I rotate the chuck manually. I am currently making enquiries with Artsoft about the currency of my licence as it may have disappeared with a deceased older computer, although a hard drive transplant was attempted.
Anyhow I am currently waiting for a reply about this.
Thanks again ,
Mike Patterson