Hello Guest it is May 15, 2021, 07:33:54 PM

Author Topic: M3 Probing error THC Pokeys  (Read 505 times)

0 Members and 1 Guest are viewing this topic.

M3 Probing error THC Pokeys
« on: December 11, 2019, 05:21:47 PM »
I have bought Mach 4 last week as an upgrade for Mach3.

I have a Plasma table with PoKeys57CNC and a PlasmaSense THC unit. I am using a Floating Head configuration.

I am using the Plasma Screen and I got the THC working but sometimes while Probing it stops the cycle.

Macro Alarm: 3 The Probe did not strike during our M3 touch move.

But the Probe signal is activ if I look at the diagnostic page.

This problem randomly occurs.

Any clue?

And my value in the dros of the THC settings screen are changing every time I restart Mach 4.


Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: M3 Probing error THC Pokeys
« Reply #1 on: December 12, 2019, 09:44:23 AM »
You are either running out of travel (need to make the max probe distance larger) or have a noisy/bouncy input signal. Lots of post on this forum on how to troubleshoot and fix noisy/bouncy inputs. This one good example.......... https://www.machsupport.com/forum/index.php?topic=42086.msg274439#msg274439

The values in the DROs are changing because your machine units are mm or the Gcode your running is in mm mode. This has been fixed but not in a build yet. It should make it into the next build.
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: M3 Probing error THC Pokeys
« Reply #2 on: December 12, 2019, 05:30:42 PM »
My max Probe travel is at 100mm and my min max THC 100 and - 100 it is more then enough.

 I have no soft limits enabled.

The problem only occurs on the m3 Macro not in other Z Probe Funktions.

The I use shielded and grounded wires.

The PoKeys57CNC has some input filtering built in. And I played with the software filtering as well.
Re: M3 Probing error THC Pokeys
« Reply #3 on: May 25, 2020, 07:37:46 PM »
I am having this same issue with Mach4 Plasma and Pokeys57CNC. If I type M3 into the MDI and press start it will work sometimes, and other times I get the error "MACRO ALARM; 3 The probe did not strike during our M3 touch move.". If I use G31z-3 in MDI the probe works without an issue. I've tried installing an RC filter, but that didn't seem to help.

I attached a log of my probe testing with the Plasma torch turned off. The first and the third probe were successful, the second one shows the error.
« Last Edit: May 25, 2020, 07:41:22 PM by RootbeerFLHX »
Re: M3 Probing error THC Pokeys
« Reply #4 on: May 26, 2020, 09:08:42 PM »
i use also pokeys for woodworking cnc ,we use alot with probe,only with G31
never have problem,only with travel limit,so we add in the begin of the M function of the tool hight detect,disable the software limit
and at the end of the m function enable