Hello Guest it is November 16, 2019, 04:01:33 PM

Author Topic: Lcam 2.0...  (Read 49785 times)

0 Members and 1 Guest are viewing this topic.

Re: Lcam 2.0...
« Reply #20 on: May 08, 2007, 02:55:13 PM »
Hi Paul
 Thanks for the info, i see from the above post that you are using LC for a lathe i am new to Mach and LC not used anything like LC before and  i am trying to figure out how to  draw a profile in a cad program so LC can recognize an outside versus an inside turn i know you have to draw a line some how to designate this but i don't understand it can you give me any info on how this is done.

Thanks Rg's
Dennis

Offline PaulWC

*
  •  125 125
    • View Profile
Re: Lcam 2.0...
« Reply #21 on: May 08, 2007, 03:37:29 PM »
Hi Dennis,

Here's the thread on LC Turn setup. It's a little stale, but should get you going:

http://www.artsoftcontrols.com/forum/index.php?topic=2968.0

LC Turn is still getting some fixes by our Guru's, so give it a try and report your results. Lathe ops seem to be somewhere around 25% or less interest here, so we need all the supporting members we can round up. Fortunately, Art is the Big Gorilla in our corner.  ;)

Good luck, and let us know of any techniques you find to make LC Turn G-code work.

Paul, Central OR

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Lcam 2.0...
« Reply #22 on: May 08, 2007, 04:53:38 PM »
Hi, All

Thanks for the post work in todays LC update, Art & Brian, Post is a little off I think but a nice step forward.

Seam's to post the Rough portion of code a little long on both end's.

Orientation for start of G-code & return to start point seem unclear/off.

What happened to the return to 0,0 in Post Option ?

Maybe there should be a Start at x,z & Return to X,Z in LC Lathe or Post option's, To allow for clearer setup ?

Thanks & just some Thought's Hear, Chip

Re: Lcam 2.0...
« Reply #23 on: May 08, 2007, 09:35:24 PM »
Hi Paul & Chip
Thanks for your input, i agree with Chip that the start position shold be at the center of the billit on the right hand side and all turns shoulod be from this point to the X + to the Z- for the cut's.
The turn should start from the right hand side of the billit and on the center line of the lathe and then make it's turn moves from right to left or from tail stock to chuck.
Right now with the profiles Art posted the zero point is on the left then goes to the right to start the cut.

Dennis

Offline PaulWC

*
  •  125 125
    • View Profile
Re: Lcam 2.0...
« Reply #24 on: May 08, 2007, 10:21:54 PM »
Hi Dennis,

I normally set 0,0 the way you mention. I use a 1/4" drill blank in the chuck to touch off X with a cigarette paper, then step in 0.126" and set X0. Then I mount the workpiece and touch off on the outer (right) end for Z0.

The only time I use the left end as Z0 is when I'm doing a facing cycle to bring stock to correct length. Then I touch off on the face of the chuck body.

I downloaded today's LC posting, and I still get tool profiles shifted to the left by the nose radius value. And still have the tool profile trying to go to X0 off the left end of the stock.

Patience will bring all good things with time!  ;)

Paul, Central OR

Offline PaulWC

*
  •  125 125
    • View Profile
Re: Lcam 2.0...
« Reply #25 on: May 09, 2007, 01:52:43 PM »
Hi Art,

Here's the dxf file I was using when trying the offsets.

Thanks, Paul, Central OR

Offline PaulWC

*
  •  125 125
    • View Profile
Re: Lcam 2.0...
« Reply #26 on: May 09, 2007, 02:33:46 PM »
Hi Art,

Here is a saved Project file with my settings.

By the way, the Forum won't allow uploads of *.Lcam files.

Thnks again, Paul

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Lcam 2.0...
« Reply #27 on: May 09, 2007, 03:11:18 PM »
Hi, Art

Hears the DXF File that would load before recent changes in LC ver. 2.0.001.

It Hangs up LC during Load at Duplicate Entity Removal ...

LC Ver. 2.0.003 Has fixed The Move Origin Mouse Move Hear Also, Woooo---Hoooooooo.

Thanks !!, Chip

Offline PaulWC

*
  •  125 125
    • View Profile
Re: Lcam 2.0...
« Reply #28 on: May 09, 2007, 03:59:59 PM »
Hi Art,

Here's a new project file generated from the current LC download.

Thanks again, Paul

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Lcam 2.0...
« Reply #29 on: May 10, 2007, 01:26:39 AM »
Hi, Art

Sorry about that File, Took a Coffee Brake to load for Me, But it Loaded.

There's a 3 x 4 inch object in there Some Where to cut, It's so small you can't see it at All, Just 2 dashed lines bottom Right of drawing.

I Didn't now it had some Turned Off Layer's, Hadn't loaded it in to a Cad Program. 

File Was from a Friend's company that builds 37' & 47' Trawler's.

The Zoom Button feature zoomed into it Fine.

The double click on the Screed to re-size Fine Also

A couple Thought's Hear.

Could you Add a stasis Bar or % Done showing that LC is Still Active, And a way to Terminate Back to a stable LC if Such a File is Loaded by Mistake

Windows Task Monitor and the top of the LC Window will Show "Not Responding" even though LC is Plugging Along Just Fine.

Thanks, Chip

PS: The Move Origin with Mouse is Working  Wonderfully.