Hello Guest it is October 15, 2019, 12:33:28 AM

Author Topic: Lcam 2.0...  (Read 49331 times)

0 Members and 1 Guest are viewing this topic.

Offline PaulWC

*
  •  125 125
    • View Profile
Re: Lcam 2.0...
« Reply #10 on: May 05, 2007, 10:11:38 PM »
Me again,

Just noticed the Width setting shows 0.0078. It is actually 0.078 in use. Brain F*rt when generating the screen caps.

Paul, Central OR

Offline PaulWC

*
  •  125 125
    • View Profile
Re: Lcam 2.0...
« Reply #11 on: May 07, 2007, 12:53:52 PM »
Just downloaded ver 2.00.2 and can now generate Turn profiles. However, the profiles are shifted to the left by the nose radius value, and there is a nose radius artifact at the right end of the profile. Also, the profile "spills over" the left end and goes almost to spindle center. The posted G-code has "K" values that are *extremely* high digits, and other X-Z values are out of range for the min-max boundries of the original dxf.

Attached are the latest rev of my dxf, screen shot of generated profile and G-code posting.

On the Mill side, I'm having issues with "hungapp" lockups when trying to set "drill circles".

Thanks for all the effort you guys are putting into this app. LC is maturing rapidly and is appreciated. Looking forward to future revs... kinda like opening the latest Birthday card from Grandma... can't wait to see what's stuffed inside.  ;)

Paul, Central OR

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Lcam 2.0...
« Reply #12 on: May 07, 2007, 01:33:34 PM »
Hi, Brian

Missed your comment on Post options looking forward seeing the list, Thanks.

Items 1, 2 working now with 05 07 Update.

Item 3 still not working.

Working now 05-07 Update 1. Duplicate. line in lower left Square is missed by old and new LC, with Remove Redundant lines Checked or Un-Checked, Load Options.

Working now 05-07 Update 2. Dots are missed in Layer_3_ Dot, with Remove Dots Checked or Un-Checked Load Options, or with Layer Enabled Checker, Old ver Worked.


3. What I find is, If I load the Attached file and don't zoom in on the Origin Marker first and Move it, LC errors out to Windows error report.

Once I've moved it and double click to default size window it seems to work fine from then on, Iif I load a new file, I have to repeat the

Zoom, Mover Origin again. Un-less it the same file

I have the same version of Visual Studio you use, If I could get some partial source code, New or Old that covers this type of Origin move and  a little guidence from someone maybe we could track this problem down and be done with it.

I've reported this before with Debug of program with EXE file but its in Assembly code, Guess this is hard to work with,

I have the time and computer with this problem, Would like to help on this if you have a way, This problem is causing a few others problems also.

Another Great Advance In New LC, This is So-----Nice.

Thanks, Chip

Offline klmark

*
  •  107 107
    • View Profile
Re: Lcam 2.0...
« Reply #13 on: May 07, 2007, 02:27:33 PM »
Hello Everyone
I have the same problem on one computer it works as afn09556 has posted but on  the other one no  matter what I do I always get a errors out to Windows error report just to let you know some other guys have a problem to has any one tryed the Mach 3 Load button In LC my dose nothing or less I am not doing something right  I am not complaning just testing
                                                                          markkl
« Last Edit: May 07, 2007, 02:29:23 PM by markkl »

Offline klmark

*
  •  107 107
    • View Profile
Re: Lcam 2.0...
« Reply #14 on: May 07, 2007, 02:35:52 PM »
Hi
Where can a guy download LC ver 2.00.2 I don't see it on the web
                                      thank you

Download the LazyCam in normal download, It's Been updated, Just doesn't show new Ver., Chip
« Last Edit: May 07, 2007, 03:14:27 PM by afn09556 »

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Lcam 2.0...
« Reply #15 on: May 07, 2007, 03:07:42 PM »
Hi, Brian & Paul

Just downloaded Paul's NC file, It Crashes Mach3 to Windows error report.

Having the same problem with the LC Lathe G-code, The K values are huge, 1000K Billion's, Bigger than I can count.

N640 G1  X-5.0748   
N645 G0  Z0.1000
N650 G1  Z-1.0000 
N655 G3  X-5.1250  I-2.5625  k-6277438562204192500000000000000000000000000000000000000000000000000.0000
N660 G0
N665 G1   
N670 G0  X0.0599  Z0.1000
N675  Z-1.0000
N680 G1   
N685 G0
N690 G1  X-0.0664   
N695 G0
N700 G1   
N705 G0  X-0.0820  Z0.1000
N710  Z-1.0000
N715 G1   
N720 G0
N725 G1   
N730 G0
N735 G1  X-5.0305   
N740 G0  Z0.1000
N745 G1  Z-1.0000 
N750 G3  X-5.1250  I-2.5625  k-6277438562204192500000000000000000000000000000000000000000000000000.0000
N755 G0
N760 G1   

Thanks, Chip
Re: Lcam 2.0...
« Reply #16 on: May 07, 2007, 09:21:38 PM »
Yup, that is junk data that you are getting for K...

I will see if I can find the problem

Thanks
Brian

Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Lcam 2.0...
« Reply #17 on: May 07, 2007, 09:51:55 PM »
problem has been found and i sent it to Art :) will be in the next rev
Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Lcam 2.0...
« Reply #18 on: May 08, 2007, 10:52:59 AM »
Hi Guy's
In looking at LC i can't tell what version i am using it just say's 2.0 i know there have been upgrades to LC but what is the current version?

Rg's
Dennis

Offline PaulWC

*
  •  125 125
    • View Profile
Re: Lcam 2.0...
« Reply #19 on: May 08, 2007, 12:51:41 PM »
The currently available download is named "LazyCam2.00.exe", but it installs ver LazyCam2.00.2.

Paul, Central OR