Hello Guest it is October 16, 2019, 01:41:04 AM

Author Topic: feedrate changing after spindle stop part 2  (Read 5052 times)

0 Members and 1 Guest are viewing this topic.

feedrate changing after spindle stop part 2
« on: June 16, 2015, 05:56:12 AM »
Hello chaps

After the earlier posting i thought i should post the code for the experts to have a look at

I have marked the line in the subroutine where it always changes the f value


Here it is
% filename is    :-   simple boresinglecut.tap
% program number:-   01001  (program number -put at start of program)   
% Program name    :-   simple boresinglecut.tap
% Program description:-   Makes a single cut in the bore according to parms set
%          SETUP STRING (INITIALIZATION)------
% make sure to home the machine first then to reference x and z positions
m05            (stop the spindle)
g18            (xz plane)
g21            (feed in mm)   
g40            (g49)
g95            (feed per rev mode set on)
%G80         (cancel motion mode)
%g96         (CSS control)
s1400         (CSS cancel and set speed to 1400)
%g61         (exact stop mode)
g64            (constant velocity mode)
f.1            (feed .1 per rev)
g028          (go to home position)
% -- setting up parms-------------------------            
#1=27.0         (bore start dia)
#2=-38         (end of z cut notice the minus !!)
#10=.5         (first diameter on bore x axis)
#11=4         (second diameter on bore x axis)
#20=4.5         (first cut length on z axis)
#21=9         (second cut length on z axis)
#22=42         (third cut on length z axis)
m04         (start spindle forwards)
m98 p1 l3      (run sub no 1 5 times)
% ---- program shutdown starts----
m09             (water off)
m5              (stop spindle)
m30             (end program and rewind m2 will also end program)
% ----------this is the end of the program --
O01   (subroutine  #1 starts)
g0z19         (start to clear front of boring bar)
g0x#1         (START cut X axis)
g0z1         (move z closer)             ********this is where it always changes the feedrate
g01 x#1 z-5         (cut in 5 mm for the location)
g01 x[#1-#10] z-9   (bore first taper)
g01 x[#1-#11] z-39   (bore second taper)
g0 x[#1-#11-1]z-38   (back off quickly)
m 05 g0z50      (stop spindle move tool out of the way for measuring)
g0x#1         (put tool back to show size on dro)
%m00          (msg,stop and measure then press cycle start)
m04            (start spindle again)
#1=[#1+2]      (add 2mm on dia parm )
m99            (this is end of sub 01)
%   LEAVE THIS % TO MARK END OF FILE
think of the trees-- use both sides of the computer paper

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: feedrate changing after spindle stop part 2
« Reply #1 on: June 16, 2015, 09:47:14 AM »
Hi,

g0z1         (move z closer)             ********this is where it always changes the feedrate


it is a G0 i think it should be G1.

Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: feedrate changing after spindle stop part 2
« Reply #2 on: June 16, 2015, 10:46:10 AM »
thanks for that thomas- i did change the line and still have the same problem.

If i were to send you my file would you be able to put it on your computer and
see if it runs correctly.

I did recently pick up a compile error regarding one of my M files and i am concerned
that i may have got some form of corruption

I would appreciate your help

regards

fred
think of the trees-- use both sides of the computer paper

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: feedrate changing after spindle stop part 2
« Reply #3 on: June 16, 2015, 05:10:59 PM »
Hi Fred,
thanks for that thomas- i did change the line and still have the same problem.

If i were to send you my file would you be able to put it on your computer and
see if it runs correctly.

I did recently pick up a compile error regarding one of my M files and i am concerned
that i may have got some form of corruption

I would appreciate your help

regards

fred


send me your files,  i'l have a look.

Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: feedrate changing after spindle stop part 2
« Reply #4 on: June 17, 2015, 03:35:00 AM »
thank you very much
I am going to try and attach the .tap file If I cant get it right then i will email it to you seperately

Please dont try mand cut with the code because i havent debugged the sizes yet
and it is bound to cause a crash

I have just been cutting with no tool in the toolpost. you will notice that the f word is set correctly
until it gets to the first G01 word and then it resets itself to 0.04
think of the trees-- use both sides of the computer paper

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: feedrate changing after spindle stop part 2
« Reply #5 on: June 17, 2015, 03:52:14 AM »
Hi,

tested your file.
i have a constant feedrate from 0.1
during the complete run.

Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: feedrate changing after spindle stop part 2
« Reply #6 on: June 17, 2015, 04:54:35 AM »
thanks thomas--

this is not what I have. Mine definitely resets to f=.or
what version of mach3 do you have?
will the .xml file be able to tell you anything ?? if so I will
email it to you tonight when i get back to the computer
or maybe one of the other files that nack generates?

( are you in Bavaria? ) ( I have a brother living in Munchen)

think of the trees-- use both sides of the computer paper

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: feedrate changing after spindle stop part 2
« Reply #7 on: June 17, 2015, 05:02:28 AM »
Hi Fred,

i have tested on Version R3.043.058.
i am living in Bavaria near Regensburg.

yes please post your xml i will have a look.

Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: feedrate changing after spindle stop part 2
« Reply #8 on: June 17, 2015, 10:01:28 AM »
 my version is 3.042.040

I will upgrade later this evening

in the meantime my xml file is attached
many thanks

fred
think of the trees-- use both sides of the computer paper
Re: feedrate changing after spindle stop part 2
« Reply #9 on: June 18, 2015, 03:54:22 AM »
I'm back again.
I upgraded to the latest version and I still experience the same problem.

Please tell me if my logic is sound.
The problem is that whenever I call a G01 move  the f value is changed
from the f setting on f=0.1 to f=0.04 ( or f=0.05)

My first thought was that I had a corruption in the code. so i went through the code carefully
and couldnt find any command which would affect the feedrate.
Then I thought that maybe there was a corruption in my Mach exe . I then reininstalled
the latest version and still have the same problem.
Having TPS try the code on his machine shows that the code and the exe are both working OK
therefore the problem must be something to do with the configuration that i am using.

I dont know how to attack the problem.

Any advice will be appreciated.
regards

fred

  
think of the trees-- use both sides of the computer paper