Hello Guest it is October 17, 2019, 01:11:46 PM

Author Topic: feedrate changing after spindle stop part 2  (Read 5053 times)

0 Members and 1 Guest are viewing this topic.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: feedrate changing after spindle stop part 2
« Reply #10 on: June 18, 2015, 04:13:25 AM »
I just ran your xml and file on version 3.043.062 it ran fine

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: feedrate changing after spindle stop part 2
« Reply #11 on: June 18, 2015, 11:24:54 AM »
Hi Fred,

sorry  i will be offline for a few days

Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: feedrate changing after spindle stop part 2
« Reply #12 on: June 18, 2015, 12:15:19 PM »
Thanks chaps -- i will rewrite the code and try a few more tricks

i will report back to this topic if i sort the problem out.

first thing i will do is to reduce the code to bare bones ( no subs etc) and see what happens

best regards and thanks
fred
think of the trees-- use both sides of the computer paper

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: feedrate changing after spindle stop part 2
« Reply #13 on: June 18, 2015, 01:37:48 PM »
Fred it is NOT your Gcode that is causing it. It is more than likely a corrupt load of Mach3 that is causing it.  I tested your Gocde here and there is NOTHING wrong with it. It runs just fine.

(;-) TP
Re: feedrate changing after spindle stop part 2
« Reply #14 on: June 18, 2015, 01:55:30 PM »
Hello TP - thanks for the input

I think i might of found something.

It appears to me that when i enter a G01 command the feed rate is halved.

Is there any switch which could be applying a 50% to the feedrate??

I take note of your suggestion that mach3 may be corrupt- but i have just upgraded to
the latest version downloaded from the artsoft site and the problem persists.
I ran some other code that i know was working previously when I machined a lot of plastic
blocks to rounds and it worked fine. then i saw that the code was calling F1 ( 1mm cut per rev)
when i changed this F to f0.1 i got the same problem the feed rate was halved to 0.04 on the DRO
so i changed the code back to f1 and lo and behold when i ran it this time the dro registered .4
again about half what i was calling for.
strange?? I am going to bed now and will sleep on the problem until tomorrow night.

regards and goodnight.

fred


South africa is freezing at the moment . When i drove to work this morning it was down to
5 degrees  :-)
think of the trees-- use both sides of the computer paper

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: feedrate changing after spindle stop part 2
« Reply #15 on: June 18, 2015, 02:57:27 PM »
OKAY,  (;-) FPR

 Feed per rev Verses Feed per min CAN change your feedrate  So it can change itself. Try turning OFF Feed per rev (G95) and set it for FPM G94) just a s a test
Re: feedrate changing after spindle stop part 2
« Reply #16 on: June 19, 2015, 07:52:23 AM »
Will try when I get home this afternoon

(wotis FPR?)
think of the trees-- use both sides of the computer paper
Re: feedrate changing after spindle stop part 2
« Reply #17 on: June 19, 2015, 11:07:42 AM »
Br549--
 thanks  I  changed to feed per minute and there was an immediate improvement.

However still not quite right.
the earlier f call was for f1.0
because this was so slow i changed to f25
when running with f25 the DRO reading is showing feed = 23.28
much improved ove the earlier reading with using feed per rev but still not
quite right.
Is it normal for the feedrate to be a few points below what is specified in the
f word??







think of the trees-- use both sides of the computer paper
Re: feedrate changing after spindle stop part 2
« Reply #18 on: June 19, 2015, 11:15:17 AM »
further observation on the same topic.
I have taken the fword out of the setup string.
when i load mach3 from scratch  the feed dro shows "6"
where does it get this value from ? is this a built-in default?
think of the trees-- use both sides of the computer paper

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: feedrate changing after spindle stop part 2
« Reply #19 on: June 19, 2015, 11:16:21 AM »
HIYA Fred,  Macah3 actually set the feedrate based on the actual kernal speed deviation. IF you are running at 25K on kernal speed and the PC is actually reporting 24800 then yes there will be a difference in actual feedrate based on the ratio between declared and actual kernal speed.  25000 vs 24800 = .992   SO 100 ipm feed would actually be 99.2 .

Using IPR is a bit different  over using IPM. Yo have to get used to it.  AND I cannot say that mach3 actually does it correctly.  Are you by chance using CSS?

(;-) TP