Hello Guest it is July 24, 2019, 03:34:29 AM

Author Topic: Angle of rotation and reverse run problem...  (Read 3023 times)

0 Members and 1 Guest are viewing this topic.

Angle of rotation and reverse run problem...
« on: March 06, 2014, 05:45:00 AM »
Hi!
I face a problem, if you have seen it, please advice:

When angle of rotation (standard DRO 118) has any value,
when i hit "reverse run" to follow the path backwards (under G40),
the machine goes somewhere else (probably follows different angle).
I didnt have this problem until now, might be any settings or something?

Versions 3.043.066 and 067 have been tried.

Giannis
Re: Angle of rotation and reverse run problem...
« Reply #1 on: March 06, 2014, 08:23:36 AM »
Here's a print screen to show you what exactly is the problem.
There is already an angle while running.
When pause and reverse run is hit, the machine goes back with a different angle.

Have you seen that  before?
Re: Angle of rotation and reverse run problem...
« Reply #2 on: March 12, 2014, 02:08:46 AM »
Any ideas?

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Angle of rotation and reverse run problem...
« Reply #3 on: March 12, 2014, 04:09:14 AM »
I never use reverse run so cant really be of help I am afraid but possibly try an older version of Mach just in case it is one of the issues that has been introduced with 066.
Hood
Re: Angle of rotation and reverse run problem...
« Reply #4 on: March 18, 2014, 02:09:53 PM »
The problem goes back down to version 3.043.53
It seems is old problem.
Please consider for the next version.
Thanks
Re: Angle of rotation and reverse run problem...
« Reply #5 on: December 15, 2014, 03:12:03 PM »
Hello Giannis,

Have you been able to solve this issue? I have the same problem.

Thanks.

Juan Carlos
Re: Angle of rotation and reverse run problem...
« Reply #6 on: December 16, 2014, 04:51:45 AM »
No, I didn't solve it...
I just run the 3.043.53 version where it works.
Giannis
Re: Angle of rotation and reverse run problem...
« Reply #7 on: December 16, 2014, 07:25:58 AM »
Thanks!

Best Regards,

Juan Carlos
Re: Angle of rotation and reverse run problem...
« Reply #8 on: December 16, 2014, 08:30:17 AM »
Dear Giannis.

I've just tried the 3.043.53 version, but It didn't works too. I also tested the Version R3.042.029, without lucky. I wonder if there is another thing thats makes this problem to appear. Maybe have you changed anything else?

Thanks!

Juan Carlos
Re: Angle of rotation and reverse run problem...
« Reply #9 on: December 16, 2014, 10:44:21 PM »
Juan, I'm working with pokeys.
So the best combination that worked for me was 3.043.53 and 3.0.65 firmware for pokeys.
I spent dozens of hours to find out why and how. Seems there won't be another bug fix for mach3.
Mach4 is already here.