Hello Guest it is October 22, 2019, 03:02:56 AM

Author Topic: Old Dynapath System 10 upgrading to Galil CS 18420 ICM 2900 No idea on wiring???  (Read 36266 times)

0 Members and 1 Guest are viewing this topic.

I wonder if there is a ground issue? The encoders are grounded to the mill frame as well as the ground I/O, but no other grounds are connected to the I/O. I dont see how it would affect the signals from the drivers????

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
Where are you Steve?

I am in Virginia very close to Washington DC.

Joe

I'm in Alabama, near Birmingham.

Steve

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
I wonder if there is a ground issue? The encoders are grounded to the mill frame as well as the ground I/O, but no other grounds are connected to the I/O. I dont see how it would affect the signals from the drivers????

The encoders should feed directly into the Galil.  Are they single ended or differential?

Steve

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
The bottom line is that I think you will have the same issues even if you spent money on new drives.  The thing we HAVE to figure out is getting encoder input to the Galil and then tune the servo loop.  If we have a drive that will move with a command signal and encoders reporting back position info to the Galil, then that should be doable.  We just have to get there.

Is the PC hooked up to the internet where I could remote control it?  With you on Skype by the machine so that we could talk our way through some tests?

Steve
Yes and that would be wonderful.. I'd throw some money your way for your time!!!

Offline smurph

*
  • *
  •  1,138 1,138
  • "That there... that's an RV."
    • View Profile
Send me your Skype username to smurph at smcomp dot com and I will try contacting you tomorrow.  I'm in the Central time zone but I operate on the Pacific time zone hours.  :)  So don't expect an early session!

Steve
I'll go set one up now. I usually am up late and I'll work around your schedule
Well I'm back at it. With the help of Steve, I figured out a few wiring problems, but I still can't seem to get the Servos to hold under the SH command.
Thread from the dead!!! I have had a lot change in my life and I'm now able to restart this project. Steve are you still around????
Well the three year break must have been just what the mill needed because I got the servos working with the smarterm. The issues/questions I have now is the spindle control. I have five wires going to the spindle control/driver thinggy. Two wires are I believe 0-10v enable. The other three are direction control I think..... So to use Mach/galil to control the spindle I thought I could use my fourth axis control??? But the spindle has no encoder or feedback to the card so will Mach/galil be ok with no feedback on W but still control the spindle???

Second issue/question. The old westamp A651 is velocity controlled, I also have single ended encoders, I've heard this is unstable possibly unsafe. Should I look into new servo drives? If so what drives?

Third issue. The limit switches. I think I will have to run the limit switch in parallel with the servo drivers and Mach. Or I could just run the limit switches to Mach/galil and let the the servo enable feature turn off the drivers when the limits have been tripped? Would that be ok?
« Last Edit: February 18, 2017, 09:51:17 AM by Wilde Racing »