Hello Guest it is November 13, 2019, 12:51:38 PM

Author Topic: Soft Limit Problem  (Read 9838 times)

0 Members and 1 Guest are viewing this topic.

Offline rufan

*
  •  37 37
    • View Profile
Soft Limit Problem
« on: January 09, 2014, 03:17:24 AM »
Recently I have swapped the ESS Smoothsteppper for the CS-Lab CSMIO/IP-S controller
When I startup Mach3 I perform a x-y-z Axis reference this is done perfectly
Then I enable the Software Limits.
Now I cannot move any axis in step mode or with G-code, when I try this I get an error message: see picture below.
The weird thing is: the only way to move the Axis with soft limit ON is if JOG is in continues mode.
Whit Soft Limits disable every thing works fine.

What can occur this problem?
Is this a CS-Lab error message? I have never had this problem or see this message before with the Smootstepper controller.
I have the latest Mach3 .066 installed and the latest CS-LAB v2.100 Plug-in installed.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Soft Limit Problem
« Reply #1 on: January 09, 2014, 06:47:12 AM »
Can you attach your xml and I will take a look.
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Soft Limit Problem
« Reply #2 on: January 09, 2014, 06:50:41 AM »
Actually, looking at the pic above it looks like none of your axes are referenced.
Also might be worth trying an earlier version of Mach as 066 is known to have homing issues with external controllers.

Hood
« Last Edit: January 09, 2014, 06:53:27 AM by Hood »

Offline rufan

*
  •  37 37
    • View Profile
Re: Soft Limit Problem
« Reply #3 on: January 09, 2014, 06:56:33 AM »
Hood,

From what I can see, when the axis go to the reference point and Machine coord's are set to 0.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Soft Limit Problem
« Reply #4 on: January 09, 2014, 07:01:52 AM »
I was assuming the LEDs at the side of the DROs were the referenced LEDs and they are not green.
Might also be worth loading the default Mach screen just as a test to see if things change.
I will have a look at your xml and see if I can find any issues.
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Soft Limit Problem
« Reply #5 on: January 09, 2014, 07:05:25 AM »
I see you have the C axis enabled, do you actually have a C connected?
Hood

Offline rufan

*
  •  37 37
    • View Profile
Re: Soft Limit Problem
« Reply #6 on: January 09, 2014, 12:44:51 PM »
It is what Hood say: C-Axis.
I need the C-axis for my turret, but I don't want to reference it.
If I disable the C-axis then everything works fine with SoftLimit on.
If C-Axis is enabled then I get this error.

I assumed that if the HOME input for an Axis is not enabled the system should not worry about it's reference.
This was the case with Smoothstepper.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Soft Limit Problem
« Reply #7 on: January 09, 2014, 01:20:39 PM »
General Config page in Mach , Disable the soft limits for rotational axis.
Hood

Offline rufan

*
  •  37 37
    • View Profile
Re: Soft Limit Problem
« Reply #8 on: January 09, 2014, 01:33:00 PM »
Hood,

Disable the soft limits for rotational axis, does not the job still getting the error.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Soft Limit Problem
« Reply #9 on: January 09, 2014, 01:37:55 PM »
Ok will have another look through your xml but you may have to contact CS-Lab and see if they can suggest anything. I am at home now so cant test but if I remember I will test tomorrow on the lathe by enabling the C axis and see if I get this problem.
Hood