Hello Guest it is October 17, 2019, 12:44:01 PM

Author Topic: Pause between g-code steps  (Read 4247 times)

0 Members and 1 Guest are viewing this topic.

Pause between g-code steps
« on: February 07, 2012, 03:11:01 PM »
New here.. looking for help with a Mach3 issue. Sorry if this is the wrong place to start this thread.

When running a program, there is a short pause between g-code moves.
I have checked that it's set to Constant Velocity not Exact Stop. Any other ideas on how to fix this?

Could very well be my g-code is poorly written and it's not a Mach3 problem at all...

Thanks,
cbade

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Pause between g-code steps
« Reply #1 on: February 07, 2012, 04:42:17 PM »
Does your G Code have a G61 in it?
Hood
Re: Pause between g-code steps
« Reply #2 on: February 07, 2012, 04:47:39 PM »
It does not. I also checked in the settings to be sure the Constant Velocity is checked. I can add a G64 and try the code again.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Pause between g-code steps
« Reply #3 on: February 07, 2012, 04:49:06 PM »
If you attach your code and your xml maybe the issue can be found.
Hood
Re: Pause between g-code steps
« Reply #4 on: February 07, 2012, 04:55:58 PM »
I've attached the .XML used and the G-code in question. The pause happens between each move.

Thanks for your help.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Pause between g-code steps
« Reply #5 on: February 07, 2012, 05:11:33 PM »
Look on Settings page and disable CV Feedrate and see if that helps.

Hood
Re: Pause between g-code steps
« Reply #6 on: February 07, 2012, 05:32:39 PM »
Looks like that did the trick. The setting was at +1.000 and I disabled it.

I'm curious as to why this is the fix.. I'll do some google searching.

Thanks a ton! You're the man, Hood.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Pause between g-code steps
« Reply #7 on: February 07, 2012, 05:37:07 PM »
I would say what that means is you were telling the machine to slow to 1 unit per min before doing the CV.
Hood
Re: Pause between g-code steps
« Reply #8 on: February 07, 2012, 05:40:30 PM »
So another fix could be to change the CV Feed-rate value to the same as the feed-rate set by the G-code? I'll try it.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Pause between g-code steps
« Reply #9 on: February 07, 2012, 05:45:36 PM »
Yes that should work but usually its just disabled by default I think. I imagine it is meant for people who have machines that are not very rigid but with fast acceleration, could be wrong though :)
Hood