Hello Guest it is April 23, 2021, 05:34:48 AM

Author Topic: Help! Please! this Chaos has to stop!  (Read 19579 times)

0 Members and 1 Guest are viewing this topic.

Help! Please! this Chaos has to stop!
« on: December 02, 2006, 02:33:39 PM »
Hi,
Can anyone help me! My machine is loosing its location everytime I run a cutter path. This is getting ridiculous ???  I have a K2 cnc router kt2514. I am running Mach2 and am in the process of switching over to Mach3 but I am having problems with it running smoothly, so for now I am running Mach2.  I am using a P4 2gig with 1 gig of ram for the controller PC, I have 276oz steppers direct drive with couplings and gecko 201 stepper drivers.

My machine screws up and then starts to run again out of location, I have played with the velocity and the acceleration, I was wondering if there could be something wrong with the machine electrically. The stepper controller box gets very very hot so I added fans to cool it. The motors arn't getting hot, and I used WD-40 for the lube on the leadscrews, and when the machine isn't on I can move all three axis with ease by rotating the leadscrew by hand. I have plastic antivibration nuts on all three axis and couplings that I made sure that the fit is good and not binding.

These are my questions:
Can anyone go through the voltages on my stepper drivers to see if there a problem with too much power or something like that?
Should I use grease instead of WD-40 for lubrication? Does anyone have any suggestions?
Any other Ideas that could be the problem I will check them all, I need to get this problem fixed!
I will be checking for posts all day.
Thanks,
Greg.
"Ideas have consequence" Ravi Zaccharias

Hood

*
Re: Help! Please! this Chaos has to stop!
« Reply #1 on: December 02, 2006, 05:41:09 PM »
Have you got enhanced pulse enabled? I know you have messed with the motor tuning but just tune it slow and try out and see if it loses steps, if not then turn up the velocity a bit and try again. Is the current resistor on the Geckos correct for your motors?
Hood

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Help! Please! this Chaos has to stop!
« Reply #2 on: December 03, 2006, 12:06:15 AM »
Hi, Greg

If your using Backlash, CV Mode needs to be off, set to Exact Stop Mode.

Are all axises losing steps.

Thanks Chip
Re: Help! Please! this Chaos has to stop!
« Reply #3 on: December 03, 2006, 12:10:37 PM »
Tell me if what they told you fixes it. If not E-mail me and i will try to help you
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Help! Please! this Chaos has to stop!
« Reply #4 on: December 03, 2006, 12:44:55 PM »
Hi,
Thanks for the replies!

-Enhanced pulsing is not on
-Constant Velocity is on
-Can't find CV mode, I am using Mach2

Here are a few more questions I have that might be an issue:

-In BIOS my com port 1 is set to EPP, is that right? There is two other settings ECP and Bi-directional.
-In Mach 2 com port 1 baud rate is at 9600, should that be set higher? my wire is quite short.
-When I was reading the manual for the stepper driver they were talking about a 5 amp 250 vac  fast acting fuse, my machine keeps blowing them, the fuse is located at the power supply, I am using a 6.3 amp fuse and it hasn't blown yet.  The guys from k2 said it wasn't a problem.  What do you think?

Thanks Brian, I will keep in touch with you, The problem is intermitten, Yesterday I ran two programs one to ruff and semi-ruff then on the third program to semi finish it screwed up and lost location and I ran the program about 4 or 5 times and it kept screwing up. Then it worked on the 6th time, then my finishing program ran fine but I wasn't running it at the feed that I wanted to, because of fear that it would screw up.  I found if I run it fast it screws up more.  This is what it does on a constant basis no specific axis they all screw up at different times. The only thing that I noticed is that all axis freeze up and once it finishes getting to the point it starts back up again out of location.  It depends on how much damage being out of location does decides if my part is scrap.

Thanks guys,
Greg
"Ideas have consequence" Ravi Zaccharias

Hood

*
Re: Help! Please! this Chaos has to stop!
« Reply #5 on: December 03, 2006, 02:02:34 PM »
Try it with enhanced pulse enabled, there are a lot of benefits to enabling it and from what I understand very few if any against.
 CV is constant velocity so have a look and see if Backlash compensation is turned on, if it is turn it off and see if it helps. Backlash comp can cause problems with some setups, especially stepper setups. The fuse question cant really be answered without knowing what power your steppers etc require but if the K2 guys say its OK at what you have I am sure it must be.
Hood
Re: Help! Please! this Chaos has to stop!
« Reply #6 on: December 03, 2006, 06:27:10 PM »
What is the Accel and Max Vel for each axis?
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Help! Please! this Chaos has to stop!
« Reply #7 on: December 03, 2006, 11:59:25 PM »
Hi,
I will give it a try with enhanced pulse enabled, CV is constant velocity is on, but I can't find Backlash compensation so I'm not sure if it's turned on, I am using Mach2 do you know where to find it.  You want me to run it with exact stop on? I will run the machine tomorrow and will post and tell you what happened.

Brian, My Accel and Vel for my machine are the following:
          Accel          Vel
X axis   7.2225      1.8675
Y axis   7.74         1.838
Z axis   7.47         1.944

What do these numbers mean to you?
Thanks,
Greg
« Last Edit: December 04, 2006, 12:06:22 AM by method13 »
"Ideas have consequence" Ravi Zaccharias

Hood

*
Re: Help! Please! this Chaos has to stop!
« Reply #8 on: December 04, 2006, 02:21:23 AM »
Backlash and CV/Exact stop modes are found under Config tab then down to state. If you do have Backlash enabled then I would disable it first and try using CV. If you put it in Exact Stop mode it mayl seem very jerky especially if you are doing code with a lot of very small moves. You can also change to Exact Stop mode by having a G61 in your code, to change to CV you have G64
Do you have ballscrews in this router, if yes then really you shouldnt need backlash comp.
 I also suggest you try one thing at a time so that  you find out what your problem has been, then if it happens again you will know right away ;)
 Hood
Re: Help! Please! this Chaos has to stop!
« Reply #9 on: December 04, 2006, 12:04:23 PM »
Hi, I noticed in the above pic you are using Gecko drivers, Are the drivers mounted on heatsinks with heat transfer paste.
The drivers should not be very hot if your steppers are not. There is something wrong there. Find out what amps per phase the steppers are and check the limit resistors for the geckos.

Regards