Hello Guest it is September 19, 2019, 12:03:32 PM

Author Topic: Mach3 Problems - Rant!!  (Read 37003 times)

0 Members and 1 Guest are viewing this topic.

Offline BR549

*
  •  6,895 6,895
    • View Profile
Re: Mach3 Problems - Rant!!
« Reply #80 on: June 09, 2011, 11:48:08 AM »
Normally you would tune the velocity loop first then tune the positon loop.

Just a thought, (;-) TP

Offline Pinky

*
  •  48 48
    • View Profile
Re: Mach3 Problems - Rant!!
« Reply #81 on: June 09, 2011, 02:07:41 PM »
Hmmm can't seem to find any parameters called "velocity loop" nor "position loop" BR549.

We did auto gain tuning on all the axis. Afterwards we had to adjust "Kvp: P Gain of speed loop" to get rid of the resonance on all the axis.

Then did another sample cut and wow, it's looking really good, almost 100% !!!

Only problems that remain now is:

1) The z axis is sounding a bit funny,almost as if the ball screw is hitting against the bearing when moving....rather strange, but we've taken a video and will forward it to our manufacturer tomorrow.

2) When cutting at the speed we would like to cut,which is about 3 times faster, the engraving almost returns to the state it was before we did the auto gain tuning. Which leads me to believe we'll need to up some of the parameters in order to go faster. Just need to figure out how to get rid of the resonance as we up the values.

Apart from that everything is MUCH better :D
Re: Mach3 Problems - Rant!!
« Reply #82 on: June 09, 2011, 03:07:32 PM »
Damn, I wanted to tell them it's better!!!>:/ Grrrr!!

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Problems - Rant!!
« Reply #83 on: June 09, 2011, 03:26:22 PM »
Tuning can often make an axis sound like a bag of rocks. Afraid I dont know anything about your drives so its just a case of mess around with settings and see what works. Does your drives software have a built in scope? Mine do and it makes tuning easier as you can graphically and numerically see when things are improving.
Hood

Offline Pinky

*
  •  48 48
    • View Profile
Re: Mach3 Problems - Rant!!
« Reply #84 on: June 09, 2011, 03:34:58 PM »
Thanks for the reply Hood.

We still fiddling around with the servo software, but did notice something labeled "date scope" Just not sure which settings we should be monitoring as they have about 20 different ones to choose from :(

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Problems - Rant!!
« Reply #85 on: June 09, 2011, 04:13:18 PM »
Is there no info on tuning in the manual? Servos can be a PITA to tune when there is not much info on specifics for the drives. I usually just resort to messing around with the settings, being ready with the E-Stop just in case ;)

Hood

Offline BR549

*
  •  6,895 6,895
    • View Profile
Re: Mach3 Problems - Rant!!
« Reply #86 on: June 10, 2011, 01:02:22 AM »
IF your servo got noisier then you have not finished tuning yet (;-)  Noisier is NOT good.

Servo tuning is a fine ART. IF you have a built  in scope then you need to USE it. It will show you what teh motion curve looks like . You can see the overshoot and correction as it happens live.

I hope you saved your OLD settings(;-)

(;-) TP
« Last Edit: June 10, 2011, 01:04:47 AM by BR549 »

Offline Pinky

*
  •  48 48
    • View Profile
Re: Mach3 Problems - Rant!!
« Reply #87 on: June 10, 2011, 01:08:54 AM »
Plenty info on tuning in the manual with descriptions on what each parameter does, just figuring out how far you can push each parameter,keeping in mind that some have to be moved x4 and other /1.5 otherwise they cause resonance.

I'm just a bit confused still about the "Limit of Load Inertia Estimation" parameter as I'm not really understanding how one goes about changing it in auto tuning.

I've attached the software help file for tuning the servo's in case anyone gets bored and feels like reading it ;)

Agreed BR549, it will take a lot more time getting it 100%, and yes, we did save all our old settings :D

PS.... had to rename the file for uploading, please rename .pdf to .chm
Re: Mach3 Problems - Rant!!
« Reply #88 on: June 10, 2011, 01:24:47 AM »
latest sample cuts from last night after running the auto servo tuning. Still not 100% but a cr@p-load better IMHO.

Offline Pinky

*
  •  48 48
    • View Profile
Re: Mach3 Problems - Rant!!
« Reply #89 on: June 10, 2011, 06:12:05 AM »
Ok nevermind, doesn't look as if the Software manual works when attaching it here, what a pity.