Hello Guest it is October 21, 2021, 07:32:59 AM

Author Topic: Recovering from hard drive crash THC300 settings  (Read 4872 times)

0 Members and 1 Guest are viewing this topic.

Offline jeremyrockjock

*
  •  39 39
  • Why buy what you can build.
    • View Profile
Recovering from hard drive crash THC300 settings
« on: April 27, 2011, 09:39:56 PM »
I have my plasma table almost back to where it was before the crash. My last hurtle is that the torch will not fire with output1. It will fire with charge pump2 (port2Pin17). I have output 1 set as port2 pin1 and it does nothing. Any ideas how to change the torch trigger back to output 1?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Recovering from hard drive crash THC300 settings
« Reply #1 on: April 29, 2011, 04:17:16 AM »
If you have output 1 set up properly to the correct port, pin and also enaled then it is likely your port that is the problem.
If you attach your xml I can have a look and see if there is a config issue.
Hood

Offline jeremyrockjock

*
  •  39 39
  • Why buy what you can build.
    • View Profile
Re: Recovering from hard drive crash THC300 settings
« Reply #2 on: April 30, 2011, 07:49:56 AM »
   I ended up uninstalling mach and slaving in my old hard drive and using the program from it. The operating system has messed up on the old dive but all the files are still there. It works but I may try copying the files over to the new hard drive later on.

Offline jeremyrockjock

*
  •  39 39
  • Why buy what you can build.
    • View Profile
Re: Recovering from hard drive crash THC300 settings
« Reply #3 on: April 30, 2011, 12:06:53 PM »
I spoke too soon. I think my problem is profile related. My old hard drive files corrupted so I am back at square one. I reloaded mach 3 but I think I remember having to open it with a certain profile for the intial setup for thc. I am running THC300b? maybe, it the cabinet mounted model.

Offline jeremyrockjock

*
  •  39 39
  • Why buy what you can build.
    • View Profile
Re: Recovering from hard drive crash THC300 settings
« Reply #4 on: April 30, 2011, 01:59:24 PM »
After reloading Mach3 I ran the thc300 setup, Then went in and set my motor pins and port address for 2nd port. Also inluts and outputs. Table will move but need calibrated. The torch button in mach with not fire the torch control on the THC300 controller.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Recovering from hard drive crash THC300 settings
« Reply #5 on: April 30, 2011, 04:27:02 PM »
Have you tried to get the xml from the THC vendors? 

Hood

Offline jeremyrockjock

*
  •  39 39
  • Why buy what you can build.
    • View Profile
Re: Recovering from hard drive crash THC300 settings
« Reply #6 on: May 01, 2011, 12:14:05 PM »
Yes, I have installed them as instructed.

THC Mach3 Files


--------------------------------------------------------------------------------

     Downloads


--------------------------------------------------------------------------------

Download the THC300SM3 Zip File here (contains all of the files listed below in a single zip file) updated 6-1-08

THC300

Copy the Bitmap folder into the MACH3/Bitmap/ folder
Copy the THC300SM3.XML and the THC300S.SET files
into the Mach3 folder
Make sure your license file is in the Mach3 folder as well.
 

THC300 set updated 6-1-08
THC300 XML file   Pin settings for both ports
THC300 Screen Snapshots




So now after reinstalled mach several times I have all the motors set right and the table itself is operating fine. I just cannot get te THC to work. I know that the 2nd port is working because the signal for the touch off is working. I just have to torch when I press the torch on/off button in mach3
 

Offline jeremyrockjock

*
  •  39 39
  • Why buy what you can build.
    • View Profile
Re: Recovering from hard drive crash THC300 settings
« Reply #7 on: May 03, 2011, 09:49:50 PM »
Can anyone help? I have no response from the THC300 after installeing again as per vender instructions.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Recovering from hard drive crash THC300 settings
« Reply #8 on: May 04, 2011, 02:15:53 AM »
I dont think anyone can really help unless they have the same machine wired by the same person in the same way. Your best bet would be to trace the wires and make sure you have the correct port and pins set for the connections of the wires.
Hood

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Recovering from hard drive crash THC300 settings
« Reply #9 on: May 04, 2011, 05:06:33 AM »
you do have your spindle relay enabled and set to output1 in spindle setup right?

Ian