Hello Guest it is August 18, 2019, 05:37:33 AM

Author Topic: Help ! "Radial Cut with Zdepth" toolpath from mastercam makes Skip steps ??  (Read 25218 times)

0 Members and 1 Guest are viewing this topic.

I have this problem when cutting sphere using radial cut import from Mastercam toolpath.
no matter how slow the feedrate I choose, it always create loose steps.

is this a compatibility issue or my router setting is not right ?
I use very slow feedrate but still dosn;t solve the loosing steps problem.

anyone experience this ?

help...

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Is your Z axis a lot slower than X and Y?
Try running in Exact Stop mode (G61) and see if it still happens.

Hood
Z might be slower, it's because the ballscrew Z lead is like 1 inch, but X and Y is about 1/8 inch.

now how to set exact stop mode on x y and z ?

I'll try tonight.

I try to set the Step pulse and Dir pulse to 15us, I tought it solved, but it not.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
I think I remember Ray Livingstone having an issue with helical paths when he was using the knee on his mill for the Z axis. The knee was a lot slower than the X and Y and that seems to be the problem if I am remembering correctly. I think he was fine if he worked in Exact Stop for that part of the code but I may be recalling incorrectly.

To set to Exact Stop just insert a G61 in the code just before the problem part of the code  and then a G64 after the problem  code to put it back to constant velocity if required.

Sherline mode may help if you were seeing improvements with the wider pulse but Sherline can only work at 25KHz kernel
Hood

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Just reading again and you said radial paths, is that just X and Y moving  and Z stationary until Z moves down with X and Y stationary? If yes then what I described above is not likely to be your problem but maybe the sherline will help.
Hood
here is the picture of what I'm cutting.

it's radial with Z depth.

I use to use G64/constant stop before, it give me the same result, so I try this smooth const. Vel.

now I realize, this might help you to solve problem.
when the mach3 read gcode lines, it stop for split second before reading to the next line, it's not smooth reading, that's the moment "loosing step" ... I think.
now how the mach reads "stop" momentary ? does my computer too slow ? or need bigger buffer ? CPU ?

« Last Edit: January 04, 2011, 03:57:49 AM by calico »
With such a large lead on the Z axis screw, it may be an acceleration issue on Z. Try lowering the acceleration on the Z axis.

Mike

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
From your descruipyion of the stop at the end of each line of code that sounds like you are using Exact Stop (G61) already.
Do you have backlash comp enabled, if you do switch it off and see if the problem is solved.
Hood
I did try lowering the Z axis acceleration, still the same problem
is this because of the Z ? something got to do with Z that cause this loose steps ?


I use Backlash Comp enable already.

now I'm thinking that my PC is not catching up reading the Mastercam gcode lines.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Please disable the backlash and see if that cures your problem, if it does then you may need to tune the backlash settings better when you re-enable them.
Hood