Hello Guest it is August 17, 2019, 11:37:07 AM

Author Topic: Help ! "Radial Cut with Zdepth" toolpath from mastercam makes Skip steps ??  (Read 25216 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Its set to 20 according to your xml, you may want to increase that.

What rev of Mach are you using?
Hood
I just upgrade the mach to the latest 1 month ago.

increase to 50 will be ok ?

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Terry would likely be able to advise better but try at 200 and see.

Hood
I will do that

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
You do have strange values for steps per unit with the hardware you said you have (Geckos, 5mm pitch and no gearing) If you command a move of 10mm via MDI line does it move 10mm?
Hood
strange, I just check to Genereal config, it's already 200 for look ahead.

yes it move the correct distance up to 0.3 mm accuracy if I command, maybe less.
I'm not really sure it's 5mm.
btw I use 100Khz kernel .. is this too fast for my PC ?
I was using much lower before but give me the same result

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Obviously the xml you attached is not the same one you are using as look ahead is 20 and kernel is 25KHz in it.
Setting the Kernel to 100KHz is not a good thing to do if you dont need it and from your steps per unit you could run no problem at 25KHz so probably best you try that.
Also if you can attach the correct xml it may help if there are config issues.
Hood
jere is the correct one,
sorry for giving you the wrong xml

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
XML looks ok from first glance with the exception of the high kernel, would set that to 25KHz and see if it helps.

For future reference you must have 0.5inch pitch screws on the X and Y and 20mm pitch on Z.

Hood