Hello Guest it is January 17, 2021, 05:48:58 PM

Author Topic: New Lcam with post processor  (Read 15342 times)

0 Members and 1 Guest are viewing this topic.

New Lcam with post processor
« on: August 12, 2006, 10:58:38 PM »
There is a new Lcam with the ability to read a Post file... The Post file can be changed in notepad and I have included an example .pst file for you to play with. There is also a Doc in the Zip file that should help you with the PostVars that you will need to make your post. Please test it and tell me if you think you would like to have other PostVars added and how it works for you. So you can get this on the FTP server under LazyCam/LazyCam 2.60 With Post Doc's.zip

Thank you :) and sorry I can't tell you more... I and burnt out and need to get some rest  ::)

Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline John S

*
  •  111 111
  • Nottingham England
    • View Profile
Re: New Lcam with post processor
« Reply #1 on: August 13, 2006, 05:57:41 PM »
Sorry Brian.
downloaded it and opened a file.
Selected a contour and it came up correct.

Went thru altering depth feeds etc but as soon as I alter the fisrt item LC freezes and locks up.

John S.

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: New Lcam with post processor
« Reply #2 on: August 13, 2006, 07:53:43 PM »
Hi, Brian

It locked up when I entered Start Depth and Final Depth in Layer Control column's only.

Been working on Plasma with no Z hight

M3/M5 generates first Dot/Pearce then leaves the remaining 4 with on Dot/Pearce plas/post options 0,0,1,1,20,1 not default..

Manual file mode seem's to work in any sub. Dir. now and post's code to the proper Dir. as assigned in LC.

But it will not update Mach3 even if there all in the same sub. Dir. even when its \Mach3.

Auto file create still post's code in \Mach3 as Gcodefilename.tap, not in \Mach3\Gcode where it should be, but will update Mach3 with new file.

Also it will not increment further file's with the same name, test1.tap, test2.tap as it did some time back, any way I think it did.

Working on some of the post's for LC option's, I have a way to go hear, could you post an example the way it could / would be.

Just some info so you wont get board.

Thank's Chip
« Last Edit: August 13, 2006, 10:07:10 PM by afn09556 »
Re: New Lcam with post processor
« Reply #3 on: August 14, 2006, 08:10:53 AM »
John and Chip,
I have done some testing and I can't get it to happen to me :( Could you please tell me every step? I would love to get this fixed

Thankyou
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: New Lcam with post processor
« Reply #4 on: August 14, 2006, 01:31:49 PM »
Hi, Brian

This morning it was working fine, so I deleted the LC. XML should have re-named it o-well dumb dum me, it's back to freezing up the screen.

On in ital load of LC it doesn't generate an XML that's probably normal  at this time it's freezing as before, even with a xml, I have close it and restart it have try-ed to get it to work and dup. the change that made it work.

Hears my non working xml maybe this will help, send me your working xml to try hear.

Loaded the Dxf I posted  in LC, I can set / change all the item's in Layer Control Except Final Depth and Start Depth if thy are changed and OK is clicked the screen freezes and the only way to get out is Windows Task Manager End Task.

Thank's Chip

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: New Lcam with post processor
« Reply #5 on: August 14, 2006, 02:54:47 PM »
Hi, Brian

I have found that if I load a dxf file and set the Per Pass value to .5 that I can set Final Depth and Start Depth without lockup.

At this point I can change the Per Pass back to Default Value of 1 and seem to have no lockup problem.

This is without closing LC and restarting, once shutdown and restarted it will freeze again with out changing the value in Per Pass.

If I change Per Pass to .5 close the window then change it back to 1 default value again then the problem is gone till restart of LC again.

BTW the processer is at 100% when locked up, window's running, End Task will shut LC down  .

Thank's Chip

« Last Edit: August 14, 2006, 03:03:04 PM by afn09556 »

Offline John S

*
  •  111 111
  • Nottingham England
    • View Profile
Re: New Lcam with post processor
« Reply #6 on: August 14, 2006, 06:06:04 PM »
Brian,

Here's the sequence.
Load LC.
Open x3beam.dxf
Accept defaults on load options
Click outer shape
set :-  [ working in mm ]
Depth 10.0
feedrate 250.0
passdepth 5.0
plunge 100.0
Rapid hight 3.0
spindle 2000.0
start depth 0.0
tool 11

Post code and x3beam.tap is generated. Close LC and go to Mach3
this is the first part of the code. Mach3 barfs on line 45 no feed rate ?
Note rapid hight is 0.1 and depth is 0.0 ?

Just noticed only one feed has been applied where it specifies two 100 and 250.

N5 (File x3 beam )
N10 (File Posted in Mill Mode)
N15 (Monday, August 14, 2006)
N20 G90G80G40 G91.1
N25 G0 Z0.0000
N30    X13.6513 Y-23.4014
N35 M3 S0
N40    Z0.1000
N45 G1 Z0.0000  F0.00
G42
N50 G2 X16.8483 Y-21.7991 I1.1969 J1.6023
N55 G40
N60    X13.6513 Y-23.4014 I-2.0000 J0.0000
N65 G0 X26.0223 Y-15.7130
N70    Z0.1000
N75 G1 Z0.0000
N80 G2 X32.9738 Y-14.6854 I15.7479 J-82.5040
N85    X34.9006 Y-17.6993 I0.2095 J-1.9890
N90 G3 X33.7918 Y-22.3856 I6.8696 J-4.0998
N95 G2 X31.4550 Y-24.5028 I-1.9946 J-0.1466
N100 G3 X20.4959 Y-23.9733 I-7.6099 J-43.8283
N105 G2 X18.3464 Y-21.9136 I-0.1506 J1.9943
N110 G1 X17.9478 Y-20.1734
N115 G2 X19.1810 Y-17.3181 I1.7711 J0.9290
N120 G40
N125    X26.0223 Y-15.7130 I22.5892 J-80.8990
N130 G0 X39.3764 Y-25.0037
N135    Z0.1000
N140 G1 Z0.0000
N145 G2 X45.7702 Y-21.7991 I2.3938 J3.2046
N150 G40
N155    X39.3764 Y-25.0037 I-4.0000 J0.0000
N160 G0 X37.8802 Y-27.0066
N165    Z0.1000
N170 G1 Z0.0000
N175 G2 X48.2702 Y-21.7991 I3.8900 J5.2075
N180 G40
N185    X37.8802 Y-27.0066 I-6.5000 J0.0000
N190 G0 X57.5182 Y-15.7130
N195    Z0.1000
N200 G1 Z0.0000

« Last Edit: August 14, 2006, 06:07:59 PM by John S »
Re: New Lcam with post processor
« Reply #7 on: August 14, 2006, 09:57:02 PM »
Cool I will work on that tomorrow :)

Thank you
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: New Lcam with post processor
« Reply #8 on: August 14, 2006, 10:26:03 PM »
Hi, Brian

In the file below the G81 code is missing M3's before the M5's 4 places, this was done in plasma mode with 0.0.1.1.20,1 in plasma window.

N1 (File test55Dotpolyline )
N2 (File Posted in Plasma Mode)
N3 (Monday, August 14, 2006)
N4 G90 G80 G40 G91.1
N5 G0  Z0.0000
N6 G0  X0.0000  Y0.5020
N7 G0  Z0.0000
N8 M3 S0(PLasma On)
N9 G1  Y1.0040
N10  X1.0000
N11  Y0.0000
N12  X0.0000
N13  Y0.5020
N14 M5 (Plasma Off)
N15 G0  Z0.0000
N16 G0  X1.6996  Y1.6058
N17 G0  Z0.0000
N18 M3 S0(PLasma On)
N19 G2  X2.5020  Y2.0080  I0.3004  J0.4022
N20  X1.6996  Y1.6058  I-0.5020  J0.0000
N21 M5 (Plasma Off)
N22 G0  Z0.0000
N23 G0  X3.0000  Y1.0040
N24 G0  Z0.0000
N25 M3 S0(PLasma On)
N26 G1  X4.0000  Y2.0080
N27  Y0.0000
N28  X2.0000
N29  X3.0000  Y1.0040
N30 M5 (Plasma Off)
N31 G0  Z0.0000
N32 G0  X3.0000  Y1.2500
N33 G0  Z0.0000
N34 M3 S0(PLasma On)
N35 G81  X3.0000  Y1.2500  Z0.0000  R0.0000  F11.00
N36 M5 (Plasma Off)
N37 X3.7500  Y2.0000
    M3;--------------------------------------------------M3 missing
N38 M5 (Plasma Off)
N39  Y2.7500
    M3;--------------------------------------------------M3 missing
N40 M5 (Plasma Off)
N41 X0.2500
    M3;--------------------------------------------------M3 missing
N42 M5 (Plasma Off)
N43  Y1.5000
    M3;--------------------------------------------------M3 missing
N44 M5 (Plasma Off)
N45 G80
N46 G0  Z0.0000
N47 G0  X4.0000  Y2.2500
N48 G0  Z0.0000
N49 M3 S0(PLasma On)
N50 G1  Y2.7500  F111.00
N51 G3  X3.7500  Y3.0000  I-0.2500  J0.0000
N52 G1  X0.2500
N53 G3  X0.0000  Y2.7500  I-0.0000  J-0.2500
N54 G1  Y1.5000
N55 G3  X0.2500  Y1.2500  I0.2500  J-0.0000
N56 G1  X2.7500
N57 M5 (Plasma Off)
N58 Z0.0000
N59 M5 M9
N60 X0.0 Y0.0
N61 G40 G80M30

Thank's Chip
 

Offline John S

*
  •  111 111
  • Nottingham England
    • View Profile
Re: New Lcam with post processor
« Reply #9 on: August 15, 2006, 03:02:43 AM »
Brian,

Reading my code again there is no G21 or any way to select it and it hasn't selected a tool.


John S.