Hello Guest it is November 18, 2019, 09:06:56 PM

Author Topic: Is it true about Galil plugin?  (Read 19605 times)

0 Members and 1 Guest are viewing this topic.

Re: Is it true about Galil plugin?
« Reply #40 on: July 25, 2008, 06:09:21 AM »
Sure...

Me too..

But if I hit ref all before a program is loaded it works every time.. If it is after a program and I hit ref all sometimes it works like a charm and sometimes it don't.
Hey THANKS 4 all the help in advance. I'll need more than you'll ever expect!!!


www.cravenpottery.com
Re: Is it true about Galil plugin?
« Reply #41 on: July 25, 2008, 06:58:55 AM »
Mmmm, That is interesting. Mine seems to do it at any point and then sometimes it works fine?????

I am going to try a different PC and see what happens. I am using one of the MachMotion PC's now.

Did yours get better after updating the software to R3.041?

Darek
Re: Is it true about Galil plugin?
« Reply #42 on: July 25, 2008, 09:50:43 AM »
Hello,
That is odd... Could you please see if you jog before you home if that will fix it? I am thinking that we have a mode in the Galil that is not getting set and jogging may set it :)

Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Is it true about Galil plugin?
« Reply #43 on: July 25, 2008, 06:24:25 PM »
Yes and no? But me changing computers would be a headache and a half.....

Brian I will try that as soon as I get time away from my office.pluuuu...
Hey THANKS 4 all the help in advance. I'll need more than you'll ever expect!!!


www.cravenpottery.com
Re: Is it true about Galil plugin?
« Reply #44 on: July 27, 2008, 08:50:36 AM »
Brian,

The travels are long on this machine so we usually jog it close to the switches before homing. When it hangs I have to exit  and restart Mach3 before it will attempt to home again. I have to jog off the home switch at this point to re-home. I am using external buttons through Modbus, brains and OEMButtons to jog, don't know if that makes a difference.

Pointcloud,

I read where you have the PCI card. I am using the DMC-2183 with ethernet connection. Trying a different PC will be allot easier for me.

Darek

Re: Is it true about Galil plugin?
« Reply #45 on: July 27, 2008, 11:12:43 AM »
That seems odd.. I would think that may be a noise problem.. we could make a bit of code to test the inputs and tell if they ever see the input go high...
Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Is it true about Galil plugin?
« Reply #46 on: July 27, 2008, 02:44:55 PM »
Just ESC instead of exiting? That way you will not loose positioning? Or your offsets????

Still have not made it back to the shop....
Hey THANKS 4 all the help in advance. I'll need more than you'll ever expect!!!


www.cravenpottery.com
Re: Is it true about Galil plugin?
« Reply #47 on: July 29, 2008, 03:39:03 PM »
ESC will let it jog again but it will not try to home again untill I exit Mach. If I try home after ESC it will not jog until I hit ESC again.

I will check for noise also. I am using the opto board which specs 1mA for input current, approximately 2v but I have found they will trigger at lower voltages.

Darek
Re: Is it true about Galil plugin?
« Reply #48 on: July 29, 2008, 03:51:42 PM »
Sounds to me like I should be able to fix it in code too.. You should be able to press Escape and have that fix it!...
I need to take the Galil test board down to the router and hook it up.. Could you please tell me what you are doing to make it fail?

Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Is it true about Galil plugin?
« Reply #49 on: July 29, 2008, 05:32:33 PM »
Wow.. Esc worked for me?

I will be running a part Friday, I hope... So I'll see what happens in my case...



Hey THANKS 4 all the help in advance. I'll need more than you'll ever expect!!!


www.cravenpottery.com