Hello Guest it is December 06, 2019, 12:40:50 AM

Author Topic: Mach causing Galil to shut off motors  (Read 3308 times)

0 Members and 1 Guest are viewing this topic.

Mach causing Galil to shut off motors
« on: August 11, 2008, 12:35:11 PM »
New problem that just started this weekend. I have a Galil 1842 and Mach, was working fine but now when I try to jog x or y on the main page, or try to run a program, I get the message "begin not valid with motor off" or something close. I go to MDI page and I can move the x and y. I can also move them fine in Smart Terminal. When this happend on the main page, the X DRO shows about 1/2 an inch of movement, but the motor instantly shuts off and there is no motor movement at all. This just started all of a sudden and I am sure I have not changed any settings. I verify that the motors are shut off in Smart Terminal, I have to do an SH to get them back on. It doesnt seem to affect the Z axis. I can still jog it from the main page. Somehow, Mach is giving Galil the MO command on x and y as soon as I try to jog or run a program.
Re: Mach causing Galil to shut off motors
« Reply #1 on: August 15, 2008, 02:48:43 PM »
Still having the same problem. Last night, when I forst started Mach, I could jog X and Y and Z just fine. As soon as I tried to run a program, X DRO said it moved .53" and immediately shut the x motor off without it moving at all. It also diables my X drive, but no others. Then after doing a couple of resets, nothing would work when running a program. I could not even jog the Y axis, but I could jog Z. Meanwhile, I can go into smart terminal and run any motor I like just like nothing is wrong.
I doubt anyone else has seen this. I am tempted to format the hard drive and start all over. 
Re: Mach causing Galil to shut off motors
« Reply #2 on: August 18, 2008, 12:05:35 PM »
For anyone who might benefit.
I found I had an encoder on my X axis acting up. Mach tried to accelerate that axis and the Galil shut the motor off because of too large an encoder error. I played with the motor in Smart Terminal and discovered this to be the case. At low speeds and accels, it worked fine, but as the accel increased, I would lose encoder pulses. I have US Digital encoders, and i re-adjusted the positioning of the disk and the problem went away. 
One more thing I have discovered, I cant use GalilTools with Mach. GalilTools requires a different driver and Mach would not recognize the card. I rolled back to the Smart terminal driver and Mach sees the Galil fine.
Hope this info helps someone else.

Offline Chaoticone

*
  • *
  •  5,633 5,633
  • Precision Chaos
    • View Profile
Re: Mach causing Galil to shut off motors
« Reply #3 on: August 18, 2008, 12:59:32 PM »
Thanks for those tips. Another useful user posting useful information.  :)

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!