Hello Guest it is October 24, 2019, 01:12:16 AM

Author Topic: How to enable soft limits? Also note: Deaf people can't hear the video tutorial.  (Read 18382 times)

0 Members and 1 Guest are viewing this topic.

Offline birdbrain

*
  •  41 41
  • Stupidity, beyond belief!
    • View Profile
I know this is gonna be simple but I can't figure it out. Where, exactly (which screen, which tab etc.) can I enable the soft limits?
I would love to benefit from the video tutorials which I'm sure cover this but I'm deaf and without sound the tutorials don't make any sense!

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
The soft limits are enabled from the main screen, there is a button near the DROs.
 You will also need to set the dimensions for your soft limits, this is done from the Config menu then down to the Homing and limits page.
Depending on where your home switches are and what type of machine you have will determine how you set them up but I will give you an example for the normal setup.
For the X and Y minimum you set that to 0
For Z Max you set to 0
X and Y max sre set to the travel for these axis
Z Min is set to the axis travel but it should be a negative number.

You can also set up a slow zone, this is the distance that Mach will start to slow down so that it doesnt overtravel when reaching the soflimits, you will have to find out the perfect distance for your individual machine as all machines will vary due to differences in acelleration, velocity and even machine weight and motor size.

If you are not clear or have a different setup just post again and I will help all I can.

Hood

Offline birdbrain

*
  •  41 41
  • Stupidity, beyond belief!
    • View Profile
Thanks Hood.
That's a big help. Just didn't know where to find the button.

Different subject:  ???
Is it possible to reference just one axis to it's home switch?
It's easy to reference "all home" but I have a rotating A-axis that needs to be referenced when stock is changed. I don't always want to re-reference X, Y and Z as well.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
If you go to the diagnostics page you will see buttons to reference each axis individually. If you wanted you could alter the standard screen to have these buttons on the main page or for that matter you could alter the screen and just add one button to reference the A Axis. To alter or make a complete custom screen you use Screen4 which you should find in the Mach3 folder, if its not there then you can get it from the downloads page.
Hood

Offline birdbrain

*
  •  41 41
  • Stupidity, beyond belief!
    • View Profile
Thanks, again, Hood.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
no problem :)
Hood said it correctly above but i'd like to chime in and add this .... use zero as hood noted, bump your limits in the plus and write them down and use these with enough adjustment for lets say just touching limit without tripping ! then give yourself some decelleration room and set a slow zone that is not too great or small and i used about .200" ! after this is done it is real neetoe in that you can jog right up to your limits without tripping them for whatever reason. one more item ! the softlimit must be off to home referance machine then don't forget to turn it back on ! also after setting all this up and it is working perfect do two more things for assurace. set the "normal function" and then do a full system shut down by the book, no shortcuts, restart and double check function. I found that there are a few things that don't get updated into the xml till mach and pc are properly shut down and resarted, plus i feel much better knowing it is as it should be with PROOF !  MACH is a dream cum true !
CRUISER
  Don

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
The softlimits dont need to be off to home if you have them set correctly ;)

Hood
REALY !  If i try to referance home my IH mill with the softlimit active, and mine is set to be active at power up, then i receive an alarm till i turn it off and re-start the referancing proceedure. So, aparently I missed something setting mine up. Could you elaberate some on what must be differant so that it will ignore the softlimit while referancing home. I would certainly appreciate this as it does at times get to be a little agravating when i forget to turn it off or back on after !  Thanks !
CRUISER
  Don

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
That is because you have not set zero as your min for X and Y and for Max for Z.
The way Mach works is you home, it hits the switches, reverses and then when the switches close again its homed. So your zero position is when the switches are closed. The slow zone is so that when you rapid (or feed) towards a limit Mach will be able to decelerate and stop exactly on zero and not go that fraction further and hit the limits. With a machine with slow acceleration you may have to set up a big slow zone, a machine such as my new mill with AC servos will be able to decelerate from rapid to zero in under a mm I would think so the slow zone will be small on it.
 Because you have your min soflimits greater than machine zero Mach will not allow you to hoime with the softlimits enabled. This is because it would have to go beyond the soflimts you have set to get to the home position.

Hood