Hello Guest it is October 22, 2019, 08:05:33 AM

Author Topic: How to enable soft limits? Also note: Deaf people can't hear the video tutorial.  (Read 18378 times)

0 Members and 1 Guest are viewing this topic.

AWW ! I understand, I tried to set it up like that at first but it didn't work out for some reason. I eventually ended up where i'm at now. As i recall i ended up on the wrong side of the limit switch and faulted ! but it was quite a while back and i disremember details ! Actually tho, i like it this way. I don't need the soft limit set exact at zero and i can run up to soft, turn off soft, re-ref home, drive off limit, turn back on and run from there if  i have a questionable situation and need to dbl chk ref. So, I think i'll leave well enough alone and keep my yap shut for a while again, As i recall it was really touchy setting up that way as it must be accurate all the way down to the nannobuthair or it will fault out. And my presant setup works for me ! I can see tho that if set exactly that your way would be smooth too !  Thanks Hood and keep up the good work, your a definate possitive influance here and i do indeed appreciate all i see from you ! CHEERS !
CRUISER
  Don

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Cruiser
 If you set up a slow zone it will not stop at that point, it will just start to slow down when it reaches the slow zone but will continue at a reduced (and reducing) rate until it reaches the zero position. The easiest way I found to set the slow zone was to set it quite large at first then jog away and then jog back at full rapid and see if it hits the limits, if it doesnt reduce the slow zone and try again. You will soon find out where your best position is. If you set it too large you still wont compromise table movement, just it will start to slow down sooner.
 If you decide  that you want to keep it your way then I think you could probably edit your Ref All button to disable the softlimits first, do the Home on each axis, you would then need it to move off the limits by the amount you have set for your min (G28) would do that and then finally enable the SoftLimits again. That way you wouldnt have to remember to re enable the softlimits after a home move.
 Not tried it as the way Mach does it is good for me but if I get a chance I will try it and see.
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Cruiser
 If you want to keep the setup you have you can put this in your RefAll button and test it out. Seems to work fine here but be aware I am not a VB Ghuru so be ready with the E-Stop just in case ;)
 You will need to go to the Homing and limits and set values in the G28 box for each axis you have, the values will need to be whatever your soft mins for X and Y and SoftMax for Z are set to.
 The VB should look to see if the softlimits are enabled if they are they will turn them off, then will reference each axis in turn and then move to the G28 position before turning the SoftLimits back on. If for some reason the Softlimits are off it will do the homing, move to G28 position and turn the SoftLimits on.

Hood

If GetOemLED(23) Then
  DoOemButton(1029)
  DoButton( 24 )
  DoButton( 23 )
  DoButton( 22 )
  DoButton( 25 )
  Code"G28"
 While IsMoving
 Wend
  DoOemButton(1029)
 Else
  DoButton( 24 )
  DoButton( 23 )
  DoButton( 22 )
  DoButton( 25 )
  Code"G28"
 While IsMoving
 Wend
  DoOemButton(1029)
 End If
« Last Edit: July 12, 2008, 06:14:24 PM by Hood »
When I test if my machine will really stop at exactly 0.00 or my max, it kinda works. For example I move the x axis to the right (starting for 0.00), it moves, as well as the DRO on MAch3, then when I move it to the left, (back to the original position which is 0.00), it doesn't move. It just stays on that position, while the DRO moves to 0.00. SO yeah the limits work and stuff. But it doesn't apply to the machine.

When I try and do it again, the 0.00 position is not on the old place anymore since I moved it to the right and it didnt go back, SO it just keeps moving to the right and not moving when i move it to the left, but Mach3 is thinking that it moved to 0.00 when in reality it didnt. So the motor just kept moving right without going back.

This is happening to all the axes.

Oh and it says on the bottom
"Soft Limits System Movement Aborted"

Any ideas?